Page 1 of 1

The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 12:28 am
by Axolotista
Hello community!

I am a total ignorant about Linux, but I am slowly learning. But today I have two problems that are way beyond my reach. Please help! My livelihood depends on it.

Initial problem:
A couple of months ago we had an unexpected electricity outage in my home and my computer was on while the power went and came over and over in a short period of time. The computer restarted automatically and partially several times and since then I cannot update packages or anything through the updated program.

I tried to fix it but I get this:
E:The package xserver-xorg-core needs to be reinstalled, but I can't find an archive for it.

The machine otherwise seems to work well and I was too busy to dive into research like now in order to fix it.

Second problem:
I am trying to install Davinci Resolve 16 basic free version software but once I did, it says I need to update my graphics card.
The program comes with a pdf how to install document and has detailed instructions about updating graphics drivers and such. But I cannot proceed.

My system info from the inxi comand is

Code: Select all

gigabyte@gigabyte-H270M-D3H ~ $ inxi -Fxxxzr
System:    Host: gigabyte-H270M-D3H Kernel: 4.4.0-189-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Gigabyte product: H270M-D3H v: Default string
           Mobo: Gigabyte model: H270M-D3H-CF v: x.x
           Bios: American Megatrends v: F8d date: 03/09/2018
           Chassis: Default string type: 3 v: Default string
CPU:       Quad core Intel Core i5-7500 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27264
           clock speeds: min/max: 800/3800 MHz 1: 893 MHz 2: 1099 MHz
           3: 799 MHz 4: 844 MHz
Graphics:  Card: NVIDIA GP108 [GeForce GT 1030]
           bus-ID: 01:00.0 chip-ID: 10de:1d01
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GT 1030/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 Intel 200 Series PCH HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
           Card-2 NVIDIA GP108 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0fb8
           Sound: Advanced Linux Sound Architecture v: k4.4.0-189-generic
Network:   Card-1: Intel Ethernet Connection (2) I219-V
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6 chip-ID: 8086:15b8
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR9227 Wireless Network Adapter
           driver: ath9k bus-ID: 03:01.0 chip-ID: 168c:002d
           IF: wlp3s1 state: up mac: <filter>
Drives:    HDD Total Size: 2128.4GB (5.0% used)
           ID-1: /dev/sda model: ST2000DM005 size: 2000.4GB serial: Z9801W37
           ID-2: /dev/sdb model: ADATA_SU800 size: 128.0GB serial: 2H2920067196
Partition: ID-1: / size: 102G used: 84G (87%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 17.13GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:38C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb http://packages.domain.com/ xenial main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ppa-xenial.list
           deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/stebbins-handbrake-releases-xenial.list
           deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
           deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
Info:      Processes: 223 Uptime: 3 min Memory: 1379.5/16007.7MB
           Init: systemd v: 229 runlevel: 5 default: graphical.target
           Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35 
gigabyte@gigabyte-H270M-D3H ~ $ [/b]  

I think I have to fix the first problem to then get to the second one. Or what do you guys think? Please help!

Thanks in advance

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 1:31 am
by zcot
to reinstall a package you can use the command: apt reinstall <exact-package-name-here>

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 1:44 am
by Axolotista
Hi!
Thank for replying. :)

I tried and got

Code: Select all

gigabyte@gigabyte-H270M-D3H ~ $ apt reinstall <xserver-xorg-core>
bash: error sintáctico cerca del elemento inesperado `newline'
gigabyte@gigabyte-H270M-D3H ~ $ 
A syntactic error :oops:

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 3:15 am
by JOPETA
Just apt reinstall xserver-xorg-core, w/o <>. :wink:

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 3:18 am
by kukamuumuka

Code: Select all

sudo apt-get --reinstall install xserver-xorg-core

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 12:19 pm
by Axolotista
Thanks for replying and for the syntactic patience! :)

However, once I set the command into the terminal, the message I get is the same as at first: that the file xserver-xorg-core is missing and cannot be reinstalled.

Code: Select all

 Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: El paquete xserver-xorg-core necesita ser reinstalado, pero no se encuentra el archivo para ello.
Translation:
Reading list of packages ... done.
Creating dependence tree
Reading state info... Done.
E: The xserver-xorg-core package needs to be reinstalled, but the file could not be found.

Any idea about how and from where I can find this file?

And, since last night, I lost audio completely and the updater admin program no longer shows me any of the 20+ updates it used to show me. I think this is getting worse quickly.

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 12:48 pm
by kukamuumuka
What is the result for the next command?

Code: Select all

apt-cache policy xserver-xorg-core

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 1:05 pm
by Axolotista
This:

Code: Select all

gigabyte@gigabyte-H270M-D3H ~ $ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Instalados: 2:1.18.4-0ubuntu0.7
  Candidato:  2:1.18.4-0ubuntu0.7
  Tabla de versión:
 *** 2:1.18.4-0ubuntu0.7 100
        100 /var/lib/dpkg/status
Translation:
Instaled: 2:1.18.4-0ubuntu0.7
Candidate: 2:1.18.4-0ubuntu0.7

Version Table
*** 2:1.18.4-0ubuntu0.7 100
100 /var/lib/dpkg/status

What just happened?

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 1:21 pm
by kukamuumuka
Run

Code: Select all

sudo dpkg --configure -a
sudo apt-get -f install

Re: The package xserver-xorg-core needs to be reinstalled

Posted: Thu Jan 14, 2021 2:35 pm
by Axolotista
Ok, it just asked for my password and that was it.