mic does not work with Skype. Please help me.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 6
Joined: Fri Dec 27, 2019 7:18 am

mic does not work with Skype. Please help me.

Post by MartinA »

A year or so ago, Skype worked fine. Since then I transferred my hard drive to a different model Acer Veriton computer. I did not try Skype after the transfer but everything else worked as before.

Now I cannot get Skype to hear my voice via the mic. If I send a voice test message via Skype no sound comes back. I have selected the correct mic input source on Skype. I tried reinstalling Skype but same result. I know the mic is ok because on Linux's 'sound settings input' display, the input level bargraph moves when I talk.

Please help me with any suggestions.
Thanks, Martin

Following advice I saw on this forum I obtained the following info:

Code: Select all

$ inxi -Fxxrzc0
  Host: mainPC Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.4 wm: muffin dm: LightDM 
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
  Type: Desktop Mobo: Acer model: Veriton M2610G serial: <filter> BIOS: Acer 
  v: P01-B3 date: 10/12/2012 
  Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24744 
  Speed: 1597 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1598 2: 1596 
  3: 1597 4: 1596 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0102 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Desktop v: 3.3 Mesa 19.0.8 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:1c20 
  Sound Server: ALSA v: k4.15.0-54-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: 2.3LK-NAPI port: d000 
  bus ID: 06:00.0 chip ID: 10ec:8168 
  IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Ralink RT2870/RT3070 Wireless Adapter type: USB 
  driver: rt2800usb bus ID: 2-1.5:6 chip ID: 148f:3070 
  IF: wlx48022a40f773 state: down mac: <filter> 
  IF-ID-1: bridge0 state: down mac: <filter> 
  Local Storage: total: 1.37 TiB used: 186.84 GiB (13.3%) 
  ID-1: /dev/sda model: SPCC Solid State Disk size: 238.47 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: Seagate model: ST3750525AS size: 698.64 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-3: /dev/sdc vendor: Western Digital model: WD5000AZRX-00L4HB0 
  size: 465.76 GiB speed: 3.0 Gb/s serial: <filter> 
  ID-1: / size: 232.08 GiB used: 186.76 GiB (80.5%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 703.5 MiB used: 77.4 MiB (11.0%) fs: ext4 dev: /dev/sda1 
  ID-3: swap-1 size: 980.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2 
  System Temperatures: cpu: 30.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tina main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/rolfbensch-sane-git-bionic.list 
  1: deb http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
  Processes: 237 Uptime: 6m Memory: 7.73 GiB used: 1.44 GiB (18.6%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 
User avatar
Level 22
Level 22
Posts: 16688
Joined: Mon Jun 12, 2017 8:39 pm

Re: mic does not work with Skype. Please help me.

Post by MrEen »

Hi MartinA,

Let's start by making sure the correct input is the default with this command:

Code: Select all

pacmd list-sources
Post Reply

Return to “Newbie Questions”