home partition and Mint 7 XFCE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 5
Joined: Tue Aug 11, 2009 6:28 am
Location: Mallorca. Spain

home partition and Mint 7 XFCE

Postby xanin » Fri Oct 09, 2009 5:14 pm

I just can't access my files in the home partition after installing Mint 7 XFCE. The files are there because the space in the partition is still taken, and I obviously didn't format my home partition when installing, but after opening home as root they are nowhere to be seen. I also tried using the live CD, but no success either.

Could someone help me with this?


User avatar
Level 12
Level 12
Posts: 4418
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: home partition and Mint 7 XFCE

Postby vrkalak » Fri Oct 09, 2009 9:44 pm

I'm having kinda the same problem, but not in LinuxMint.

I am creating a new Debian 6.0 Squeeze - Xfce Edition from the basic Debian Core, and I have a separate /home partition,
as well as, partitions for the other Linux OS distros. (LinuxMint included) (I'm still a n00b with Xfce)

I can find the various Partitions in gparted, but I can't mount them in Xfce?
They show up in Lilo (boot manager) ... I can open them, but not 'mount' them on the Xfce desktop?

Is this an Xfce specific 'bug' ? How can we get around it? Is there a 'work-around'?
How can we 'mount'/'unmount' the other OS and /home in Xfce?
:: Debian-Sid (Xfce/Fluxbox) :: LinuxMint-18 (LTS) LXDE w/Openbox ::
Registered Linux User: #497031 :: My DeviantART Page

Level 1
Level 1
Posts: 5
Joined: Tue Aug 11, 2009 6:28 am
Location: Mallorca. Spain

Re: home partition and Mint 7 XFCE

Postby xanin » Wed Oct 28, 2009 12:08 pm

I decided to reinstall Mint xfce7 without using that partition as home, but now I can't even mount it. I can see it in GParted, but I get an error message "Failed to mount "partition", the enclosing drive for the volume is locked".

I can actually open it from Windows using Ext2 IFS, but just cannot see any of my old files, only the newly home files and folders from the previous Mint xfce7 install. The thing is, in GParted I still see the partition with 46GB used while the accessible files add up tu only 4GB. I tried using PhotoRec, but all that it did recover were files even older than the ones I'm missing and I did do delete them.

Very confusing for me, but I can only think that all my old files must be still there within those 46GB of used space.

Any help would be greatly appreciated,


Level 1
Level 1
Posts: 1
Joined: Wed Oct 28, 2009 1:10 pm

Mint 7 XFCE: ntfs drives icons disappeared from desktop

Postby Andromeda » Wed Oct 28, 2009 1:37 pm

Hello to everybody.
This is my very first message (so please be sweet). I am sure to find intelligent people and I hope to find a solution for the problem I have experienced.

A couple days ago I installed latest Mint 7 Xfce on a hard drive dual booting with Windows Xp. My machine also has a slave hard drive NTFS formatted.

After installation everything seemed to work o.k. and the icons for ntfs volumes were shown on desktop (as it always happened for the older releases). Then, after a reboot they have simply disappeared from desktop!!
I can find the volumes in home/media nad open them and navigate into them but only from home/media. I mean the icons for ntfs drives on my desktop are gone!

That's frustrating, since I haven't done nothing special but downloading a couple softwares (Skype, Opera) from Synaptic and changing the system locale to my mother tongue. But no deep changes at all.

Mint disk seems to be set o.k.
So what may be happened? Any help will be obviously appreciated and help maybe somebody else.

Thanks in advance, bye.

Level 5
Level 5
Posts: 574
Joined: Fri Feb 13, 2009 7:07 pm

Re: home partition and Mint 7 XFCE

Postby StanTheMan » Thu Oct 29, 2009 6:34 pm

When you install a Linux distro with a datta partition monted on /home , your UserName account will have read and write access ONLY to the /home/UserName directory , and NOT to the rest of the /homne directory.
To fix that you have to re-set the permissions to /home by selecting a GROUP name and making your UserName account a member of that SROUP.
The group could be the same as your UserName , or it could be another group word such as ' users ' .

drwxrwxr-x root users xxxxxx xxxxxx /home

Here the /home directory has read and write to Root , read and write to the group users , read and execture to others. Your UserName set as a member of the grouup=users allows you to read and write to the whole mounted /home partition.

Return to “Newbie Questions”