Fallback mode when I view or edit photos

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Fallback mode when I view or edit photos

Post by kelevra »

I am having the same issue with my install. All was well until recent updates. I can replicate the issue when I view or edit photos. I don't mean to steal this thread but there appear to be a few threads already and I don't have a Nvidia card installed. Here are my specs:

Code: Select all

Kernel: 5.4.0-65-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 dm: LightDM 1.30.0 
  Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Pro 6305 SFF 
  v: N/A serial: <filter> Chassis: type: 4 serial: <filter> 
  Mobo: Hewlett-Packard model: 1850 serial: <filter> UEFI: Hewlett-Packard 
  v: K06 v02.77 date: 03/22/2018 
CPU:
  Topology: Dual Core model: AMD A4-5300B APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 1024 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 13575 
  Speed: 1822 MHz min/max: 1400/3400 MHz boost: enabled Core speeds (MHz): 
  1: 1405 2: 1406 
Graphics:
  Device-1: AMD Trinity 2 [Radeon HD 7480D] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus ID: 00:01.0 chip ID: 1002:9993 
  Display: x11 server: X.Org 1.20.9 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.4.0-65-generic LLVM 11.0.0) 
  v: 4.3 Mesa 20.2.6 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: AMD Trinity HDMI Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:01.1 chip ID: 1002:9902 
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k5.4.0-65-generic 
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM5761 Gigabit Ethernet PCIe vendor: Hewlett-Packard driver: tg3 v: 3.137 port: f100 bus ID: 03:00.0 
  chip ID: 14e4:1681 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: D-Link System WUA-1340 type: USB driver: rt73usb bus ID: 1-3:3 
  chip ID: 07d1:3c04 
  IF: wlx0015e9f7b4d7 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 74.23 GiB (15.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: 00WD scheme: GPT 
Partition:
  ID-1: / size: 456.96 GiB used: 74.22 GiB (16.2%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 8.2 C mobo: N/A gpu: radeon temp: 0 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://muug.ca/mirror/linuxmint/packages ulyssa main upstream import backport
  2: deb http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu focal main restricted universe multiverse
  3: deb http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu focal-updates main restricted universe multiverse
  4: deb http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 173 Uptime: 10h 51m Memory: 7.05 GiB used: 1.48 GiB (21.0%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 
Any help would be greatly appreciated.
Last edited by kelevra on Sun Feb 21, 2021 2:05 am, edited 2 times in total.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
User avatar
Moem
Level 21
Level 21
Posts: 12575
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Linux Mint issue when I view or edit photos

Post by Moem »

kelevra wrote:
Sat Feb 20, 2021 1:04 pm
I don't mean to steal this thread
Mod note:
Good! Hang on to that thought, it's a good one. :wink:
I have split off your new question into a separate topic; we do not re-use existing topics here. Thanks for your understanding!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
SMG
Level 11
Level 11
Posts: 3737
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint issue when I view or edit photos

Post by SMG »

What were the recent updates you installed? Check in Update Manager > View > History of Updates.
What error messages or crash reports are you seeing in the System Reports app?
What app are you using to view/edit photos?
LM20.1 Cinnamon
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Re: Linux Mint issue when I view or edit photos

Post by kelevra »

Moem wrote:
Sat Feb 20, 2021 1:49 pm
kelevra wrote:
Sat Feb 20, 2021 1:04 pm
I don't mean to steal this thread
Mod note:
Good! Hang on to that thought, it's a good one. :wink:
I have split off your new question into a separate topic; we do not re-use existing topics here. Thanks for your understanding!
No, thank you Moem. The OP's issue was the same one I am having. I know better now.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Re: Linux Mint issue when I view or edit photos

Post by kelevra »

SMG wrote:
Sat Feb 20, 2021 5:13 pm
What were the recent updates you installed? Check in Update Manager > View > History of Updates.
This issue has been happening for a couple weeks, more so now that I am playing around with wallpapers and family photos. There must be 20+ updates since this began.
SMG wrote:
Sat Feb 20, 2021 5:13 pm
What error messages or crash reports are you seeing in the System Reports app?
Do you want me to post the whole latest error report? It is rather lengthy. Also there are ~6 error reports in total.
SMG wrote:
Sat Feb 20, 2021 5:13 pm
What app are you using to view/edit photos?
I quick view images with the default Cinnamon image viewer and I use GIMP to do all my editing.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
User avatar
SMG
Level 11
Level 11
Posts: 3737
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint issue when I view or edit photos

Post by SMG »

kelevra wrote:
Sun Feb 21, 2021 2:30 am
This issue has been happening for a couple weeks, more so now that I am playing around with wallpapers and family photos. There must be 20+ updates since this began.
Was a couple of weeks ago when you upgraded from LM20 to LM20.1?

I've seen a couple of people who have noticed they seem to have what appears to be a memory leak with Cinnamon since upgrading. I have not noticed it, but I also run Cinnamon with all the Windows Effects turned off (which might make a difference). Check your memory usage when the issue happens to see if there might be a correlation.
kelevra wrote:
Sun Feb 21, 2021 2:30 am
SMG wrote:
Sat Feb 20, 2021 5:13 pm
What error messages or crash reports are you seeing in the System Reports app?
Do you want me to post the whole latest error report? It is rather lengthy. Also there are ~6 error reports in total.
I am interested in the top portion of the reports. This is an example of that part from someone else's crash.

Code: Select all

          PID: 1897 (cinnamon)
           UID: 1000 (xxxxxx)
           GID: 1000 (xxxxxx)
        Signal: 6 (ABRT)
     Timestamp: Fri 2021-02-19 17:53:41 +07 (1 day 2h ago)
  Command Line: cinnamon --replace
    Executable: /usr/bin/cinnamon
If all your crash reports are the same (other than the time), then just one example is fine. Mint does clean the logs on a weekly basis, so it is possible the list may be shorter when you go back to get the info.
LM20.1 Cinnamon
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Re: Fallback mode when I view or edit photos

Post by kelevra »

SMG wrote:
Sun Feb 21, 2021 2:58 pm
Was a couple of weeks ago when you upgraded from LM20 to LM20.1?
I actually installed the 20.1 beta, as this a recently acquired machine. If I understood what I read correctly, it should be 20.1 now.
SMG wrote:
Sun Feb 21, 2021 2:58 pm
I am interested in the top portion of the reports. This is an example of that part from someone else's crash.

Code: Select all

  PID: 1237 (cinnamon)
           UID: 1000 (bill)
           GID: 1000 (bill)
        Signal: 6 (ABRT)
     Timestamp: Sun 2021-02-21 11:34:35 PST (10h ago)
  Command Line: cinnamon --replace
    Executable: /usr/bin/cinnamon
 Control Group: /user.slice/user-1000.slice/session-c2.scope
          Unit: session-c2.scope
         Slice: user-1000.slice
       Session: c2
     Owner UID: 1000 (bill)
       Boot ID: d69fadda4cae47818597db5666aa5be1
    Machine ID: b76cc7b1bbdc489e93909d2043031de8
      Hostname: HP-Compaq-Pro-6305-SFF
       Storage: /var/lib/systemd/coredump/core.cinnamon.1000.d69fadda4cae47818597db5666aa5be1.1237.1613936075000000000000.lz4
       Message: Process 1237 (cinnamon) of user 1000 dumped core.
I hope this enough. If not, I can post more.
SMG wrote:
Sun Feb 21, 2021 2:58 pm
Check your memory usage when the issue happens to see if there might be a correlation.
I just caused the system to crash by opening multiple images (3). When I closed them the system crashed and I am now in fallback mode. I monitored the ram usage and it started at ~24% and climbed to ~ 32%. It is now at ~26%.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
User avatar
SMG
Level 11
Level 11
Posts: 3737
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Fallback mode when I view or edit photos

Post by SMG »

I did not participate in the beta, but it is my understanding those installs did upgrade to become the official version.

It appears you are getting the same error as the other person, but that person was seeing it happen upon start-up, so there may be something different causing it to happen in your case.

~/.xsession-errors is a file which might shed some light on what happens before the crash. It's a text file and there will be time stamps in the file (but not necessarily for every line), so you should be able to see when Cinnamon starts in relation to when you know the crash happened and hopefully see what errors or warnings may have happened before the crash. You can check the file manually or if you just want to see the error lines you can run cat .xsession-errors | grep -i "error".
LM20.1 Cinnamon
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Re: Fallback mode when I view or edit photos

Post by kelevra »

SMG wrote:
Sun Feb 21, 2021 2:58 pm
I have not noticed it, but I also run Cinnamon with all the Windows Effects turned off (which might make a difference).
I turned all the window effects last night and I have not been able to make the system crash tonight. I will give it a hard hit tomorrow with GIMP and see if I can reproduce the issue.

Thanks for all the help so far SMG I really appreciate it.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
AnonymousFighter
Level 1
Level 1
Posts: 33
Joined: Thu Feb 18, 2021 2:12 pm

Re: Fallback mode when I view or edit photos

Post by AnonymousFighter »

Radeon HD 7480D is not supported. It will never work correctly.
User avatar
kelevra
Level 4
Level 4
Posts: 390
Joined: Fri Feb 21, 2020 2:56 pm
Location: Kanata

Re: Fallback mode when I view or edit photos

Post by kelevra »

SMG wrote:
Mon Feb 22, 2021 4:20 pm
.xsession-errors is a file which might shed some light on what happens before the crash.

Code: Select all

cat .xsession-errors | grep -i "error"
Nemo-Share-Message: 23:23:39.420: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
(cinnamon:1189): Cjs-CRITICAL **: 23:24:41.271: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:24:50.378: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:24:58.780: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:25:04.095: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:29:37.173: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:30:44.388: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:31:17.102: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:32:24.388: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:32:25.972: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:32:34.019: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 23:41:28.542: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 05:42:39.751: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 05:42:40.534: JS ERROR: TypeError: b is null
Nemo-Share-Message: 11:36:30.030: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
(cinnamon:1189): Cjs-CRITICAL **: 11:42:03.580: JS ERROR: TypeError: b is null
(cinnamon:1189): Cjs-CRITICAL **: 11:42:04.832: JS ERROR: TypeError: b is null
Clutter:ERROR:clutter-actor.c:5944:clutter_actor_dispose: assertion failed: (priv->parent == NULL)
I see errors but I can't make or tails of them. I can do some searching and see what I can dig up.
AnonymousFighter wrote:
Tue Feb 23, 2021 5:03 am
Radeon HD 7480D is not supported. It will never work correctly.

I guess switching to MATE is the next course of action.
"None of us is as smart as all of us." Ken Blanchard

Mint 20 Cinnamon
Intel© Celeron© CPU B820 @ 1.70GHz 8GiB
Mint 20.1 Cinnamon
AMD© APU A4-5300B @ 3.4GHz 8GiB
User avatar
SMG
Level 11
Level 11
Posts: 3737
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Fallback mode when I view or edit photos

Post by SMG »

kelevra wrote:
Tue Feb 23, 2021 3:54 pm

Code: Select all

Clutter:ERROR:clutter-actor.c:5944:clutter_actor_dispose: assertion failed: (priv->parent == NULL)
I see errors but I can't make or tails of them. I can do some searching and see what I can dig up.
Check the time stamps. I only see the last couple which appear to be recent. Did those happen right before the crash? If you restarted Cinnamon, you should see that happen in the file and be able to see what lines in the log happened before it.

As an FYI, I have that same "samba" error in my file too and I am not having crashes.

I did a grep on 'clutter' on my file and I do not have any errors related to it. This is what I get:

Code: Select all

Clutter-Message: 07:01:11.969: Sync method: PRESENTATION TIME
The timing is around when I booted my computer this morning.
kelevra wrote:
Tue Feb 23, 2021 3:54 pm
AnonymousFighter wrote:
Tue Feb 23, 2021 5:03 am
Radeon HD 7480D is not supported. It will never work correctly.
I guess switching to MATE is the next course of action.
If the Radeon HD 7480D is not supported, changing to MATE won't help. Linux provides the support and not Cinnamon. Your install has drivers for the Radeon, so I have no idea what that comment from AnonymousFighter was supposed to mean.
LM20.1 Cinnamon
Post Reply

Return to “Newbie Questions”