Dell with Mint 7 use 90% Xorg

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
tdipower
Level 1
Level 1
Posts: 9
Joined: Wed Sep 19, 2007 1:55 pm

Dell with Mint 7 use 90% Xorg

Post by tdipower »

My Dell Latitude D600 is installed with Linux Mint 7 and updated.
When i just start it up it idles at 85-100% CPU. I have started terminal an started "top". It tells me that root run's xorg at 85-100%

Is there any way to see what is making this ?

The only hardware driver I use is B43 Broadcom Wlan driver. I have tried disabling this, but no change.

help!! :shock:
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: Dell with Mint 7 use 90% Xorg

Post by DrHu »

tdipower wrote:The only hardware driver I use is B43 Broadcom Wlan driver. I have tried disabling this, but no change.
More context:hardware, software
In terminal, check
  • inxi -F
    --short list of all hardware
    inxi -G
    --graphics card only
    inxi -H
    --help optins for inxi command
And the video card is ??

My top display shows xorg at 0.7% average
nvidia
  • Graphics: Card nVidia NV36.2 [GeForce FX 5700] X.Org 1.6.0 Res 1600x1200@50.0hz
    GLX Renderer GeForce FX 5700/AGP/SSE/3DNOW! GLX Version 2.1.2 NVIDIA 173.14.16
--a fairly old card (nvidia geforce 5x), still no problem running Mint; except I always turn off any eye candy effects, Compiz (none).
--You might want to try that, and also check the video driver you are using for graphic card/chipset ?
User avatar
rich_roast
Level 6
Level 6
Posts: 1123
Joined: Sat Sep 05, 2009 4:37 pm

Re: Dell with Mint 7 use 90% Xorg

Post by rich_roast »

XOrg is what displays your windows, switching off the wireless driver will have no effect on it.

It might be worth disabling visual effects for the time being (preferences -> appearance -> visual effects tab), but research shows this model of machine has a radeon 9000 which isn't far behind mine where XOrg runs fine. Certainly 90%+ usage seems brutal.

Are there any apps running in particular when top reports this usage, e.g. Firefox?

Otherwise, the only other thing I can think of is adding the following line to /etc/X11/xorg.conf (use alt+f2, gksu gedit /etc/X11/xorg.conf to do this, but back xorg.conf up somewhere safely first)

Code: Select all

Section "Device"
	Identifier	"Configured Video Device"
	Option	"EnablePageFlip" "on"
EndSection
Page flipping is disabled by default in the radeon driver due to being unstable sometimes, but enabling it can improve performance. Might be worth a try, it was here. If it all goes wrong

Code: Select all

dpkg-reconfigure --phigh xserver-xorg
should bring things back to default settings, if that fails replace the new xorg.conf with the one backed up.
tdipower
Level 1
Level 1
Posts: 9
Joined: Wed Sep 19, 2007 1:55 pm

Re: Dell with Mint 7 use 90% Xorg

Post by tdipower »

The card is as stated by Rich a ATI Radeon, specified a RV250 [Mobility FireGL 9000] and the rest of the inix -G gave X.org 1.6.0 Res 1400x1050@60hz. so that's about right. :-)

I have turned of the visual effects (none) and now the xorg use around 1% CPU, so I guess that's the itch.
Then the next question is... what effect does this? :-)

Should I try adding the 4 lines in xorg.conf anyway?
User avatar
rich_roast
Level 6
Level 6
Posts: 1123
Joined: Sat Sep 05, 2009 4:37 pm

Re: Dell with Mint 7 use 90% Xorg

Post by rich_roast »

I should emphasise that the line in XOrg doesn't improve performance by a huge amount on my system, but does facilitate playing 3d games, for example. It may have a positive effect, it may not.

X.org has a radeon homepage, and

Code: Select all

man radeon
displays all the possible options available.
User avatar
lagagnon
Level 7
Level 7
Posts: 1878
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Dell with Mint 7 use 90% Xorg

Post by lagagnon »

Did you install the proper ATI video driver (ie go to menu, Control Center, Hardware, Hardware Drivers)???
tdipower
Level 1
Level 1
Posts: 9
Joined: Wed Sep 19, 2007 1:55 pm

Re: Dell with Mint 7 use 90% Xorg

Post by tdipower »

Just to answer myself.

I have now added the flip to the xorg.conf and turned on custom apperance. not much change. 5% less... maybe.
I then turned the apperance to normal and did a restart of the gui. I'm now at 5% at idle with only the terminal. If I start system monitor it's sudanly 95% again.
Turning the effect to none gives me a 5% with system monitor running, and the computer isn't slugish.

so... is there anyway I can run with effects or am I stuck as is?
Guess it works anyway for firefox and irc, but.... you always want what you can't have.. 8)


There is no option to add a hardwaredriver for this card...
User avatar
lagagnon
Level 7
Level 7
Posts: 1878
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Dell with Mint 7 use 90% Xorg

Post by lagagnon »

See my post above which you missed...
Lantesh
Level 6
Level 6
Posts: 1214
Joined: Sat Apr 12, 2008 1:02 pm

Re: Dell with Mint 7 use 90% Xorg

Post by Lantesh »

When you have effects enabled you are running Compiz, but it's possible that Metacity is also running, and both running at the same time will spike your CPU like that. Turn your effects back on and if your CPU spikes again go into terminal and run this command:

Code: Select all

killall metacity
If the spike goes away you have found your problem.
Post Reply

Return to “Newbie Questions”