Wicd can't connect to visible unsecured network

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 9
Joined: Thu Nov 05, 2009 1:34 am

Wicd can't connect to visible unsecured network

Postby OldSchool » Sun Nov 15, 2009 9:11 pm

I am running Linux Mint 6 "Felicia" Fluxbox on a Compaq TC1000 tablet. Wired networking works great out of the box.

Wicd can see my wireless network but cannot connect. It sees the correct ssid name and set-up parameters (no encryption). Iwconfig can also see my interface at eth1 and all the correct parameters.

I have been able to get the wireless connection to work sporadically using ifup eth1 from the command line. However this is not reliable.

I tried to solve using http://www.linuxmint.com/wiki/index.php ... rk_manager , however I bet I don't have network manager as part of the above community edition. I believe I only have Wicd and it not working for wireless.

Any help appreciated.

Level 1
Level 1
Posts: 7
Joined: Sat Aug 22, 2009 10:47 pm

Re: Wicd can't connect to visible unsecured network

Postby pennyfarthing » Mon Nov 16, 2009 1:52 am

Hi OldSchool,
I was having trouble connecting using a D-Link router. Same problem as you. Could see my network but unable to connect. Posted a help request on the forum, but no response. I figure that the solution has so many variables that it's hard to home in on the actual problem. I'm pretty much clueless in this regard, but just burrow away regardless.

However, I have managed to get my connection working fine using Wicd which I like better than network manager. For what it's worth these are the issues I looked at and by trial and error managed to fluke it.

I did all my set up using a wired connection via IP address. Don't forget to save changes. User name is admin and password leave empty.
What had me stumped was that I had omitted to get my computers Mac address. The setup did not do this automatically and I used the "clone mac address" feature in the setup to insert it. I can see with my setup under Status, Wireless and Number of Wireless Clients entries such as:- mac address, IP, Mode, Rate and Signal. You should see something similar. If these entries are blank you will not be able to connect. Save.

Also make sure that your password is the same as the one you use in Wicd (client). You will need to reboot the router for the settings to take effect. Do this whilst the wired connection is attached. Also in setup, I found that leaving the connection visible works fine. Invisible requires manual entry so I backed out of this and left visible ticked. I also ticked encrypton as WPA2 rather than an open connection.

I then rebooted both the computer and the router. The connection initially was slow but after a few goes it now connects in about 10 seconds. My one unresolved issue is with email. Using Thunderbird, I cannot send or receive large file attachments, say over 600KB. It times out and I have not found a solution yet. All other email works fine both ways, so I'm stumped.

Don't know if any of the above is helpful. I just know from my experience that it is usually something minor and quite obvious once you know the answer, that causes these problems. BTW I'm using Mint 7 Gloria Main. Good luck!

Return to “Newbie Questions”