How i "remember authorisation" in mint 8 helena

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 48
Joined: Sun Aug 30, 2009 4:18 am
Location: East Africa, Uganda

How i "remember authorisation" in mint 8 helena

Postby trueleowdeo » Tue Nov 24, 2009 4:44 pm

I just tried out mint 8 (helena) but whenever i am loading a hard disk , i am asked for the password. I think this is ridicoulous and is there a way to "automatically" remember the authorisation so that i just click on the hard disk and it doesnt ask me for the password.

Or perhaps i can disable this asking for a password.


Level 4
Level 4
Posts: 211
Joined: Thu Dec 04, 2008 6:35 am
Location: Glasgow Scotland

Re: How i "remember authorisation" in mint 8 helena

Postby distoaddict » Tue Nov 24, 2009 4:56 pm

this behavior comes from ubuntu 9.10. in mint 7 it would ask if you wanted the password remembered or once only but i dont see that option in helena.

Level 18
Level 18
Posts: 8011
Joined: Tue Feb 03, 2009 10:27 am

Re: How i "remember authorisation" in mint 8 helena

Postby altair4 » Tue Nov 24, 2009 5:22 pm

It appears that the only way around this issue is to actually mount the partition at boot using fstab.

For example if sda1 is the partition you want to mount and it's a windows partition formatted in NFTS you would do something like this:

Open Terminal
Type mkdir /home/altiar4/Windows
Type sudo su
Type echo "/dev/sda1 /home/altair4/Windows ntfs defaults,umask=007,gid=46 0 0" >> /etc/fstab

For other examples please read Auto Mount Partitions at Boot: viewtopic.php?f=42&t=22093

This will create a folder named "Windows" in your home folder into which partition sda is mounted. It will be accessible by altair4 ( in this case ) with read and write permissions and it will never ask for authorization.

I don't know why Ubuntu did this and I don't know if the Mint folks can easily restore this functionality but there is a way around this design decision.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 30 guests