Page 1 of 1

no sound on emachines T2893

Posted: Mon Jul 02, 2007 9:35 pm
by spinyshooter
well the name says it all. I just installed linux mint a week or so ago and have been learning the basics of it but no matter what(music, video, games...) I can't get the sound to work. I am simply using the speaker port on the motherboard and the only pci cards I have in are a wireless network card and a wired network card. I'm sure this has a simple solution, I just don't know it as I am new to Linux :oops:


p.s. so far I like cassandra better than windows xp :D

Posted: Tue Jul 03, 2007 6:21 am
by Husse
Welcome to Mint spinyshooter
It's always a good idea to add some facts about your hardware for sound issues
You seem to have AC97 audio, but we need to know the chipset to continue
Also check out the settings - in the volume control, in totem and movieplayer in.....

Posted: Tue Jul 03, 2007 7:15 am
by spinyshooter
every setting I can find has the sound turned all the way up and I still get no sound

How do I go about getting the chipset?
when I go into sound preferences it gives me:
Intel 82801db-ich4
Intel 82801db-ich4-iec958
would either of these be it?

sorry about the stupidity on my part as I'm not too good at all this :oops:

also I installed a wintv card and tvtime and the sound works fine, through the headphone jack on the card, when I'm watching t.v.

Posted: Thu Jul 05, 2007 6:11 pm
by spinyshooter
anyone?

Posted: Thu Jul 05, 2007 8:27 pm
by OU812
If you're lucky, all you have to is go to a terminal and enter

Code: Select all

alsamixer


Then adjust the volume levels (up/down arrows) and if a setting is muted, unmute by pressing m. The most important settings are master and pcm. Then enter this command to save your settings:

Code: Select all

sudo alsactl store


If this doesn't work, there may be an issue with your type of sound card.

john

Posted: Thu Jul 05, 2007 8:49 pm
by timmyflight
I'm running Cassandra on an Emachines W3107 with the Realtek AC 97 chip,
Cassandra picked it up and installed it immediately (so did Bea and Barbara,
as a matter of fact). The sound is great. Now on the other hand, Vista Ultimate
did NOT recognise the AC 97 chip, I had to go to the Realtek website to download the driver and of course M$ popped up a little box saying " we have not tested or approved this driver, are you really sure you want to potentially ruin your computer by doing this?" Of course I installed it, and amazingly enough (for the
M$ guys having not tested or approved it) it works.

Posted: Thu Jul 05, 2007 10:08 pm
by spinyshooter
well thanks for the replies, but unfortunately neither works

am I missing something?
http://www.putfile.com/pic.php?img=5899189
these are the settings, then I hit the ESC button, then type in sudo alsactl store, restart computer then I go to sounds and test and still no sound. Is there something else I'm missing or should I just try and scrap up a sound card?

The only sound card I can find right came off a 1996 computer
brand-none on card
model-AA1815
PCB NO. 072-218154071
that's all that's on it, and I don't even know if it works, but should I just give that one a shot?

Posted: Fri Jul 06, 2007 12:09 am
by ghill00822
I had the same problem with my laptop. right click on the speaker icon at the bottom right of the screen, select preferences,and play around with the settings.It worked for me, hope it works for you.

Posted: Fri Jul 06, 2007 6:01 am
by Husse
model-AA1815
It's an Analog Devices chip
As long as it's not ISA you could give it a try - don't forget to turn off the built in sound to avoid conflicts