Mouse does not work properly in VMWare WinXP guest

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jduffy
Level 1
Level 1
Posts: 10
Joined: Fri Dec 04, 2009 1:48 am

Mouse does not work properly in VMWare WinXP guest

Post by jduffy »

Hey new guy here.

I installed Linux Mint 8 and then installed VMWare Player from their most recent bundle to run WinXP as a guest and I can install just fine but when I go to use WinXP the mouse does not work properly. I can click on menus and the Start but clicking on a window of an open program de-highlights that window. I can't click in say notepad or even a browser to enter text.

Not sure what in the world is going wrong. I'd appreciate any ideas if you have them.
jduffy
Level 1
Level 1
Posts: 10
Joined: Fri Dec 04, 2009 1:48 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by jduffy »

I just uninstalled and reinstalled and tried using Win7 and the same thing happens, the mouse does not work correctly.

Any thoughts?
jduffy
Level 1
Level 1
Posts: 10
Joined: Fri Dec 04, 2009 1:48 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by jduffy »

No thoughts on this?

For the time being I've installed virtualbox but it doesn't have quite the same smooth feel to it but at least I'm able to get some work done today.

Still looking for some thoughts on how I might be able to get VMWare working with Win7.
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

It must be a BUG!!!

I have the same problem and I'm using LinuxMint8 i386 as a host-OS, and VMwareplayer 3 and Windows XP sp3 as a guest-OS! It is very annoying and as soon as vmwaretools gets installed to get things more workable it gets totally unworkable. Mouse clicks won't get through the virtualmachine although it detects the mouse as active in the virtualmachine. Sometimes clicks do come through, only half or parts of the virtual screen.

It works great in Ubuntu 9.10 i386! The same virtualmachine with WindowsXP and vmwaretools interacts perfectly on Ubuntu.

I will try one more clean LinuxMint8 install this time with sudo apt-get upgrade && sudo apt-get dist-upgrade for new kernel and other updates. Than install build-essential and linux-headers-`uname -r` and than the vmware installer...
Last edited by walterav on Sun Jan 31, 2010 10:05 am, edited 3 times in total.
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

walterav wrote:
I will try one more clean LinuxMint8 install this time with sudo apt-get upgrade && sudo apt-get dist-upgrade for new kernel and other updates. Than install build-essential and linux-headers-`uname -r` and than the vmware installer...
It didn't work, it looks like a GTK bug from the older vmwareplayer 2.53 but its not fixable this time.
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

I filled a bug report, hope someone will take a look at it, its easy replicate-able.

https://bugs.launchpad.net/linuxmint/+bug/512250
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

Admin / Moderator can this thread be moved to "Software & Applications" section?

Although I'm not the creator of this post don't know if I can request something like that.
deleted

Re: Mouse does not work properly in VMWare WinXP guest

Post by deleted »

I use VMPlayer 3 on 64 bit Linux Mint 8.
I run XP, Ubuntu 8.10 (and 9.10), xp64 all a guests.
The only time I have a mouse problem is when it is held by the guest.
CTRL-Alt will always clear it up (if the guest gets the click instead of the host)
CTRL-G does the other way around.
This will work whether or not you have vmtools installed.
-Hint
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

hinto wrote:I use VMPlayer 3 on 64 bit Linux Mint 8.
I run XP, Ubuntu 8.10 (and 9.10), xp64 all a guests.
The only time I have a mouse problem is when it is held by the guest.
CTRL-Alt will always clear it up (if the guest gets the click instead of the host)
CTRL-G does the other way around.
This will work whether or not you have vmtools installed.
-Hint
Did you try LinuxMint8 i386 also as host-OS? Good to hear you have no problems working with or without vmwaretools.

I will try the 64 bit release tonight as host-OS and keep this post updated.
deleted

Re: Mouse does not work properly in VMWare WinXP guest

Post by deleted »

No I didn't. I have a 64 bit machine and I have to work sometime;)
-Hinto
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

I will try the 64 bit release tonight as host-OS and keep this post updated.
It works great in the x64 release of LinuxMint 8!

But what about the main/i386 edition? Ubuntu 9.10 i386 is working like I mentioned before... I need to have the 32 bit version for compatibility. so 64 is no option. Maybe in future.
deleted

Re: Mouse does not work properly in VMWare WinXP guest

Post by deleted »

Since most of the 32 bit and 64 apps (and distros) are single sourced, I don't think you'll find a difference.
VMWare actually builds the linux modules when you install according to what you're running.
Can you provide more information?
-Hinto
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

hinto wrote: Can you provide more information?
-Hinto
Install Linuxmint8 main/x64 on USB-stick, keep all settings default during install, I chose to use the entire usbstick for install.
Update LinuxMint8 main/x64 with just Mintupdate.
terminal:
apt-get update
apt-get install build-essential linux-headers-`uname -r` #headers are already installed if I'm not mistaking
sudo sh VMwareplayerinstallxxx32/64.run

If you got 30 minutes of spare time and a empty 4/8GB usb-stick can you try to make an install via VMwareplayer 3 onto the usb-stick, you can keep using your pc and let the installation and updates run in the background. When finished the steps I described above, reboot your pc with the LinuxMint8 main i386 stick "not the x64 we know it works" and open one of your already made Virtualmachines...
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

It seems fixed with all MintUpdate updates till today and the above instructions. Mmm...

I try one more re-install without any updates... can't believe it is working right now!
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

It even works on a not updated LinuxMint8 main, and a remastersysed LinuxMint8 from a week ago... don't understand anymore. Did several re-installs of Mint and Ubuntu and reboot between the two and noticed one was working and they other doesn't. Have done more than 10 re-installs, and 3 times a guest-os install which is mostly automated...maybe they updated vmware-tools or my usb-stick is broken for testing...

I'll try one more re-install this weekend, with a remastersysed distro and also all (dist)upgrades, and try if I can Vmwareplayer from the LiveDVD session. Keep ya updated
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

walterav wrote: I'll try one more re-install this weekend, with a remastersysed distro and also all (dist)upgrades, and try if I can Vmwareplayer from the LiveDVD session. Keep ya updated
New Situation, a previously created guest-OS does not have the problem, and the machine created with a former liveCD at the moment does not work. So right now I have two virtualmachines running. One with the problem and the other without.

The problem right now is Virtualmachine and not host-OS related as I was thinking before.
I'll do some more testing... Maybe its the automated installer of Windows.
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

walterav wrote:
walterav wrote: The problem right now is Virtualmachine and not host-OS related as I was thinking before. Sorry LinuxMint ;-)
I'll do some more testing... Maybe its the automated installer of Windows.
!!!POSSIBLE FIX!!!
Pressing CTRL-ALT-DELETE inside the bad/not responding machine seems to fix it. Every time I start the virtualmachine with the mouse click bug, pressing CTRL-ALT-DELETE will make mouse response normally. CTRL-ALT is not enough as that was the default uncapture behaviour.

I will look into the settings of the virtualmachine and look if I see differences between the two.

Update:
I couldn't find any differences so fast, I will post this strange behaviour on the VMware forums next week. Thanks for the input so far.
deleted

Re: Mouse does not work properly in VMWare WinXP guest

Post by deleted »

...I do need to add the the mouse does not show up at all for me if I run VMPlayer in Unity Mode. (Mint host, XP guest)
walterav
Level 1
Level 1
Posts: 42
Joined: Fri May 29, 2009 5:25 am

Re: Mouse does not work properly in VMWare WinXP guest

Post by walterav »

walterav wrote: I will post this strange behaviour on the VMware forums next week. Thanks for the input so far.
http://communities.vmware.com/message/1468344#1468344 #its on the vmware community
hinto wrote:...I do need to add the the mouse does not show up at all for me if I run VMPlayer in Unity Mode. (Mint host, XP guest)
There are more bugs indeed, like not showing vmware window bar "well its white instead of filled with icons" when a guest-OS is in fullscreen mode, but thats the next bug. This one is the most annoying for me right now.
deleted

Re: Mouse does not work properly in VMWare WinXP guest

Post by deleted »

There are more bugs indeed, like not showing vmware window bar "well its white instead of filled with icons" when a guest-OS is in fullscreen mode, but thats the next bug. This one is the most annoying for me right now.
I haven't seen that one...

-Hinto
Post Reply

Return to “Newbie Questions”