usb disk gone read only!!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 10
Joined: Wed Jun 27, 2007 3:34 pm

usb disk gone read only!!

Postby virtualandi » Sat Jul 07, 2007 9:04 am

hi people. Im running cassandra & ive developed a prob with my 2gb usb mem stick. it worked fine 4 ages, now it has gone 'read only'. i cant seem 2 do anythin with it. Can somebody tell me how 2 change this? Ive tried altering permissions but it just says it cant 'cos its read only.
What hav i done!!!?


User avatar
Level 8
Level 8
Posts: 2277
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sat Jul 07, 2007 9:30 am

Can you give us a directory listing so we can see who the user is and what permissions are set? e.g. type this into a terminal:
ls -al /media/where/USBstick/is/mounted
... then paste the result here.

Also: can you please the output of this command: mount (without parameters).

And then this one: df -ah

That should help to analyse the problem...

Return to “Newbie Questions”