Disabling touchpad mouse?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Disabling touchpad mouse?

Post by dave_s »

In Mint 7 it was possible to disable the touchpad mouse. Is there a reason why it can not be included in the Mint 8 options?

I believe it can be disabled via the terminal but this has to be done on every reboot.

Thanks

Dave
User avatar
rich_roast
Level 6
Level 6
Posts: 1123
Joined: Sat Sep 05, 2009 4:37 pm

Re: Disabling touchpad mouse?

Post by rich_roast »

It's strange that there's only the option to disable the touchpad while typing through preferences->mouse.

One fix is to install gpointing-device-settings using Synaptic package manager. It didn't make a menu item straight away when I installed it, but you can just run

Code: Select all

gpointing-device-settings
from terminal or Alt+F2 run dialogue. It has a drop down list on the opening tab for switching touchpad off.
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Re: Disabling touchpad mouse?

Post by dave_s »

Thanks for that, works a treat.

Much appreciated :D

Dave
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Re: Disabling touchpad mouse?

Post by dave_s »

Actually, spoke too soon.

It does not retain the setting and the touchpad turns itself back on again after a while.

So I suppose back to the original question. Is it possible to include the original setting from Mint 7 ?

Dave
User avatar
rich_roast
Level 6
Level 6
Posts: 1123
Joined: Sat Sep 05, 2009 4:37 pm

Re: Disabling touchpad mouse?

Post by rich_roast »

Dug out this bug, comment #2 fix doesn't work for me and the problem I'm experiencing is more serious; settings do not even persist for one session (more like about five minutes), never mind persisting between logins and logouts. I've tried everything I can think of in gconf-editor too, to no avail. I might get around to submitting a report but this seems entirely broken to me and I don't know where in the stream that breakage is.

Try installing gsynaptics using Synaptic (do not confuse the two! The name of the former is based on a touchpad manufacturer, I think); this will introduce a "Touchpad" item in your preferences section of mintMenu; the checkbox to enable/disable touchpad is on the first tab. I'm not having a great deal of joy with it, either, but then I'm fiddling around something awful with gconf trying to figure this out :?

Very irritating.

[update] Gah, not even completely removing gpointing-device-settings and rebooting has fixed this, something seems to persistently turning the touchpad back on. I suspect gnome-settings-daemon or a problem with a gconf key but can't confirm. :x

[second update, should "solve"]Gah, I give up. This'll "fix" it:

Code: Select all

sudo mv /usr/lib/xorg/modules/input/synaptics_drv.so /somewhere/safe
Xorg won't be able to load the touchpad driver. The touchpad will therefore not work. Xorg still runs normally, I've tried :mrgreen:
User avatar
Marshmellow
Level 1
Level 1
Posts: 1
Joined: Sun Jun 13, 2010 6:05 pm

Re: Disabling touchpad mouse?

Post by Marshmellow »

Thank you very much, rich_roast

I almost gave up. Knowing the offending file helped fix my problem. I was unable to perform your command, recieving an error stating no such directory existed. Instead, I opened /usr/lib/xorg/modules/input folder as root. I just renamed the file a nasty word. I believe the same result is achieved.
Xorg won't be able to load the touchpad driver. The touchpad will therefore not work. Xorg still runs normally, I've tried :mrgreen:
Thank you very much . I am a complete newb, and am on my 3rd try in regards to migrating from a 15 year addiction to Windows. Feels good man. Thanks a bunch. :? & :D
I registered here in order to thank you for your diligence. 8) :idea:
User avatar
rich_roast
Level 6
Level 6
Posts: 1123
Joined: Sat Sep 05, 2009 4:37 pm

Re: Disabling touchpad mouse?

Post by rich_roast »

Thanks for the kind words, glad to have been of use. That makes the exercise worth it. 8)

Happy hacking.
bartonlp
Level 1
Level 1
Posts: 6
Joined: Wed Jun 22, 2011 4:52 pm

Re: Disabling touchpad mouse?

Post by bartonlp »

I have just installed Linux Mint 11 over Ubuntu 11.04. I use to be able to do 'rmmod psmouse' and stop the touchpad. Now that hangs the machine. I have a Dell Inspiron 1545. I can't find the package mentioned here (gpointer-device-settings) with apt-get etc. Does anyone know why the rmmod does not work or where I can get gpointer-device-settings? I am still looking but some help would be appreciated. Thanks
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Disabling touchpad mouse?

Post by Aging Technogeek »

Your problem is that you are looking for the wrong thing. The file you want is gpointing-device-settings, not gpointer-device settings. It is available in Package Manager, just enter gpointing-device-settings in the Quick Search box.
Registered Linux User 483387
bartonlp
Level 1
Level 1
Posts: 6
Joined: Wed Jun 22, 2011 4:52 pm

Re: Disabling touchpad mouse?

Post by bartonlp »

I'm sorry I meant "gpointing-device-settings". I just typed it wrong. I can run the app but nothing to turn off the "ImPS/2 ALPS GlidePoint".
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Disabling touchpad mouse?

Post by Aging Technogeek »

Insead of "rmmod", you might try "modprobe -r" to remove the module. This is the more commonly used command in Mint.
Registered Linux User 483387
bartonlp
Level 1
Level 1
Posts: 6
Joined: Wed Jun 22, 2011 4:52 pm

Re: Disabling touchpad mouse?

Post by bartonlp »

Yes I thought so also and tried that as well with the same results -- hang, no keyboard, no mouse; reboot via power off. The interesting thing is it use to work with Ubuntu 10.10 just fine. Only when I upgraded to Ubuntu 11.04 did the problem exist. Then I installed LinuxMint 11 over Ubuntu 11.04 (not a full clean install mind you) and Mint has the same problem. I spent yesterday googeling with no useful results. If I don't get some help soon I may reinstall LinuxMint 11 from scratch and see if the problem had something to do with the Ubuntu 11.04 installed previously. I hate to do that but I really don't have a lot of stuff on the laptop and everything is backed up to my desktop machine anyway.

Thanks
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Disabling touchpad mouse?

Post by Aging Technogeek »

Something else to try before you reinstall. A little app called "Touchpad Indicator". In spite of the name, it can control the touchpad and automatically disable it when a USB mouse is plugged in.

http://www.webupd8.org/search?q=touchpad+indicator
Registered Linux User 483387
bartonlp
Level 1
Level 1
Posts: 6
Joined: Wed Jun 22, 2011 4:52 pm

Re: Disabling touchpad mouse?

Post by bartonlp »

That sounds like a possible. Where would I find this app? Is it part of the apt-get and if so what is it called for installation?
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Disabling touchpad mouse?

Post by Aging Technogeek »

Open a terminal and enter these three commands

Code: Select all

sudo add-apt-repository ppa:atareao/atareao

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install touchpad-indicator
Touchpad indicator will be found under Accessories in the menu. When launched, it will display a small icon of a touch pad in the notification area of the panel. Click on the icon and click Preferences to set it up to autostart and disable the touchpad when a mouse is plugged in, or, if that choice is not selected, you can toggle the touchpad on and off from the same dropdown menu. You can also add a keyboard shortcut if you want.

To read more about it, click the link in my previous post.

It works quite well. I install it every time I install a Gnome distro on any of my laptops.
Registered Linux User 483387
bartonlp
Level 1
Level 1
Posts: 6
Joined: Wed Jun 22, 2011 4:52 pm

Re: Disabling touchpad mouse?

Post by bartonlp »

Thanks for the instructions I will try it our on Monday.
kjkrum
Level 1
Level 1
Posts: 17
Joined: Thu Jul 14, 2011 5:18 pm

Re: Disabling touchpad mouse?

Post by kjkrum »

Good info, thanks! I'm using Mint 11, and turning off my Synaptics trackpad with gpointing-device-settings seems to have worked. It's stayed off for a few hours now. I'll try touchpad-indicator later.
User avatar
Cariboo
Level 4
Level 4
Posts: 202
Joined: Sun Jan 13, 2008 10:00 pm
Location: Kelowna, BC

Re: Disabling touchpad mouse?

Post by Cariboo »

@AgingTechnoGeek....
Thanks for the instructions.
Works great on my HP g6-1B67ca Notebook (Dual boot System LM11 + Windows7)...
One minor issue: the indicator lamp is not ON in either condition.
Under Windows7 the DISABLED condition is indicated by an orange light. :wink:
Self-built MSI-785GM-E51 Desktop, Dual boot: LM18-64bit and Win10-64bit , Samsung Galaxy S4 un-locked.
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Disabling touchpad mouse?

Post by Aging Technogeek »

There should be a red X in the icon when the touchpad is disabled. I guess this is easier to do than turning on the touchpad disabled light (which not all computers are equipped with).
Registered Linux User 483387
User avatar
Cariboo
Level 4
Level 4
Posts: 202
Joined: Sun Jan 13, 2008 10:00 pm
Location: Kelowna, BC

Re: Disabling touchpad mouse?

Post by Cariboo »

Aging Technogeek wrote:There should be a red X in the icon when the touchpad is disabled. I guess this is easier to do than turning on the touchpad disabled light (which not all computers are equipped with).
Yes, there is a red X. I locked it to the panel. I agree, to be universal, this is the better way.
Self-built MSI-785GM-E51 Desktop, Dual boot: LM18-64bit and Win10-64bit , Samsung Galaxy S4 un-locked.
Post Reply

Return to “Newbie Questions”