Page 1 of 1

Newbie frustrations

Posted: Tue Jul 17, 2007 2:09 pm
by Paul L
I've been using Mint for the past couple of weeks. I have used a number of other distros before but am very happy with Mint. However, there are a number of issues that are stopping me from making the break from the 'other' OS.

As a relative newcomer I simply do not fully understand the directions that are given to "simply" install hardware. Software is Ok, hardware is something else. Please could people fully explain for us newcomers what exactly we should do - please do not assume that we know how to follow your instructions.

I am having problems with two main issues - getting my phone to sync and getting my mp3 player to work. I have looked at the Wiki for Synce and to be honest it might as well have been written in Chinese. Can somebody explain EXACTLY how I manage this please. I read on a forum that my Rio Cali mp3 player should just work when plugged in. It doesn't.

Now I understand that typing in dmesg will show me my devices - both my phone and mp3 are shown on the list but neither is visible.

Without wanting to appear a complete numpty what am I missing?

Any help would be appreciated.



Posted: Wed Jul 18, 2007 9:04 am
by Husse
To use the Rio player you must install a program

Code: Select all

sudo apt-get install rio libkarma0 karma-tools rioutil
That's all you have to do.
This gives you a CLI (Command Line Interface)
To get a GUI this link
unfortunately it's not a .deb package but seems simple enough once you have java installed
See the read me

Code: Select all

To run the binaries, simply download the JAR file and run 
"java -jar jrioutil.jar".
Java needs to be in your path, which it probably is already.
To help you with the phone I need to know what phone it is.
And - yes a bit more user friendly would be nice

Rio Cali works (ish)

Posted: Wed Jul 18, 2007 3:10 pm
by Paul L
Thanks for the prompt response. Using the rioutil program I am able to access the mp3 player via the command line. (nearly there!)

Couldn't understand exactly how to run the gui. I downloaded the jar file. Saved it to desktop. When I click on it the program wants to extract (I assume therefore that a jar file is a 'zip' file). Not sure where to extract it to. I typed in sudo java -jar jrioutil.jar but it was unable to find the program. I would appreciate any suggestions. Please be gentle! Thanks

By the way my phone is a SPV M600 aka HTC Prophet


Re: Rio Cali works (ish)

Posted: Wed Jul 18, 2007 3:44 pm
by scorp123
Paul L wrote: When I click on it the program wants to extract (I assume therefore that a jar file is a 'zip' file).
You're not supposed to extract it ....

How to use *.jar files -- from SUN: ... AR/basics/
Paul L wrote: I typed in sudo java -jar jrioutil.jar but it was unable to find the program.
You were probably in the wrong directory. Didn't you say you saved it onto the desktop? So the file would be in the /home/youruseraccount/Desktop/ folder; but when you opened a terminal you were in your home folder /home/youruseraccount ... not in the right sub-directory as it seems. Obviously the command was then not able to find the files you specified.

GUI works

Posted: Thu Jul 19, 2007 11:12 am
by Paul L
Thanks for the help. I spotted my error after much hair pulling. The file I downloaded was called jrioutil-1.0.2.jar (not jrioutil.jar) and had been saved to my downloaded directory. I moved it to my username directory and ran java -jar jrioutil-1.0.2.jar and hey presto it works.

Maybe I'll get the hang of this yet!

Just need to sync my phone now and bye bye Windows!

PS Does anyone know how to change the name of partitions? I couldn't get my ntfs partitions to automount. I reformatted them as fat32 and copied the data back in. Unfortunately I don't seem to be able to change the name - stuck with sdd2 instead of Photos or whatever. Any help appreciated.

Thanks again


Posted: Thu Jul 19, 2007 12:37 pm
by nick

To save making mistakes when typing long file names, its easier to use the Tab Key

ie type "java -jar jr" then hit Tab and the name will be filled in for you.


Partition Names solved

Posted: Thu Jul 19, 2007 4:23 pm
by Paul L
I used the 'other' OS to change the names and Mint reads them OK. Problem solved.

Posted: Fri Jul 20, 2007 6:00 am
by Husse
To set the label of a partition you use e2label (if you have ext2 or 3) man e2label
e2label /dev/sda1 Photos you should probably be root
I forgot how to do it so I had to look it up again :)

As for your smartphone SPV M600 I have not found anything useful. Google and you may find the solution.
If not post back and I'll see what I can do, maybe scorp123 knows better - I don't use such appliances