Comcast Setup Issues

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Level 4
Level 4
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Comcast Setup Issues

Post by theevilone6620 » Fri Jan 29, 2010 8:48 pm

I am having a problem now that i have no idea how to fix. I just had my comcast internet service reactivated, it was shut off due to non payment. Now that they turned it back on I cannot connect to the net in Mint. Whenver I pull open a web browser, i get a page that says the OS is not supported. It is trying to download and install the windows internet connection wizard software. The funny thing is, that when they originally set up my net connection they installed the software on windows and after they left I switched to mint and all was good.

However, now, since the reactivation, i get this problem in mint. But when I load into Vista it works as if nothing has changed. I didnt have to reinstall the software or nothing.

I am also using a linksys router. If anyone has had this similar experience and can help me that would be greate.

I have done a little research and have read that they have to activate the modem with the MAC address, however this shouldnt be the case as like I said it works in vista. I jstu cant seem to get away from this page when laucnhing any broweser in mint.

No matter what website i try to access i get the same page saying the OS is not supported.

There has to be some way to get around using this windows installation software and manually set up the connection. But like i said i have no idea as to how to do it.

Since windows is working as if nothing has changed wouldnt you think that Mint should do the same thing?

Anyways., please someone help me
Check out my blog at anyone would like to contribute to the project send me a message..
Follow me on Twitter

Level 1
Level 1
Posts: 28
Joined: Wed Jan 13, 2010 6:32 pm

Re: Comcast Setup Issues

Post by scott_R » Sat Jan 30, 2010 4:49 pm

It's comforting knowing that your ISP is quietly installing software (probably written by the lowest bidder) onto your computer, isn't it? :shock:

Anyway, this is a problem that's been around for a while, although it's been slowly rolled out in different areas at different times, starting around 2006, IIRC. The fix is simple (but annoying), you have to call up Comcast and run through the gauntlet of helldesk folks who will give you the runaround, until you reach someone willing to help, often a manager/supervisor, who will ask for a few bits of information, then provision (make an exception to) your connection, allowing you to use Linux. The problem is, they LIKE having their software on your computer, for various reasons that are obvious enough.

Sometimes it's a piece of cake and you can get the connection opened right away, other times it's like a vacation at Gitmo...but be persistent. 8)

Level 4
Level 4
Posts: 215
Joined: Mon Dec 14, 2009 2:27 am
Location: Komandorsky Archipelago, Kamchatka Peninsula

Re: Comcast Setup Issues

Post by pompom » Sat Jan 30, 2010 8:38 pm

The OS is not really the issue. Typically all you need is a browser with Active X enabled. Are you setting up WiFi or Ethernet connection? If it worked before, it can be setup. One thing that you may try is running Internet Explo(d)er 7 using Wine. It is known to work (albeit buggy). Most of the time all that is required is a registry entry WindowHasRun=0 that needs to be set to 1 and the rigamarole will go away.


"This is Linux. It gives you cute mascot and enough rope to hang yourself." --- Miquel van Smoorenburg

Level 1
Level 1
Posts: 3
Joined: Sun Nov 29, 2009 12:21 pm

Re: Comcast Setup Issues

Post by pres » Sun Jan 31, 2010 7:37 pm

I had a similar problem and I solved it by calling tech support and they "initialized" or "registered" my Comcast cable modem. Once that was done then everything worked fine. I, too, have a Linksys wired/wireless router.

There is a way of registering your cable modem but you have to do it through Windows (didn't work for me even when I tried it through Windows).


Post Reply

Return to “Newbie Questions”