Page 1 of 1

Trouble dual-booting with Linux 7 and Windoze XP

Posted: Sun Feb 14, 2010 10:35 am
by willit
The Basics:

I like to think I know a little about PCs, and have recently moved over from WinXP to Linux Mint 7.
I built this machine myself, and I know it is kosher - all the hardware works fine.
MB: Gigabyte GA-P31-ES3G
Processor: Intel Dual-Core 2.4Ghz (x2)
RAM: Kingston 2mb Ram (x2)
HDDs: Western Digital 1TB; Maxtor 500gb; Maxtor 120gb
Sound Card: Sound Blaster Audigy2 ZS
Graphics Card: Radeon X1800 GTO (NV721CF)

The Situation:

I've had to re-install Windows XP since some of the software I have won't run effectively on Linux either directly or through VirtualBox. I will mention at this point that the XP partition is on a separate HDD from the partition that Linux is installed on.

So, I have Linux Mint 7 on one HDD and Windows XP on the other, and Windows has taken precedence so I am supposed to boot up with the Linux Mint disc in order to re- activate the grub menu. The first part of the instructions instructs me to:

Open up a terminal, and type the following:

- sudo grub
- root (hd0,0)
- setup (hd0)
- quit
- exit

It's all going fine until I type "setup (hd0)", to which it spits out something like "cannot mount inactive partition". I can't help but think that it's because each of the partitions are in different physical locations. If this is the case, is it still possible to dual boot, or will I have to re-install windows on a separate partition of the same HDD? If it is possible, what should I change the terminal command to?

Thanks in advance, any help would be greatly appreciated :)

Re: Trouble dual-booting with Linux 7 and Windoze XP

Posted: Sun Feb 14, 2010 11:47 am
by willit
Oops forgot to mention:

Partition with Windows XP is at "IDE Channel 0 Master" (SATA drive)

Partition with Linux Mint 7 is at "IDE Channel 1 Master" (IDE drive)

I'm guessing this may have an influence on what to write in the terminal...

Re: Trouble dual-booting with Linux 7 and Windoze XP

Posted: Sun Feb 14, 2010 11:55 am
by Leppie
which drive is set to boot first in bios?

as far as i understand from what you've written is that you are trying to set the windows partition (hd0,0) as the root for grub, which grub will not like as it cannot find any of it's files there. so i suppose you should use hd1,0 instead.

Re: Trouble dual-booting with Linux 7 and Windoze XP

Posted: Tue Feb 16, 2010 4:10 pm
by hal8000
willit wrote:Oops forgot to mention:

Partition with Windows XP is at "IDE Channel 0 Master" (SATA drive)

Partition with Linux Mint 7 is at "IDE Channel 1 Master" (IDE drive)

I'm guessing this may have an influence on what to write in the terminal...

Remember Mint now uses Grub 2 so open up a terminal, and type the following:

- sudo grub
find /boot/grub/stage 1

(this will most likely return hd1,1)
As you say its first partition on hd1 then

root (hd1,1)
setup (hd0)
-
(will install grub bootloader to the first IDE0 SATA drive which is ok if your BIOS boots form this drive)
OR
setup (hd1)

(which sets up grub bootloader on the MBR on SATA drive on IDE1, you may now have to enter BIOS and change bootorder in BIOS)

quit
exit

Re: Trouble dual-booting with Linux 7 and Windoze XP

Posted: Sat Mar 06, 2010 12:32 pm
by Mallette
Can't quite tell whether this is my problem or not, but decided to try here before starting a new thread.

I had a great LM install on a machine whose Windows had died. It even installed my rather non-routine M-Audio Audiophile USB soundcard. Hadn't seen a more hassle-free perfect install since AmigaDOS, and that has been a while. Since it was so easy I eventually decided to restore a Windows image I had of that machine, figuring even though I'd lose LM reinstall to dual boot would be easy.

It wasn't. First time I completed, making sure the dual boot option was invoked, but it went straight to Windows. Couldn't figure a way around it and decided I must have missed something, so I re-installed. I could not figure out for the life of me how to install over the first LM (which, IMHO, should be the default). Everytime I selected "manual partition" all the color codes would go out and there was no way to be absolutey sure just what you were deleteing.

In any event, I decided just to let it do a second install, then go back in with a Windows partition tool to reclaim the old space.

Same result. Keeps booting to Windows.

Is there an easy way to deal with this?

Regards,
Dave