Page 1 of 1

Yay! I am now Linuxian!

Posted: Sun Aug 05, 2007 10:54 am
by ElEdwards
I just completed the removal of XP and installed Mint 3.0 utilizing both of my hard drives (Primary: 80Gig / Secondary: 40Gig)

Wow! Everything SINGS!! It's really fast! All of my hardware is working and I've really only hit one snag:

I have dual monitors and an ATI-7000 Dual Head card. At present, I simply have a cloned display on my second monitor.
I tried using Envy to install the ATI driver... it failed in 'automatic' and trying 'manual' was a disaster!! After the driver install was done, X wouldn't start! Luckily, I had made a backup of xorg.conf, so I reinstated it and everything is back.

Can anyone help me with getting a true dual display?

Thanks!! :)

Posted: Sun Aug 05, 2007 11:58 am
by newW2
For the envy issue that you mention perhaps a update to envy will help - see Alberto Malone's post at: http://www.linuxmint.com/planet/Software/

For the dual monitor question read these two links to see if they help.

http://ubuntuforums.org/showthread.php?t=221174

http://ubuntuforums.org/showthread.php? ... l+monitors

Posted: Sun Aug 05, 2007 12:27 pm
by frank392
Hi ElEdwards,
Just press Ctrl Alt F1 and log in, then sudo envy
that will do the trick

Posted: Sun Aug 05, 2007 12:41 pm
by ElEdwards
I think what I'm running into is that the Linux ATI drivers are for video cards later than mine (ATI 7000).

I updated Envy but it still gives an error when I try to install the ATI driver.

Here's the error from the install log:
ENVY ERROR: Envy does not recognise your card as compatible with any version of the driver.this might happen because either your card is not supported by the driver or Envy's hardwaredetection failed. You can try the manual installation at your risk.
I tried the manual installation once but that prevented X from running.
Are there any generic ATI drivers that will work with my card?

Thanks! :)
El

Posted: Sun Aug 05, 2007 9:32 pm
by ElEdwards
Well, it turns out I have two problems......

#1 - ATI Card w/Dual Monitors - it appears that the ATI drivers don't support my card (ATI 7000), so for now, I just have two monitors with the same thing on each. Even with an update to the latest Envy, the ATI installation fails.

#2 - I have a SB Audigy2 Card - great sound output ..... but lousy (& noisy) mic input in either/both mic inputs.

Thoughts? Ideas? Help? :)

Thanks!
El

Posted: Sun Aug 05, 2007 9:42 pm
by Boo
Using dual head monitors is best done manually.
you have to edit the /etc/X11/xorg.conf file.

I would look for dual head configs for xorg.conf on the web.
Nvidia has good documentation on xorg.conf file configuration.
there may be some documentation for the ati in /usr/share/doc/... or somewhere like that.

but then again ATI have never been all that good on their Linux drivers so i dont expect much on the doco side either.

:D

Posted: Tue Aug 07, 2007 12:08 pm
by tseliot
ElEdwards wrote:I think what I'm running into is that the Linux ATI drivers are for video cards later than mine (ATI 7000).

I updated Envy but it still gives an error when I try to install the ATI driver.

Here's the error from the install log:
ENVY ERROR: Envy does not recognise your card as compatible with any version of the driver.this might happen because either your card is not supported by the driver or Envy's hardwaredetection failed. You can try the manual installation at your risk.
I tried the manual installation once but that prevented X from running.
Are there any generic ATI drivers that will work with my card?

Thanks! :)
El
Envy is right. Your card is no longer supported by the proprietary driver.

Uninstall the ATI driver through Envy (so as to restore mesa) and make sure you're using the open source driver "ati" in the Section Device of your xorg.conf.