which version to install on Toshiba Sattelite A70?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 12
Joined: Tue Apr 03, 2007 3:29 pm

which version to install on Toshiba Sattelite A70?

Postby RheinholdsMonkey » Wed Aug 08, 2007 12:43 am

I inherited a Toshiba Satellite A70

chunky wide screen..512 ram no HDD P4 , ATI mobility 9000
and its supposedly don't work...

just spent an hour with couple of cans of air/vacum cleaner and removed what i think was either a large mouse or a small cat..

now it boots and seems to stay stable...ran memtest..for a bit no red red flags
should probably run over night though

Tried Cassandra..loaded fine...missed some error about bios timer issue
but no sound..most everything else seems to work
cant really tell cause hardware info refuses to load..just gives blank as it get to devices and then closes...

So I tried Beta XFCE...still waiting for final to download..
It ran faster but mouse was erratic from live cd..and again no sound
and no hardware info..

I can boost the ram to 1.5 gig and put in a hardrive and try an install
but dont want to spent the cash without verifying the damm thing is actually working

does that mean i have no choice but a hardrive install and a restore to xphome from a "borrowed" (cough) sys restore disk...

So 1. what would cause hardware to be not readable in two editions on this laptop

2. if i do upgrade ...to say a gig of ram and HDD
what is the cut off line between Old/Newer systems to get the best performance..

opinions please

and if i go XFCE...does all the software in the mint portal work for that too?


User avatar
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Postby Boo » Wed Aug 08, 2007 2:13 am

I would try resetting the bios and checking it closely.
check the bios time, may have to check the battery for the on board clock.

a hard drive and more RAM is not going to fix any problems.

if you use xfce and mint portal the installs will pickup all dependencies and install them too. so all apps should work.

Now where was i going? Oh yes, crazy!

User avatar
Level 8
Level 8
Posts: 2421
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby merlwiz79 » Wed Aug 08, 2007 2:48 am

Did you burn at a low speed like 2x?
Also try booting wih acpi=off which might stop the hardware info crashing.
The final of XFCE should have this working fine.(Was a bug in beta003)(tested Hardware Info with livecd on 2 different machines and worked fine)
I also agree with what Boo says.
GNOME should run fine with a P4 and 512MB of ram.
For mintInstall, almost all of the .mint files I gave Clem were made and tested on XFCE Beta003.
I would think all would work, but some may not have all the functions it would under GNOME or KDE.
This may fix the sound issue.
FishRCynic wrote:try loading the sl-modem-daemon to take care of the modem. I use ubuntu feisty on my A70 and sl-modem-daemon with pulse audio makes the sound work properly. (mine seems to have an issue with ESD for some reason).
Hope it helps.


Hope we have helped you. :)

Level 1
Level 1
Posts: 12
Joined: Tue Apr 03, 2007 3:29 pm

Postby RheinholdsMonkey » Wed Aug 08, 2007 11:53 am


I guess I am going to start over with this laptop..
gogling reveals the A70 has some ESD problems, some Heat Problems,
and some, AC power in Jack module problems...

All of which are capable of causing some of the symptoms...
Toshiba didn't have a recall per say..but it seems they did an awful lot of
cleaning and reseatting and better thermal pasting of the Processor and radiator
assembly and a lot of changes on the AC In jack...

The ESD stuff...its noted on lots of forum as causing total lockup or
still havening mouse movement but not being able to open or close windows
strange how the same symtoms where occurring under MInt releases

I left it on Cassandra under battery power with TOP running for a few hours...TOP showed almost full memory usage..when the low battering warning came on...i plugged in the AC...It died shortly after...but rebooted fine
under AC..

The BIOS on this thing is the most "simplest" I have ever seen...bugger all for settings...I am going to see if there is a BIOS upgrade before I go any further

got a sys restore disk for XP home and a legit Toshiba one so I am going to plunk in a HDD and do that just to verify all systems are go...

So if they are..I will try again..with XFCE final..

Return to “Newbie Questions”