xorg, openGL, and ati catalyst

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 16
Joined: Mon May 03, 2010 12:45 am

xorg, openGL, and ati catalyst

Post by solna »

okay, so on a lark(and curiosity) i tried a live cd of mint, and was impressed enough to go ahead with the install after learning about wine(im a WoW-head, what can i say?).

now i'm a little baffled about the video drivers and system. i know mint comes with xorg 7.(something), and i'm pretty sure as of this morning mine did too.

and then i started playing with ATI drivers and boom, it starts looking like this...
Screenshot-1.png (118.99 KiB) Viewed 437 times
it says i have no openGL at all(i did before i played with the ATI drivers), which is a little odd.

hardware info: ati radeon 9k or 9200, mobile(toshiba satellite 185-s1072).

was getting odd messages in wine about not having openGL before i played with trying to get catalyst up. would be able to start wow and get the intro-movie(just as epic in linux as winderz), but the minute it went to login screen, boom, error 132.

i'm currently about to attempt a reinstall via crossover.

so, any thoughts on the graphics issues? how would i ensure i've got the real xorg i need?
Screenshot.png (119.94 KiB) Viewed 437 times

Level 17
Level 17
Posts: 7636
Joined: Fri May 09, 2008 1:14 pm

Re: xorg, openGL, and ati catalyst

Post by remoulder »

There is no proprietary ATI driver available that will work with your graphics card under recent versions of mint, ATI withdrew support for older cards. You have to use the OS supplied open source radeon driver. If you have installed catalyst you will need to remove it again, how you do this depends on how you installed it. If there is an /etc/X11/xorg.conf file, open a terminal and enter

Code: Select all

sudo rm /etc/X11/xorg.conf
then restart.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

Level 5
Level 5
Posts: 512
Joined: Sat Apr 17, 2010 1:58 am
Location: Where my hat is

Re: xorg, openGL, and ati catalyst

Post by Biker »

The Error 132 could be caused by a myriad of things as well. I'd have to see the entire error message (found in the WorldofWarcraft/Errors folder) in order to determine what the exact cause of the error was.

Bear in mind, while WoW may run under Wine, it's no guarantee that things will be better. I can get WoW to run on my notebook easily, however the frame rate is much poorer than running it under WIndows 7.
Linux User #384279

Post Reply

Return to “Newbie Questions”