Disk Check at startup taking - forever ...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
reactiv8
Level 1
Level 1
Posts: 41
Joined: Sun Jul 06, 2008 4:28 pm
Location: Herefordshire, England

Disk Check at startup taking - forever ...

Post by reactiv8 »

I've been using Mint now for a couple of years since Mint 6 and am enjoying weaning myself off that other OS. Along the way I've become familiar with the periodic Disk Checks at startup, and always leave them to do their work. The older versions of Mint used to give useful status progress, but not so with Mint 9 Isadora. My main PC is an HP Pavilion AMD Dual-Core with two 1TB HDDs, dual booting M$ Windoze XP on one and Minty Freshness (32-bit) on the other. Last weekend Disk Check started running and I left it for a couple of hours, but it seemed to be hanging on 90% completion of the first disk ... Being impatient, I interrupted it and booted into Mint with no problems, forgetting about it until last night ... Disk Check started again and this time I left it all night but it didn't even seem to be progressing at all! - Both the drives are about 25% full - One NTFS, the other Ext4 - The NTFS drive is regularly defragmented and in the Ext 4 drive, I always delete old files and browsing history.

Please can my wiser peers tell me what is going on here? Am I being too impatient or is this a known bug in the new version? - I'm using the mentioned hardware to post this and the system seems to be running quite happily as per normal otherwise ...

Thanks,
Chris. :?

User avatar
distrohopper
Level 3
Level 3
Posts: 105
Joined: Wed May 19, 2010 8:14 pm
Location: Toronto, Ontario

Re: Disk Check at startup taking - forever ...

Post by distrohopper »

Unfortunately, I've had this problem too. I have canceled the checks as they start.. If you want to workaround it the 'sort of' fast way is: boot up from a LiveCD or LiveUSB, open a terminal and make sure you've not mounted any of your hard drives. From the command line, run:

Code: Select all

$ sudo blkid
/dev/sda10: LABEL="sda10" UUID="1849db02-713c-4bfd-ab7b-fdbcc957c382" TYPE="ext4" 
/dev/sda11: LABEL="sda11" UUID="9135b2ce-090e-481b-885c-e2ed5e488ac0" TYPE="ext4" 
/dev/sda12: LABEL="sda12" UUID="74cc0034-73e8-4504-ae83-434ceb66570b" TYPE="ext4" 
/dev/sda13: LABEL="sda13" UUID="a4661d3f-b344-4684-a644-7a4961813553" TYPE="ext4"
...
(To get a list of all your drives...)

Then, run:

Code: Select all

fsck -pv /dev/sd<x><y>
Replace <x><y> with the device you want to check. You can do this for all your unmounted drives, I think Mint/Ubuntu only checks the disks somewhere around every 25-30 mounts. If you check them all manually it will go a lot faster and you won't be bothered again for some time. I know it's a crappy bug, but we've got to live with it for now.

User avatar
mick55
Level 6
Level 6
Posts: 1485
Joined: Fri Sep 25, 2009 2:47 am

Re: Disk Check at startup taking - forever ...

Post by mick55 »

Things are more like they are now than they ever were before.

Dwight D. Eisenhower (1890 - 1969)

JasonLG
Level 7
Level 7
Posts: 1602
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Disk Check at startup taking - forever ...

Post by JasonLG »

distrohopper wrote:Unfortunately, I've had this problem too. I have canceled the checks as they start.. If you want to workaround it the 'sort of' fast way is: boot up from a LiveCD or LiveUSB, open a terminal and make sure you've not mounted any of your hard drives. From the command line, run:

Code: Select all

$ sudo blkid
/dev/sda10: LABEL="sda10" UUID="1849db02-713c-4bfd-ab7b-fdbcc957c382" TYPE="ext4" 
/dev/sda11: LABEL="sda11" UUID="9135b2ce-090e-481b-885c-e2ed5e488ac0" TYPE="ext4" 
/dev/sda12: LABEL="sda12" UUID="74cc0034-73e8-4504-ae83-434ceb66570b" TYPE="ext4" 
/dev/sda13: LABEL="sda13" UUID="a4661d3f-b344-4684-a644-7a4961813553" TYPE="ext4"
...
(To get a list of all your drives...)

Then, run:

Code: Select all

fsck -pv /dev/sd<x><y>
Replace <x><y> with the device you want to check. You can do this for all your unmounted drives, I think Mint/Ubuntu only checks the disks somewhere around every 25-30 mounts. If you check them all manually it will go a lot faster and you won't be bothered again for some time. I know it's a crappy bug, but we've got to live with it for now.

A way easier workaround is to edit your fstab file. It's located in /etc. Change the numbers after the options both to 0 from their defaults (note that I have also added the noatime option that doesn't write access times to the file system journal, not related) Mine looks like this.

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=836ce7bf-b50f-4a9f-9113-f091a43eb4ac /               ext4    errors=remount-ro,noatime 0       0
# /home was on /dev/sda5 during installation
UUID=89d43888-011f-453c-97fc-d2e597a9d4d5 /home           ext4    defaults,noatime        0       0
# swap was on /dev/sda6 during installation
UUID=42ee2679-8bcd-477f-b8eb-62e0ce066900 none            swap    sw              0       0
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.

tlu
Level 1
Level 1
Posts: 24
Joined: Tue May 18, 2010 1:29 pm

Re: Disk Check at startup taking - forever ...

Post by tlu »

@"JasonLG": Yes, it's possible to disable disk check with the method provided by you. But I think we agree that regular checks make sense to ensure file system integrity. That's why it's important that this bug will be fixed as fast as possible. Since it seems to be fixed in Lucid but not in Mint I guess it's somehow related to the Mint version of plymouth - see https://bugs.launchpad.net/linuxmint/+bug/583923

User avatar
Canrith
Level 1
Level 1
Posts: 11
Joined: Fri Nov 07, 2008 4:55 am
Location: Nijmegen, The Netherlands

Re: Disk Check at startup taking - forever ...

Post by Canrith »

Try this one in the terminal. The number after c most of the times is 30, change it into 100 or 150 and be sure to check the partition - in this case sda2 - and if necessary change it.

sudo tune2fs -c 100 /dev/sda2
Great minds discuss ideas, average minds discuss events, small minds discuss people

tlu
Level 1
Level 1
Posts: 24
Joined: Tue May 18, 2010 1:29 pm

Re: Disk Check at startup taking - forever ...

Post by tlu »

Canrith wrote:Try this one in the terminal. The number after c most of the times is 30, change it into 100 or 150 and be sure to check the partition - in this case sda2 - and if necessary change it.

sudo tune2fs -c 100 /dev/sda2
Thanks, I knew that. But it doesn't solve the problem discussed here.

JasonLG
Level 7
Level 7
Posts: 1602
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Disk Check at startup taking - forever ...

Post by JasonLG »

tlu wrote:@"JasonLG": Yes, it's possible to disable disk check with the method provided by you. But I think we agree that regular checks make sense to ensure file system integrity. That's why it's important that this bug will be fixed as fast as possible. Since it seems to be fixed in Lucid but not in Mint I guess it's somehow related to the Mint version of plymouth - see https://bugs.launchpad.net/linuxmint/+bug/583923
I realize that. I said it's a workaround not a fix. You got a better idea until it's fixed? It beats the hell out of hard rebooting every 30 restarts. Let me know when it's fixed and I'll gladly change my fstab back to the defaults.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.

altair4
Level 19
Level 19
Posts: 9993
Joined: Tue Feb 03, 2009 10:27 am

Re: Disk Check at startup taking - forever ...

Post by altair4 »

mick55 wrote:
reactiv8 wrote:is this a known bug in the new version?
Unfortunately, it seems to be. :(

https://bugs.launchpad.net/linuxmint/+bug/583923
https://bugs.launchpad.net/linuxmint/+bug/580030
https://bugs.launchpad.net/linuxmint/+bug/588571
To anyone who wants to see this fixed I would suggest adding your voice to any of the bug reports above.

Right now 583923 has been "Confirmed" but the "Importance" is classified as "Undecided".
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
reactiv8
Level 1
Level 1
Posts: 41
Joined: Sun Jul 06, 2008 4:28 pm
Location: Herefordshire, England

Re: Disk Check at startup taking - forever ...

Post by reactiv8 »

Thank you all for your patient replies! - Nice to know I'm not alone and this will be rectified (sometime) by those infinitely more knowledgeable than me! ...

I'll check your command line hints in due course too - Always good to learn along the way with our Lovely Linux!

Regards,
Chris. ;)

gotjazz
Level 4
Level 4
Posts: 383
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: Disk Check at startup taking - forever ...

Post by gotjazz »

hrm I have another problem now - now I also ralized that those checks never finish - the problem is even if I cancel them, mint doesn't boot. It reports errors, which I choose to ignore and after "ignoring errors with /dev/blablabla per user request" it just sits there doing nothing
Image

JasonLG
Level 7
Level 7
Posts: 1602
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Disk Check at startup taking - forever ...

Post by JasonLG »

gotjazz wrote:hrm I have another problem now - now I also ralized that those checks never finish - the problem is even if I cancel them, mint doesn't boot. It reports errors, which I choose to ignore and after "ignoring errors with /dev/blablabla per user request" it just sits there doing nothing
I have the same problem that's why I'm disabling the checks in my fstab all together until the bug is resolved.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.

gotjazz
Level 4
Level 4
Posts: 383
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: Disk Check at startup taking - forever ...

Post by gotjazz »

hrm I just boot something else (my crunchbang partition or one of the live-cds i have flying around) and run fsck from there when that happens
Image

User avatar
tux-sven
Level 3
Level 3
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: Disk Check at startup taking - forever ...

Post by tux-sven »

Try this: As root I manually removed "splash" in the row "linux /boot/vmlinuz......" in file /boot/grub/grub.cfg.
Now for a several restarts it hasn't failed one time. :lol:

tlu
Level 1
Level 1
Posts: 24
Joined: Tue May 18, 2010 1:29 pm

Re: Disk Check at startup taking - forever ...

Post by tlu »

tux-sven wrote:Try this: As root I manually removed "splash" in the row "linux /boot/vmlinuz......" in file /boot/grub/grub.cfg.
No offense meant but editing that file is NOT recommended - see https://help.ubuntu.com/community/Grub2 ... b/grub.cfg. You should rather edit /etc/default/grub accordingly and execute sudo update-grub thereafter.
Now for a several restarts it hasn't failed one time. :lol:
But is this really related to removing splash? I guess if you had canceled the disk check before, the next one will be due only after 30 reboots anyway. You can find this out with

sudo dumpe2fs -h /dev/sdaX | grep -i "mount count"

or alternatively with

sudo tune2fs -l /dev/sdaX | grep -i "mount count"
Last edited by tlu on Sun Jun 13, 2010 11:12 am, edited 1 time in total.

altair4
Level 19
Level 19
Posts: 9993
Joined: Tue Feb 03, 2009 10:27 am

Re: Disk Check at startup taking - forever ...

Post by altair4 »

tux-sven wrote:Try this: As root I manually removed "splash" in the row "linux /boot/vmlinuz......" in file /boot/grub/grub.cfg.
Now for a several restarts it hasn't failed one time. :lol:
You can always find out if any workaround will work for this particular problem by forcing a fsck at boot:

Code: Select all

sudo touch /forcefsck
Then reboot
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
tux-sven
Level 3
Level 3
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: Disk Check at startup taking - forever ...

Post by tux-sven »

My idea about removing "splash" is not meant as a final solution, it's a quick way to come around the problem for the moment so you can use the computer as usual. It could also be a hint for people who can understand the boot process and read the source-code involved. I should guess it is something wrong about the plymouth implementation.
Is the letter "P" often causing problems? (Pulse audio, Plymouth)... :wink:

tlu
Level 1
Level 1
Posts: 24
Joined: Tue May 18, 2010 1:29 pm

Re: Disk Check at startup taking - forever ...

Post by tlu »

tux-sven wrote:My idea about removing "splash" is not meant as a final solution, it's a quick way to come around the problem for the moment
I understand that it's not meant as a final solution but I doubt that it's even a quick way around. For example, if you execute what I suggested for your partitions and you get an output similar like this one
Mount count: 11
Maximum mount count: 30
it's obvious that it's not because of removing splash that you don't have any problems during new restarts any more. The reason for this is rather that the next disk check is simply not yet due.

User avatar
tux-sven
Level 3
Level 3
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: Disk Check at startup taking - forever ...

Post by tux-sven »

tlu, now i have been stopping and starting my system for about 35 times. You are absolutely right. When file-check comes it still hangs!! I can type a "c" or an arrow to get it continue to start. :oops:

My computer, Acer Aspire One D250 very often stopped during boot before. It really stopped! No keys used to help. It stopped in a place just before, or after the line "setting sensor limits". I recognized it as an ongoing file-checking procedure because i could see fsck-rows just before. But it must have been something else. I could even hear the speakers connecting click-sound before the stop.
I had a feeling that fdck was never allowed to finish properly and therefore was run again next boot and almost every boot ..

Anyway my computer starts perfect every time now, until "fsck". Then I obviously need to hit the c or an arrow key. Sorry about the wrong information, but I really thought it was correct. Thank you for teaching me. :)

ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: Disk Check at startup taking - forever ...

Post by ginjabunny »

I had this problem on both my Mint9 systems this weekend, firstly my laptop, I thought there was something seriously wrong, it kept hanging when checking my /home partition, I'd wait for ages but there was no disk activity light then switch it off and the cycle repeated, I ended up taking the drive out and backing it up on my desktop system before running fsck against it which took a couple of seconds and said it was clean, when I put it back in the laptop it booted fine. Then yesterday my desktop did exactly the same, I booted into recovery and ran fsck manually and again it took a couple of seconds and said it was clean.
I have now turned off disk checking on the /home partitions, both are ext4.

There seems to be a problem here

Post Reply

Return to “Newbie Questions”