Desktop GONE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
cpsully69
Level 1
Level 1
Posts: 5
Joined: Wed Jun 09, 2010 9:38 am

Desktop GONE

Post by cpsully69 » Mon Jun 21, 2010 5:30 pm

Running Mint 9 on a Thinkpad x61.
Everything was going great. Shutdown the laptop to leave my office.
When I fired it back up, after the login screen I get the wallpaper and a mouse pointer!
No icons, no menus, no right-click on the wallpaper.
The mouse pointer does move and responds.
Before I shutdown, I was connected to a second monitor (through Fn-F7), the laptop was the primary display device.
Normally, everything comes back just fine when I boot without the external monitor attached.

I can get to TTY via CTRL-alt-F2, but don't know what to do there.

I've deleted ~/.gconf* and ~/.gnome*
I've renamed ~/.config/monitors.xml

When I do a ps, it shows /usr/lib/gdm/gdm-simple-slave --display-id /org/gnome/Display/DisplayManager/Display1

I don't know if that should be on Display0, and how to change it if it is.

Any ideas on how to get my desktop back? I'd even settle for a fresh/default desktop. Just need my menus back!

Thank you.

chattr
Level 2
Level 2
Posts: 58
Joined: Thu Jul 03, 2008 2:43 pm

Re: Desktop GONE

Post by chattr » Mon Jun 21, 2010 10:53 pm

It could be that nautilus is not running. In addition to being a file manager, in gnome, your icons and some other things are managed by nautilus.

When you get to the incomplete desktop, can you open a terminal with <alt>-F2 and typing ' gnome-terminal ' (no quotes)? If you can, in the terminal, type ' nautilus & ' and see if that gets your desktop back. If there are errors printed to the terminal when you do ' nautilus & ', copy and paste the errors here in this forum thread.

cpsully69
Level 1
Level 1
Posts: 5
Joined: Wed Jun 09, 2010 9:38 am

Re: Desktop GONE

Post by cpsully69 » Tue Jun 22, 2010 9:47 am

Thanks chattr!
When I tried to run gnome-terminal, it complained that it couldn't open the display.

I then did a 'export DISPLAY=:0' and that got it to run. I found the gnome-terminal running when I went to ctrl-alt-F7.

so, the terminal was running, but still no icons or menus.

Then I ran nautilus&, that opened in a file manager window, and I got my desktop icons...still no menu bars.

Then I tried gnome-session, that dumped a WHOLE lot of text on the screen...in particular, it was complaining that gnome-wm was not found.

When I tried to run gnome-wm, it tells me it's not installed and to run apt-get install gnome-wm.

I wasn't sure if I wanted/needed to go down that road...it all seems odd to me that this would suddenly disappear after working great for so long.

Post Reply

Return to “Newbie Questions”