[SOLVED] USB Stick not seen?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Spottydog
Level 1
Level 1
Posts: 10
Joined: Wed Nov 17, 2010 7:21 pm

[SOLVED] USB Stick not seen?

Post by Spottydog »

Hello all:

As well as my wireless connection problems, I am experiencing another strange problem that I have no idea of how to fix.

When I plug in a USB stick (it has a file on it to copy on to linux), noting happens. There's no ding - it does not appear on my desktop, or anywhere else for that matter.

The stick works fine in Windoze so I know that the stick is ok.

Ive tried searching this in the forum, but all I seem to find are messages relating to the USB internet sticks.

Thanks so much.
spottydog
Last edited by Spottydog on Thu Dec 02, 2010 11:16 pm, edited 1 time in total.
User avatar
grey1960envoy
Level 4
Level 4
Posts: 476
Joined: Mon Aug 23, 2010 10:21 pm
Location: 3rd rock from the sun

Re: USB Stick not seen?

Post by grey1960envoy »

I had a similar problem with an SD card look at "Mint cannot find SD card" :P I'm sure the response will help you as well.
In a perfect world everything has it's place, Linux on my computer, windows on the wall, and M$ in the trash!
CrunchBang, LMDE, Mint 9 ,Peppermint Hackintosh and a few others :) Registered ...Machine; #432150 user ;#530829
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: USB Stick not seen?

Post by edwardr »

What version of Mint are you using? Main edition, XFCE, KDE, ...?

Try this. Plug in your USB drive. Go to "System" and run the program "Disk Utility". Look for your USB drive in the left pane of Disk Utility and select it. In the right pane, click on "Mount volume" (or something similar, I'm typing this from memory). To the right of that you will see a path appear, like "/media/blahblahblah". Click on that and it should open your file manager to the USB drive. If you get an error message, then open your file manager directly and navigate to the location.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
Spottydog
Level 1
Level 1
Posts: 10
Joined: Wed Nov 17, 2010 7:21 pm

Re: USB Stick not seen?

Post by Spottydog »

I followed your instructions and got as far as Disk Utility - my usb stick is not listed. Any ideas how I can fix this problem? Thanks so much.
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: USB Stick not seen?

Post by edwardr »

It should show up under "Peripheral Devices" like this:

Image



Click on it then click "Mount Volume"

Image
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
Spottydog
Level 1
Level 1
Posts: 10
Joined: Wed Nov 17, 2010 7:21 pm

Re: USB Stick not seen?

Post by Spottydog »

Thanks for the easy to follow instructions haha. But they are of no help because in my disk utility window, the only storage devices that are listed are PATA Host Adapter, my 320 GB hard drive and my CD/DVD Drive. there is Nothing Else in the left hand pane. :(

Any other suggestions?

I'm not having much luck with any of this so far. My internal wireless internet card doesn't seem to want to work, and my eventual solution to that was to purchase an internet USB stick. Of course this is a bit futile, because my usb ports aren't even listed!

I would really love some more assistance here! thanks.

spot
Spottydog
Level 1
Level 1
Posts: 10
Joined: Wed Nov 17, 2010 7:21 pm

Re: USB Stick not seen?

Post by Spottydog »

I forgot to mention I am runnig release 10, editin Gnome 32-bit, on an old Dell Inspiron 6000.
User avatar
colyn
Level 6
Level 6
Posts: 1230
Joined: Sat Aug 14, 2010 1:37 pm
Location: ¿ǝɯ ǝǝs ɐʎ ʇ,uɐƆ ˙ǝɹǝɥ ʇɥƃᴉɹ ɯ,I
Contact:

Re: USB Stick not seen?

Post by colyn »

Try this...open the devise in Windows, copy any files into a temp directory then format the devise NTFS. Next copy the files back onto it then try to open it in Mint. Linux may not recognize some Windows formats but it will see NTFS.
moo
Level 1
Level 1
Posts: 6
Joined: Tue Nov 16, 2010 2:47 am

Re: USB Stick not seen?

Post by moo »

I just replied to your other post re disk utility. After reading this one I see you're having problems with usb.
Try opening a terminal and entering "lsusb" (again, don't type the quotes). If usb is activated you should see something like this:

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If you see the listing but don't see your usb key (providing it's plugged in) then there is a problem with the key or your mint 10 installation (you can test with another usb device eg. another key or a printer). If a command prompt returns without any listing it probably means usb is turned off in the bios. If that is the case reboot and enter setup (usually by pressing the del or f2 key when your system posts) Enter the configuration section for usb and enable it. While your at it, if there is a switch for wireless make sure it's enabled also.
RJ12
Level 1
Level 1
Posts: 8
Joined: Fri Jul 16, 2010 10:40 pm

Re: USB Stick not seen?

Post by RJ12 »

I had a problem with LM 10 where it would not load the usb modules unless it was plugged in at boot time, maybe that is happening for you. If you want to try the fix (It loads the storage module):
Unplug the USB Drive
Next, open a Terminal (Mint Menu > Terminal)
Type (without quotes) "sudo modprobe usb_storage" and press Enter
Enter your user password (It will look as if it isn't typing, but it is) and press Enter
Close the Terminal and plug in the USB Drive, does it work now?
Spottydog
Level 1
Level 1
Posts: 10
Joined: Wed Nov 17, 2010 7:21 pm

Re: USB Stick not seen?

Post by Spottydog »

YAY - you guys rock! Thanks for all the help with my usb problems! The last suggestion of doing sudo modprobe in terminal worked and mycomputer can now see the usb sticks!! I'm sorry it's taken me so long to reply - I haven't been around this past couple of weeks and have only just managed to get back to adressing this issue. This is great.

Now,,,,, if only I could get my internal wireless internet to work :(

Spottydog
RJ12
Level 1
Level 1
Posts: 8
Joined: Fri Jul 16, 2010 10:40 pm

Re: [SOLVED] USB Stick not seen?

Post by RJ12 »

If you want the changes to be saved on reboot, open a terminal and type (without quotes) "gksudo gedit /etc/modules"

Then when the Text Editor opens, put this on a new line (without quotes also) "usb_storage" then press the save button and close the editor (and the terminal if you want to) then when you restart you don't have to do "sudo modprobe usb_storage" all the time.
:D
Post Reply

Return to “Newbie Questions”