Installer for LM 10 deleted all of my partitions

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Sat Nov 21, 2009 7:09 pm

Installer for LM 10 deleted all of my partitions

Post by LukeC » Fri Jan 14, 2011 10:57 am

This is not really a bug in a mint tool, but I did not no what other bug section to post in.

I was installing LM 10 on my machine yesterday so that I could use it for my college python programming class (they give us live ubuntu flash drives, but they're slow and buggy, and I just like mint better). I already had ubuntu, LM 9, and some puppy linux distros installed on my hd along with windows 7. Every ubuntu-based installation up to now I have partitioned my hd beforehand with gparted, and chosen the "Specify Partitions Manually" option because I didn't trust ubiquity to do something as critical as partitioning my hard drive correctly. For whatever reason I was feeling a little lazy yesterday and decided to let the installer automatically do everything for me.

I choose the "Install alongside other operating systems option" and when I got to the screen that asked how I wanted to partition my drive, it had two boxes, one with LM 9, and one with LM 10. It said around 25GB under one, and around 25GB under the other. Together this added up to the size of the partition I currently had LM 9 on,so I assumed that all the installer would change would be the partition I had LM 9 on. I didn't want LM 9 anymore, so I clicked the use entire partition button, expecting that it would erase only that partition.

I click "Install Now" and one of the first things I see is something to the effect of "formatting partition 1 on..." Feeling my stomach drop and the icy cold hands of dread gripping my heart, I fired up gparted only to find that the installer had deleted every partition on my hd, leaving one big ext4 and one swap partition.

To make sure I hadn't done something terribly wrong, I set up a vm in virtualbox like I had my old computer.

My hd before install:

A recovery, windows, ext4 with LM 9, and an extended partition.

This is the first screen I see asking me about partitioning:

There are two buttons at the bottom, a "Use entire partition button" and a "Use entire disk" button. I clicked the "Use entire partition button" and this is what I get:

As far as I can see, there is nothing there to indicate what partition I am installing on or anything of that nature. No warnings, no confirmation, no nothing the entire installation process.

I click the "Install Now" button, and there is no confirmation screen like normal. This is the very next screen I get:

And sure enough, it flashes at the bottom "formatting partition 1 on ...."

And this is the drive afterwards:

So now I am desperately trying to find some software to recover my data. Fortunately I stopped the install before it actually stared copying files, so maybe I can get my data back. I know it's my own stupid fault for not having backups and trusting a linux installer, but it would have been nice to have a little confirmation or warning, like "Hey, you're about to wipe your whole hard drive! Are you sure you want to do that?" I'm sorry if I sound like a jerk, I'm just mildly upset that all my files may be gone. Again, it's my own fault, but I did click the button to use the entire partition, not the entire disk button, and there was never any information on exactly what I would be doing. I remain a supporter of Linux Mint, but that is the last time I ever trust an installer.

Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Re: Installer for LM 10 deleted all of my partitions

Post by robert-e » Sun Jan 16, 2011 2:30 pm

Don't feel too bad; I had occasion to do a test install of LM 10 last week. I DID partition the hard drive with gparted prior to the installation. I choose all ext 3 for /boot. /, /home, and a swap partition. I also formatted. When I ran the installer, it formatted to ext 4, without any prior warning. So I stopped the installation, ran gparted and set everything back to formatted ext 3, and then tried again, this time being careful to try to get the installer to leave the partitions alone. No joy. Therefore, when it is time for me to update the mint os, I shall not likely do so; but rather will seek some other distro that does not take such liberties.
On another note, I sure do not like how Mint branded Firefox has made it exceedingly difficult to stop "Google searching from the address bar." Over the last few years I have found the Google Corp. getting way to intrusive.
Maybe it is just me...but I value my privacy. Shrug.


Post Reply

Return to “Newbie Questions”