Page 1 of 1

How to downgrade a package ?

Posted: Tue Mar 01, 2011 1:49 am
by marX
I need to test a gfx driver for xorg 7.1 which crashed the xorg 7.5 I had. So I need xorg 7.1 to test it and if it works, lock the xorg !

What I don't know is...

1. How to downgrade a package
2. Dealing with dependecies manually
3. Backing up a package

So, please help !
Thanks in advance !!

Re: How to downgrade a package ?

Posted: Tue Mar 01, 2011 7:25 am
by Roken
For many things, you can check if a "downgrade" is available by highlighting in synaptic, going to the "Package" menu and choosing "Force Version". For others you will either have to compile yourself, or find a .deb package of the version that you want. If you find a deb, then dpkg -i packagename.deb in a terminal will install and should take care of dependancies.

However, xorg can be more of a problem (as I recently found out to my cost), and to be honest you probably don't want to downgrade xorg since it's easy to render your system unusable by doing so. A better option in your case may be to post details of the problem with the gfx driver and see if someone can help fix it.