.profile not being executed [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
opensas
Level 1
Level 1
Posts: 5
Joined: Sun Mar 20, 2011 4:01 pm

.profile not being executed [SOLVED]

Post by opensas »

HI, I've just installed latest version of linux mint lxde, and updated it...

I think that my .profile file at $HOME is not being executed, neither .bash_profile not .bash_login

in a text console (ctrl-al-F1..F6) it works ok, the problem seems to be inside lxde, or xorg to be more precise... strange

I tried with lxterminal and with guake, and it's the same

any idea what might be the problem?
Last edited by opensas on Tue Mar 22, 2011 2:18 am, edited 1 time in total.
User avatar
bitmason
Level 2
Level 2
Posts: 68
Joined: Mon Feb 21, 2011 12:27 am
Location: Arizona

Re: .profile not being executed

Post by bitmason »

check for permissions - just to eliminate the possibility:

Code: Select all

ls -l ~/.profile
"The surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us."
- Calvin & Hobbes
opensas
Level 1
Level 1
Posts: 5
Joined: Sun Mar 20, 2011 4:01 pm

Re: .profile not being executed

Post by opensas »

oh, sorry

I really was in a hurry, and just installed ubuntu...

with more time I'll surely give mint lxde another try

--

BTW I've tried manually source .profile and it worked...
deivid
Level 1
Level 1
Posts: 15
Joined: Thu Jan 28, 2010 8:42 pm

Re: .profile not being executed

Post by deivid »

.profile is only supposed to be sourced for login shells (ssh session for example). If you're just opening a terminal window once you've logged into your desktop, only .bashrc is to be sourced.
opensas
Level 1
Level 1
Posts: 5
Joined: Sun Mar 20, 2011 4:01 pm

Re: .profile not being executed

Post by opensas »

you were right!!!

when I updated .profile, I had to source it

messing around with .bashrc did the trick

thanks a lot deivid
deivid
Level 1
Level 1
Posts: 15
Joined: Thu Jan 28, 2010 8:42 pm

Re: .profile not being executed [SOLVED]

Post by deivid »

You are very welcome!
Post Reply

Return to “Newbie Questions”