Mic volume extremely low

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Mic volume extremely low

Post by sagarchandratrey »

Hi
I installed audacity and skype.

However the mic input volume is extremely low even after making in 100 percent in the sound settings.

Is there a solution to this problem...I have been facing sound issues in every installation of Mint.

I don't want to use Windows just for Sound recording.All my other work I always manage and enjoy in Mint.

Sagar
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

In a terminal run:

Code: Select all

alsamixer
Check the position of the MIC, LINE, PCM, GAIN, 3D, etc controls. (whatever your sound card shows listed) You may need to increase the level on several of these. Sometimes the GUI controls do not work properly, so try the terminal.

Also if this is a USB style mic, try different ports, and if you can, try a different mic as well to see whether this is not an issue with the mic that you are using.

Post back your results. If you still need help, one of us will try and help you....
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

Hi Slider
Thanks for replying.

When I run alsamixer in the terminal nothing happens.

I have installed Synapse and when I type in Alsa mixer in the prompt box,I am suggested Gnome Alsa mixer which I select to launch.But I get a busy curson and no screen is thrown up.

I have set the mic input to 100% in the basic sound setup which I get in the tray icon.

Sagar
Inkit
Level 5
Level 5
Posts: 678
Joined: Fri Jun 25, 2010 4:44 am

Re: Mic volume extremely low

Post by Inkit »

Hi Sagar, have you tried changing the sound preferences. Generally if you right click on the same icon, the preferences menu will open up. Check if the input volume there is right up.
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

Alsa.png
Alsa.png (7.18 KiB) Viewed 9378 times
Yep I have tried that.I have also managed to get a GUI version of ALSA mixer and set the Master and Mic volumne to maximum in both.The input volume still remains low.
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

These are my sound settings
Attachments
Sound settings.png
Sound settings.png (21.79 KiB) Viewed 9377 times
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

Hi sagarchandratrey
When I run alsamixer in the terminal nothing happens
Nothing? Did you type it into a terminal then press enter key? (I don't mean this in a condescending way, I'm sure that you did press it, just need to make sure) :wink: Lets check if you have it installed. This is not the same as the GUI program.
Run:

Code: Select all

aptitude show alsa-utils
Read the package state.


My first thought would be that your internal mic gain is probably turned down too low. This is sometimes a connected problem with external mics, even though they are a separate entity from the internal device. Sound-card module issue perhaps?

If you can, have you tried another mic? Also does your internal mic record OK? Test with audacity and record a sound-file that is playing on your system.

Run in terminal:

Code: Select all

inxi -A

Code: Select all

lsmod | grep snd

Code: Select all

arecord -l
with your mic connected and post here.

If you have time run:

Code: Select all

aptitude search pulseaudio
and post any pulseaudio packages that you see installed. An i at the beginning of the package name will denote installed.

Please let us know :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

Hi Slider
Thanks again for responding.

Here is the score
When I run the command alsamixer in the Terminal(And Press Enter ;) )

I get an invalid argument message

I have Synapse install which suggests me Gnome Alsa mixer.I launch this but I get just a busy cursor and no app is shown up.

I am pasting my screenshots below as per the directions.
Terminal1.png
Terminal1.png (75.61 KiB) Viewed 9336 times
Terminal2.png
Terminal2.png (84.12 KiB) Viewed 9336 times
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

Also,the state of the Alsa Utils is installed
Terminal 3.png
Terminal 3.png (42.38 KiB) Viewed 9344 times
User avatar
neernitt
Level 1
Level 1
Posts: 16
Joined: Tue Mar 01, 2011 3:37 pm
Location: Bangladesh
Contact:

Re: Mic volume extremely low

Post by neernitt »

Got some good solutions for ma friends. :mrgreen:
▒▐█▀▀▒▐██▒▐█▀▀▄▒▐█▀▀█▌▒▐█▀▀▀█▌░░
▒▐█▀▀░▒█▌▒▐█▒▐█▒▐█▄▒█▌░▒▄▄█▀▀░░░
▒▐█░░▒▐██▒▐█▀▄▄▒▐██▄█▌▒▐█▄▄▄█▌░░
Open Source Software Enthusiast | Linux Mint User | GNOME Fan| Hip Hop music Addict.
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

The mic works fine under windows..This has something to do with some setting which I am not able to locate.
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

sagarchandratrey

I forgot to ask you this before (my apologies) :oops: , but what version are you using. Please run

Code: Select all

cat /etc/*release
or

Code: Select all

lsb_release -a
I hate to post partial or bad answers. Ive been tracing a few bug reports and module issues related to this.... There are very many.... :?

What happens when you un-tick the output volume in your 2nd posted image?
The mic works fine under windows..This has something to do with some setting which I am not able to locate.
Thanks, that helps us know that the mic is OK. I agree and that is the problem that I've been looking into first. It may solve the others as well. Unfortunately so far, it seems to have several possible causes and they vary in difference from distro to distro. Knowing which version you have should help us on this, hopefully. We may need to add an option to the alsa-base file?

Did you try to record with your internal mic yet, and if so ,what was the outcome?

Do you have a .asoundrc or similar file on your system? You can use the find or better, the locate command. Should be in your home directory.

Run

Code: Select all

amixer
and see if you have any entries there and how many. It should show information about each as well.

I'll report back ASAP.
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

neernitt wrote:Got some good solutions for ma friends. :mrgreen:
LOL! :lol:

If you already have a good working solution please post it here and save us all some work!

:)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

I am on Linux Mint 10.

I looked at other posts which had a similar problem.A suggestion is to add an entry to the alsa-base.conf file under /etc/modprobe.d

I tried doing that and then rebooting and running thhe alsamixer command in the terminal.

But still am getting the same error message.

Also tried to locate the asoundrc file.Doesnt seem to be there under Home.
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

sagarchandratrey

It is important that you run the commands that I ask you to in order to provide me with the complete information that I need to best try and help you.

Also if you can please try and record with the internal mic that would be great.

Running the amixer command that I asked you for would also be great, then report what you see.

Without physical access to your system I can not see or test what is going on there. This is where I need your help to relay what you see.

I am on Linux Mint 10.
Great. Linux Mint 10 Gnome is what I will base on then.
I looked at other posts which had a similar problem.A suggestion is to add an entry to the alsa-base.conf file under /etc/modprobe.d
Yes this is part of what I looked into already all over the web, but I didn't have much faith that it would work. You may want to return the file to default, if you haven't already, as any changes can effect other things we may have to try.

I do not believe in adding of removing software as first choice, unless it is fairly obvious that it is a good fix. I think that it is far better to move slowly. Less chance to bork a system.

I would like to suggest disabling pulseaudio (PA) sound server temporarily, reverting back to alsa. This is a known fix in some cases. Removing PA can sometimes have other consequences that can be hard to fix easily, if at all. If we just disable PA for a test this will do no permanent damage. As a matter of fact if everything goes well, it can sometimes be left disabled instead of removing. There are a lot of particulars in trying to do this correctly, due to the PA daemon being very redundant and hard to keep from re-spawning.

If you are interested in preceding with me helping you, please backup all of your important data that you do not want to possibly lose, then post back with the commands and results that I have asked you for as listed in previous posts, thanks.
Or
These are two links that I found that are closest to what I would plan to do. With just some slight modification to them here and there though.
http://www.linuxplanet.com/linuxplanet/ ... ls/7130/2/
http://www.webupd8.org/2010/03/how-to-s ... ad-of.html
Doing these very carefully and mixing them where needed may get you up and going without all of the pitfalls of total force removal of PA.
You can try this yourself if you want or maybe someone else will post a better solution. I'll try to monitor this thread best that I can, as my changing schedule permits.

Either way, I wish you best results!

Kind Regards,
S :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
sagarchandratrey
Level 1
Level 1
Posts: 29
Joined: Tue Jul 21, 2009 11:32 pm

Re: Mic volume extremely low

Post by sagarchandratrey »

Hello Slider
Thanks for the reply.

I ran killall pulseaudio in the Terminal and that solved the problem.

Now I have removed Pulseaudio from the Startup Apps.

That should fix the problem permanently :)
User avatar
mads
Level 6
Level 6
Posts: 1293
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: Mic volume extremely low

Post by mads »

sagarchandratrey wrote:That should fix the problem permanently :)
This should definitely fix the problem permanently: Completely remove PulseAudio & replace it with ALSA.
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

I ran killall pulseaudio in the Terminal and that solved the problem.
Yes, from the start I figured that would fix things. It usually does, but not on every system, especially if the problem was not related to PA.

Now I have removed Pulseaudio from the Startup Apps.
After you restart your system run a process viewer and check to see if the PA sound-server daemon has not re-spawned. You may want to do this more than a few times. If you see strange symptoms re-appear check this first.

Easy way run

Code: Select all

pstree
and look for it there or you can use your favorite GUI process viewer.

Personally I don't use pulseaudio. I use alsa which has native oss-emulation and has always worked great for me. However, I can't just make a broad recommendation such as "removing PA to everyone". I've seen that bork a few systems in ways that required an OS re-install. Data backup is important before doing any hacks.

If you need any more help just re-post and when you feel that this is solved for you, please edit the subject post in your original post and add Solved. This helps other users.

Kind Regards,
S
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Mic volume extremely low

Post by slider »

mads wrote: This should definitely fix the problem permanently: Completely remove PulseAudio & replace it with ALSA
Hi mads

Yes you and I both agree on this! Your "How to" is very nice.

However, as stated before "forced removal" on some systems can leave them in a very sorry state. I think that these are rare, but you never know sometimes until it is too late. Disabling as a test is safer first just to make sure that the problem is related, unless it is very obvious already. Just my humble opinion. :)

Quotes from your "How to":
Please note: There is no reason to remove PulseAudio unless you are having some issues with it.
Very good advice!
Suggestions are welcome!
If I may, you might want to add something to your post there about backing up critical/ important data first before trying any of the steps that you recommend, just in case. Because know one ever really knows the outcome for sure and sometimes users may forget that this is an important step that can save them a lot of grief later.

Thank you for posting and helping!

Kind Regards,
S :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain
User avatar
mads
Level 6
Level 6
Posts: 1293
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: Mic volume extremely low

Post by mads »

slider wrote:
Suggestions are welcome!
If I may, you might want to add something to your post there about backing up critical/ important data first before trying any of the steps that you recommend, just in case. Because know one ever really knows the outcome for sure and sometimes users may forget that this is an important step that can save them a lot of grief later.
Thank you slider. It looks like this now:

Please note:
- There is no reason to remove PulseAudio unless you are having some issues with it.
- Back up your critical/important data before trying any of the steps.
Post Reply

Return to “Newbie Questions”