Printer enable

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Printer enable

Post by The Doctor » Thu Apr 21, 2011 6:19 pm

Everytime I boot up, I have to first enable the printer before I can use it. Is there a way to set it so that it is enabled on boot up?

User avatar
vrkalak
Level 12
Level 12
Posts: 4418
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: Printer enable

Post by vrkalak » Thu Apr 21, 2011 6:24 pm

Details!! We need details.

What Linux OS-distro are you using? and distro version?
Desktop Environment?

Computer information?
Printer information?

Inquiring minds want to know? :mrgreen:
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Almost all problems have a hardware component - run lspci in a terminal.
If it is a USB device also include lsusb

Include both of these terminal error messages in your response.
Image
:: Debian-Sid (Xfce/Fluxbox) :: LinuxMint-18 (LTS) LXDE w/Openbox ::
Registered Linux User: #497031 :: My DeviantART Page

The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Re: Printer enable

Post by The Doctor » Thu Apr 21, 2011 6:58 pm

I thought that it would be obvious that I was using Linux Mint since I was posting in a Linux mint forum. I don't know how to find the version or desktop environment. I changed my computer to Linux mint a few months ago.

Wouldn't it be obvious with the question. If you have to enable the printer each time before you use it, is there a way to make it enabled when you start up. Does it matter which version? If this is a problem, wouldn't the problem identify the problem?

Details!! We need Details. Don't you think this type of language is insulting to a new user? I do. Especially with the double !! and the repeat. It's like saying, you'r an idiot. Don't you know what to do. Obviously if I knew what to do, I wouldn't be asking.

I have used the forum before and never got such a put down type of remark. This forum used to be very friendly and new user easy. Don't tell me this forum is going the way of the SuSE forums. Oh, they got bettter. Is this forum getting upity?

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Thu Apr 21, 2011 9:38 pm

Everytime I boot up, I have to first enable the printer before I can use it. Is there a way to set it so that it is enabled on boot up?
If by enabled are you referring to having to start the printer? In other words does it show that it is stopped? The CUPS daemon is running?

Code: Select all

pstree
Look for cupsd.


Without more specific info, just off the top of my head, you can try the following if you want:

Run

Code: Select all

sudo cat /etc/cups/printers.conf
look for the line Accepting and make sure that it says Yes, and not No.

If you see No, open the file as root and change it to Yes > save > close > reboot your system to test.

Please let us know if this helps....
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

User avatar
vrkalak
Level 12
Level 12
Posts: 4418
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: Printer enable

Post by vrkalak » Thu Apr 21, 2011 10:17 pm

The Doctor wrote:I thought that it would be obvious that I was using Linux Mint since I was posting in a Linux mint forum. I don't know how to find the version or desktop environment. I changed my computer to Linux mint a few months ago.
There are many regular members that use this Forum, that do not use LinuxMint and ask questions about the Linux OS they do use. As Mint and Ubuntu are so very similar.
There are now, 2 different OS-base versions of LinuxMint > Ubnutu and Debian (they are not interchangeable nor compatible) not mentioning the various Desktop Environments and Window Managers.
Each of the basic Desktop Environments (Gnome, KDE, Xfce, LXDE, Fluxbox) react and supports 3rd Party Apps and Hardware differently.
The Doctor wrote:Wouldn't it be obvious with the question. If you have to enable the printer each time before you use it, is there a way to make it enabled when you start up. Does it matter which version? If this is a problem, wouldn't the problem identify the problem?
As well as, having the Printer hardware specs - as some hardware is not compatible nor does it support using Linux. Having this information would be extremely helpful.
The Doctor wrote:Details!! We need Details. Don't you think this type of language is insulting to a new user? I do. Especially with the double !! and the repeat. It's like saying, you're an idiot. Don't you know what to do. Obviously if I knew what to do, I wouldn't be asking. . . . Is this forum getting upity?
I do not believe that my response was in any way degrading, derogatory nor 'uppity'.
I am a Moderator of this Forum and have always been helpful, respectful and supportive of LinuxMint, Open Source and all it's members.
I do however have a great sense of humor.
Image
:: Debian-Sid (Xfce/Fluxbox) :: LinuxMint-18 (LTS) LXDE w/Openbox ::
Registered Linux User: #497031 :: My DeviantART Page

User avatar
odo5435
Level 4
Level 4
Posts: 374
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: Printer enable

Post by odo5435 » Thu Apr 21, 2011 10:32 pm

The Doctor wrote:I don't know how to find the version or desktop environment.
In your menu, under Applications, click on Administration and then System Monitor in the sub-menu. Click on the System tab in the window that appears and you'll find both your version and desktop environment.
The Doctor wrote:Wouldn't it be obvious with the question. If you have to enable the printer each time before you use it, is there a way to make it enabled when you start up. Does it matter which version?
For someone who has been a member of this forum since 2008 and made close to fifty posts, you should be aware that LinuxMint comes in several different versions (Gnome, KDE, XFCE, etc.) and that each version might require a different approach to problem handling.
The Doctor wrote:...wouldn't the problem identify the problem?
It depends on how the problem is posed. To use your nickname as an analogy, it is like someone going to a doctor and saying "I'm sick" and then expecting to be cured without providing any further information.
The Doctor wrote:Details!! We need Details. Don't you think this type of language is insulting to a new user? I do.
I don't. Admittedly, the request might have been put in milder terms but I merely saw it as lighthearted. That's the problem with written communication, words cannot be put in context with the writer's intention; as body language would do in spoken exchanges. Your (over-?) reaction might be at odds with what the writer intended. And having been around these forums for over three years hardly qualifies you as 'new'.
The Doctor wrote: Is this forum getting upity?
No.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon

The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Re: Printer enable

Post by The Doctor » Fri Apr 22, 2011 8:44 pm

The printer is accepting. I am using Linux Mint 9 Isadora. I'm surprised no one told just to hover the mouse over the menu button and the name would come up. I have a Epson Artisan 710 printer. When I boot up and then try to print something, nothing happens. I have to go into the control center, hardware, printer and double click the Epson printer icon, go to polices and I find that the choice "enabled" is not checked. I check it and then I can print.

Is there a way to make the choice "enabled" always checked when I boot the machine on? When I turn the machine off and then the next time I reboot the computer, I have to "enable" the printer again.

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sat Apr 23, 2011 12:08 am

Hello The Doctor,

Ok, I need for you to please post the outputs of the following commands from your terminal as user after you restart your system. (Please do not enable your printer before running the commands)

Code: Select all

id
or

Code: Select all

groups

Code: Select all

lpstat -t
If the printer shows enabled at first, try to start a job. If unable to start a job re-run the last command again post the output if it has changed from the first time the command was run. In other words, I need to compare the two outputs of the lpstat -t commands if they are different.
Is there a way to make the choice "enabled" always checked when I boot the machine on?
That is what we are working towards. This is normally done automatically, as long as you have permissions to use the printer.
Everytime I boot up, I have to first enable the printer before I can use it
Since you are able to use it once enabled you must already have permissions? Are you having to enter a password to enable it? I may have a dirty little hack that may make a work-around, but lets try the right way first OK.

Edit:
Also I forgot to ask this > Have you tried re-installing the printer yet? Sometimes this is a very simple fix as anomalies do happen. You may wanna give that a try first.
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

Beardedragon
Level 4
Level 4
Posts: 350
Joined: Sat Jan 29, 2011 3:37 am

Re: Printer enable

Post by Beardedragon » Sat Apr 23, 2011 9:08 am

The Doctor wrote:The printer is accepting. I am using Linux Mint 9 Isadora. I'm surprised no one told just to hover the mouse over the menu button and the name would come up. I have a Epson Artisan 710 printer. When I boot up and then try to print something, nothing happens. I have to go into the control center, hardware, printer and double click the Epson printer icon, go to polices and I find that the choice "enabled" is not checked. I check it and then I can print.

Is there a way to make the choice "enabled" always checked when I boot the machine on? When I turn the machine off and then the next time I reboot the computer, I have to "enable" the printer again.
System>Printing, highlight that printer and under Printer Menu "Make Default"
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sat Apr 23, 2011 11:57 am

@Beardedragon
System>Printing, highlight that printer and under Printer Menu "Make Default"
Yes that is why we need to see the output from lpstat -t. It will show the default as > system default destination: <printer_name> :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

Beardedragon
Level 4
Level 4
Posts: 350
Joined: Sat Jan 29, 2011 3:37 am

Re: Printer enable

Post by Beardedragon » Sat Apr 23, 2011 1:19 pm

slider wrote:@Beardedragon
System>Printing, highlight that printer and under Printer Menu "Make Default"
Yes that is why we need to see the output from lpstat -t. It will show the default as > system default destination: <printer_name> :)
If he had done that you would not need to see the results. Just giving him a solution, not trying to get in your way.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64

The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Re: Printer enable

Post by The Doctor » Sat Apr 23, 2011 1:39 pm

It has been listed as the default printer, but I still have to enable it each time I turn the printer on. Maybe I have to do something as Root?

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sat Apr 23, 2011 2:31 pm

The Doctor wrote:It has been listed as the default printer, but I still have to enable it each time I turn the printer on. Maybe I have to do something as Root?
I can not help you unless you post the outputs of the commands that I have listed above. Perhaps someone else will, but I personally, do not like to blindly issue commands that may not even help you or may even make things worse in some cases.

I am not there to see your system, so I must depend on your help in order to help you.

Kind Regards,
S :)

Edit: Turn the printer on before booting.... Make a difference?
Last edited by slider on Sat Apr 23, 2011 2:51 pm, edited 1 time in total.
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sat Apr 23, 2011 2:49 pm

Beardedragon wrote:
slider wrote:@Beardedragon
System>Printing, highlight that printer and under Printer Menu "Make Default"
Yes that is why we need to see the output from lpstat -t. It will show the default as > system default destination: <printer_name> :)
If he had done that you would not need to see the results. Just giving him a solution, not trying to get in your way.
You are not getting in my way and I took no offense to your post whatsoever. :) Please remember that we are all a team, so I meant no offense in my last reply to you. Many times when helping, it takes more than one person to solve a problem, as no one person can think of every possible solution.

I do not maintain an "ego" here, but am here just to help support the users. It is really all about them right, not about who helps them, as long as we try and meet their needs!

Side note: Being a default printer or not should not make it disabled at boot. Sounds more like a permissions issue maybe. Just my experience and humble opinion though, which is not always correct.

Thank you for helping! :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Re: Printer enable

Post by The Doctor » Sat Apr 23, 2011 5:16 pm

groups
william adm dialout cdrom plugdev lpadmin admin sambashare

id
uid=1000(william) gid=1000(william) groups=4(adm),20(dialout),24(cdrom),46(plugdev),105(lpadmin),119(admin),122(sambashare),1000(william)


lpstat -t
scheduler is running
system default destination: Artisan-710
device for Artisan-710: usb://EPSON/Artisan%20710
device for Print_to_PDF: cups-pdf:/
Artisan-710 accepting requests since Thu 21 Apr 2011 06:12:40 PM EDT
Print_to_PDF accepting requests since Thu 16 Aug 2007 06:15:50 PM EDT
printer Artisan-710 is idle. enabled since Thu 21 Apr 2011 06:12:40 PM EDT
printer Print_to_PDF is idle. enabled since Thu 16 Aug 2007 06:15:50 PM EDT

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sun Apr 24, 2011 2:45 am

The Doctor

Thank you for posting your output. *(Note: You still have not said whether you have tried reinstalling this printer yet?)

The output looked fine to me, you are in the lpadmin group, system default and device match, printer is accepting and enabled. One thing that looked strange was > "Print_to_PDF accepting requests since Thu 16 Aug 2007 06:15:50 PM EDT". If your are running LM 9 this must be an anomaly? It shouldn't be a cause for this problem though. I have yet to see this before or even this exact problem with a printer when groups and permissions are correct.

*Important: Please try the following command first before anything else:

Code: Select all

sudo /usr/sbin/cupsenable -U your_username Artisan-710
(I may need to change or modify the syntax, not sure) Do this instead of using the control center GUI. Try a print job > If unable to print > post error messages > try the next step below.

Log out or restart > go to your CUPS page http://127.0.0.1:631/printers/ then click Set Allowed Users button under your printer listing > enter your username in the field > click allow these users to print > click Set Allowed Users button > try a print job > If you are unable to print go to the next step below.


Please go to your CUPS page and try the following at each step:
http://127.0.0.1:631/admin?op=config-server Then click the Use Default Configuration File button > Save Changes.

Then http://127.0.0.1:631/admin tick the Save debugging information for trouble shooting > Change Settings.

Log out or restart > try a print job > If you can't print, go to http://127.0.0.1:631/admin click on view error log button and post the output here.

In order to prevent false test results you will need to log out or restart in the order as asked above in each step (restart is probably the best and assures completeness) and post requested errors or logs. Without these I am shooting at a target in complete darkness.

Please be as verbose with information as you can when making posts. Thank you for your patience. :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

The Doctor
Level 2
Level 2
Posts: 50
Joined: Sat Jan 26, 2008 1:45 pm

Re: Printer enable

Post by The Doctor » Sun Apr 24, 2011 12:31 pm

I am sorry, all that is way more than I have any idea of how to do.

slider
Level 5
Level 5
Posts: 579
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: Printer enable

Post by slider » Sun Apr 24, 2011 6:17 pm

The Doctor

I've tried to keep things as easy as possible. The first test was to just run the command syntax that was listed. You are already familiar with how to do that. Then the links containing 127.0.0.1 are click-able inside your web browser and will refer you to your "locahost loopback" address at port #631 (the listening port for printers). This is the standard GUI (Graphical User Interface) page for CUPS (Common Unix Printing System), which will allow you to administrate everything to do with printers, using a graphical environment. I listed the buttons and important things to look for in bold font. One of the most important things was the restarts in between tests and in certain order. I asked for this for a reason, so as to have a guaranteed fresh start of all programs, which should prevent contamination from previous tests or commands. This is why they are in a specific order.

I feel very confident that you can do these tests. I will not give up on you unless you give up on yourself and that is your choice alone.

If your will please post what or which things that you do not understand, I will do my best to give you an quantified answer and help you through it.


Other Options: Reinstall your printer (I have ask you this question several times now with no reply), Try a Mint Live Disc (maybe even a newer version)- see if the results are the same, Backup your important data and reinstall your operating system.


As you can see testing is necessary and should be done carefully if one wants accurate results.

I was considering a possible "dirty hack" with the /usr/sbin command that was posted (full syntax except without sudo) being added to your rc.local file. Since you did not run or post any test results how can I advise you? I'm not really sure that particular syntax or even the run level at which rc.local runs at would be correct for this function. That is why I needed you to test this. I would prefer to find a better fix than this method. The CUPS pages tests may solve your problem, that being a more proper way.

Kind Regards
S :)
"In the beginning of a change the patriot is a scarce man, brave and hated and scorned. When his cause succeeds the timid join him for then it costs nothing to be a patriot."
Mark Twain

User avatar
fragus
Level 1
Level 1
Posts: 18
Joined: Tue Feb 05, 2008 4:41 pm
Location: france

Re: Printer enable

Post by fragus » Sun May 29, 2011 3:53 am

@ slider

Thank you for the solution proposed in your post.
Yesterday, I switch to Mint 11 from Mint 9, and found out that I could no longer enable my network printer (Brother HL-2150N).
I followed your suggestion and used the CUPS page.
Now all is in order. It was even fun to do!

Thank a lot
:D

Post Reply

Return to “Newbie Questions”