Keyboard layout not remembered

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
hinks
Level 1
Level 1
Posts: 7
Joined: Thu Jun 09, 2011 3:45 am

Keyboard layout not remembered

Post by hinks » Thu Jun 09, 2011 3:49 am

Hi,

I've set wrong keyboard layout at install time, some letters are swapped so .. I wanted to fix this.

I've added correct layout and removed the initial one. New layout only works for current session, after power cycle the old layout is active again, and new layout can be selected. I've clicked 'Apply System-Wide' but the effect is always the same..

holadebeto
Level 2
Level 2
Posts: 69
Joined: Sun Jun 12, 2011 4:41 pm

Re: Keyboard layout not remembered

Post by holadebeto » Wed Jun 15, 2011 6:01 pm

Anybody else going bonkers over losing default values for keyboard layout?

If you have a secret or a way to eliminate the USA (no, I really like the country), please put it out here. I need to use a Spanish keyboard (es)

I've tried dpkg-reconfigure keyboard-configuration
I've tried setxkbmap es
I've tried the Keyboard Preferences
I've tried system config desktop/gnome/peripherals/keyboard/layout to es

When I go to type something, when I least expect it, WHAM!, I type a / and & comes up. :)

If this is something that's coming down the road on upgrades/updates, then forgive me.

Thank you

Nevermore
Level 1
Level 1
Posts: 3
Joined: Mon Jun 13, 2011 4:29 pm

Re: Keyboard layout not remembered

Post by Nevermore » Wed Jun 15, 2011 6:48 pm

I also have this problem. It turns back to usa everytime I reboot, if the screensaver comes on, and if it simply finds it pleasing to do so...

User avatar
rich_roast
Level 6
Level 6
Posts: 1125
Joined: Sat Sep 05, 2009 4:37 pm

Re: Keyboard layout not remembered

Post by rich_roast » Fri Jun 17, 2011 3:03 pm

Is there still a file at this location?

Code: Select all

~/.linuxmint/skl
If so you need to edit that. If not it's been a while since I used Linux Mint.

Kendall
Level 6
Level 6
Posts: 1120
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA
Contact:

Re: Keyboard layout not remembered

Post by Kendall » Fri Jun 17, 2011 3:16 pm

~/.linuxmint/skl has only ever been present on the LXDE and Fluxbox editions. If you're using either of these then this is definitely the correct place to set the keyboard layout.
I'm on Twitter: @kendalltristan
My website: kendalltristan.com
My blog: blog.kendalltristan.com

User avatar
Tony.B
Level 2
Level 2
Posts: 60
Joined: Mon Oct 25, 2010 3:51 pm
Location: Kent, UK & KZN, South Africa

Re: Keyboard layout not remembered

Post by Tony.B » Fri Jun 17, 2011 3:22 pm

Menu > Applications > Preferences > Keyboard worked ok for me in LM9, but perhaps this has changed for later versions.

I hope this helps

holadebeto
Level 2
Level 2
Posts: 69
Joined: Sun Jun 12, 2011 4:41 pm

Re: Keyboard layout not remembered

Post by holadebeto » Fri Jun 17, 2011 7:05 pm

Wouldn't ya know it? I just "fixed" the problem, made sure it was working correctly and then went to post it here and see the posts from you folks giving us another thing to try. Rats!

Anyway, what I did was installed gdm, (which uninstalls gdm3) went to log in properties, set auto login, and everything works fine - the keyboard has maintained my default español. Since it works so well, I'm going to live with this unless someone tells me it was a stupid thing to do. :)

Post Reply

Return to “Newbie Questions”