apt-get update/upgrade error in Mint 11

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
exoshwarze
Level 1
Level 1
Posts: 2
Joined: Mon Jun 13, 2011 10:04 am

apt-get update/upgrade error in Mint 11

Post by exoshwarze »

When I do apt-get update I get this result:

exo@behemoth ~ $ sudo apt-get update
[sudo] password for exo:
Ign file: binary/ InRelease
Ign file: binary/ Release.gpg
Ign file: binary/ Release
Ign file: binary/ Translation-en_CA
Ign file: binary/ Translation-en
Ign http://packages.linuxmint.com katya InRelease
Ign http://security.ubuntu.com natty-security InRelease
Get:1 http://packages.linuxmint.com katya Release.gpg [198 B]
Ign http://archive.canonical.com natty InRelease
Ign http://extras.ubuntu.com natty InRelease
Get:2 http://security.ubuntu.com natty-security Release.gpg [198 B]
Hit http://archive.canonical.com natty Release.gpg
Hit http://extras.ubuntu.com natty Release.gpg
Get:3 http://packages.linuxmint.com katya Release [16.5 kB]
Get:4 http://packages.medibuntu.org natty InRelease [7,092 B]
Ign http://ppa.launchpad.net natty InRelease
Ign http://archive.ubuntu.com natty InRelease
Get:5 http://security.ubuntu.com natty-security Release [27.2 kB]
Hit http://archive.canonical.com natty Release
Hit http://extras.ubuntu.com natty Release
Ign http://archive.ubuntu.com natty-updates InRelease
Err http://packages.medibuntu.org natty InRelease

Get:6 http://packages.linuxmint.com katya/main amd64 Packages [8,562 B]
Hit http://archive.canonical.com natty/partner amd64 Packages
Ign http://ppa.launchpad.net natty InRelease
Hit http://archive.ubuntu.com natty Release.gpg
Hit http://extras.ubuntu.com natty/main amd64 Packages
Get:7 http://packages.linuxmint.com katya/upstream amd64 Packages [16.0 kB]
Ign http://archive.canonical.com natty/partner TranslationIndex
Get:8 http://archive.ubuntu.com natty-updates Release.gpg [198 B]
Ign http://extras.ubuntu.com natty/main TranslationIndex
Get:9 http://security.ubuntu.com natty-security/main amd64 Packages [34.1 kB]
Get:10 http://packages.linuxmint.com katya/import amd64 Packages [5,844 B]
Hit http://ppa.launchpad.net natty Release.gpg
Hit http://archive.ubuntu.com natty Release
Get:11 http://archive.ubuntu.com natty-updates Release [27.2 kB]
Ign http://packages.linuxmint.com katya/import TranslationIndex
Ign http://packages.linuxmint.com katya/main TranslationIndex
Ign http://packages.linuxmint.com katya/upstream TranslationIndex
Hit http://ppa.launchpad.net natty Release.gpg
Get:12 http://security.ubuntu.com natty-security/restricted amd64 Packages [14 B]
Get:13 http://security.ubuntu.com natty-security/universe amd64 Packages [17.2 kB]
Get:14 http://security.ubuntu.com natty-security/multiverse amd64 Packages [1,932 B]
Hit http://ppa.launchpad.net natty Release
Hit http://archive.ubuntu.com natty/main amd64 Packages
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Hit http://ppa.launchpad.net natty Release
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Hit http://ppa.launchpad.net natty/main Sources
Ign http://archive.canonical.com natty/partner Translation-en_CA
Ign http://extras.ubuntu.com natty/main Translation-en_CA
Hit http://ppa.launchpad.net natty/main amd64 Packages
Ign http://archive.canonical.com natty/partner Translation-en
Ign http://extras.ubuntu.com natty/main Translation-en
Ign http://ppa.launchpad.net natty/main TranslationIndex
Hit http://ppa.launchpad.net natty/main Sources
Hit http://ppa.launchpad.net natty/main amd64 Packages
Ign http://ppa.launchpad.net natty/main TranslationIndex
Hit http://archive.ubuntu.com natty/restricted amd64 Packages
Ign http://packages.linuxmint.com katya/import Translation-en_CA
Ign http://packages.linuxmint.com katya/import Translation-en
Ign http://packages.linuxmint.com katya/main Translation-en_CA
Ign http://packages.linuxmint.com katya/main Translation-en
Ign http://packages.linuxmint.com katya/upstream Translation-en_CA
Ign http://packages.linuxmint.com katya/upstream Translation-en
Hit http://archive.ubuntu.com natty/universe amd64 Packages
Ign http://ppa.launchpad.net natty/main Translation-en_CA
Ign http://ppa.launchpad.net natty/main Translation-en
Ign http://ppa.launchpad.net natty/main Translation-en_CA
Ign http://ppa.launchpad.net natty/main Translation-en
Ign http://security.ubuntu.com natty-security/main Translation-en_CA
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_CA
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_CA
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_CA
Ign http://security.ubuntu.com natty-security/universe Translation-en
Hit http://archive.ubuntu.com natty/multiverse amd64 Packages
Ign http://archive.ubuntu.com natty/main TranslationIndex
Ign http://archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://archive.ubuntu.com natty/restricted TranslationIndex
Ign http://archive.ubuntu.com natty/universe TranslationIndex
Get:15 http://archive.ubuntu.com natty-updates/main amd64 Packages [128 kB]
Get:16 http://archive.ubuntu.com natty-updates/restricted amd64 Packages [14 B]
Get:17 http://archive.ubuntu.com natty-updates/universe amd64 Packages [50.7 kB]
Get:18 http://archive.ubuntu.com natty-updates/multiverse amd64 Packages [3,661 B]
Ign http://archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://archive.ubuntu.com natty/main Translation-en_CA
Hit http://archive.ubuntu.com natty/restricted Translation-en_CA
Ign http://archive.ubuntu.com natty/main Translation-en
Ign http://archive.ubuntu.com natty/multiverse Translation-en_CA
Ign http://archive.ubuntu.com natty/multiverse Translation-en
Ign http://archive.ubuntu.com natty/restricted Translation-en
Ign http://archive.ubuntu.com natty/universe Translation-en_CA
Ign http://archive.ubuntu.com natty/universe Translation-en
Ign http://archive.ubuntu.com natty-updates/main Translation-en_CA
Ign http://archive.ubuntu.com natty-updates/main Translation-en
Ign http://archive.ubuntu.com natty-updates/multiverse Translation-en_CA
Ign http://archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://archive.ubuntu.com natty-updates/restricted Translation-en_CA
Ign http://archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://archive.ubuntu.com natty-updates/universe Translation-en_CA
Ign http://archive.ubuntu.com natty-updates/universe Translation-en
Fetched 338 kB in 3min 5s (1,817 B/s)
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

When I do apt-get upgrade, this is the result:

exo@behemoth ~ $ sudo apt-get upgrade
[sudo] password for exo:
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

When I do apt-get check, this is the result:

exo@behemoth ~ $ sudo apt-get check
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_katya_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.


When I first used Mint 11, I had the same problem and I found a command that temporarily let me update/upgrade my system, but it was too tedious so I reverted to Mint 10 .
I came back to Mint 11 because of the support for my wacom tablet, and also because I thought this issue might have been fixed by now .
That being said, I would like to find a permanent solution for this problem, as running a command each time I want to update/upgrade my system is too tedious .

The command had something to do with removing a file in /var/lists or something of the sort and at some point it even refused to let me do so, which was my turning point to Mint 10 .
Last edited by exoshwarze on Mon Jun 13, 2011 10:42 am, edited 1 time in total.
rob2uk
Level 4
Level 4
Posts: 281
Joined: Tue Jul 28, 2009 2:44 pm

Re: apt-get update/upgrade error int mint 11

Post by rob2uk »

This is the third thread asking this exact question in as many days... the search box is a great tool ;)

Anyway, the solution is to run this in a terminal:

Code: Select all

sudo rm /var/lib/apt/lists/* -vf
GA-965-DS3, Core 2 Quad 2.4GHz, 8GB DDR2, 2x1TB HDD, Linux Mint 11
Acer Aspire 5332, Pentium dual core 2.2GHz, 4GB DDR3, 500GB HDD, Linux Mint 11, Linux Mint Debian
Compaq CQ-60, Sempron 2.10GHz, 4GB DDR2, 120GB HDD, Tinycore 3.7rc2 (Minecraft server!)
exoshwarze
Level 1
Level 1
Posts: 2
Joined: Mon Jun 13, 2011 10:04 am

Re: apt-get update/upgrade error in Mint 11

Post by exoshwarze »

Yes, that is the command that I used the last time, but I had to run it before each time I updated/upgraded my system .
I'm just wondering if there is a way to permanently fix this issue ?
PingusDB
Level 1
Level 1
Posts: 3
Joined: Sun Aug 01, 2010 11:43 am
Location: the Netherlands
Contact:

Re: apt-get update/upgrade error int mint 11

Post by PingusDB »

rob2uk wrote:This is the third thread asking this exact question in as many days... the search box is a great tool ;)

Anyway, the solution is to run this in a terminal:

Code: Select all

sudo rm /var/lib/apt/lists/* -vf
Sure is, but the amount of responses on this search are quite big so before you've read them all...
A permanent resolution would be very nice indeed!
ZenecadE
Level 1
Level 1
Posts: 30
Joined: Tue Nov 16, 2010 3:52 am

Re: apt-get update/upgrade error in Mint 11

Post by ZenecadE »

I feel your pain. I had the same problem but the above command didn't help me much with synaptic. What I did was open terminal then typed sudo rm /var/lib/apt/lists/* -vf then opened synaptic. Then edit software repositories and click on Other Software tab. Disable ALL items there then click close. Now click the reload button. If successful, you won't be kicked out of synaptic. Now edit the software sources again and enable the options under Other Software 1 by 1 exiting the software with each repository you enable. Remember to click Reload.

It turns out I had 1 software source that was the problem. Once I disabled it, my problem was fixed permanently. Sadly though, I can't remember which source it was coz it was on my other PC at home.
naren
Level 1
Level 1
Posts: 4
Joined: Thu Sep 08, 2011 4:02 pm

Re: apt-get update/upgrade error in Mint 11

Post by naren »

am getting error
E: Malformed line 1 in source list /etc/apt/sources.list.d/local-repository.list (dist parse)
E: The list of sources could not be read.
User avatar
ThistleWeb
Level 5
Level 5
Posts: 890
Joined: Fri Mar 25, 2011 9:59 am
Location: Scotland
Contact:

Re: apt-get update/upgrade error in Mint 11

Post by ThistleWeb »

naren wrote:am getting error
E: Malformed line 1 in source list /etc/apt/sources.list.d/local-repository.list (dist parse)
E: The list of sources could not be read.
It's not cool to tag your issue onto someone elses thread. It'd also be an idea to search the forums, there is a thread with the solution to this specific issue.
Crivens!
Post Reply

Return to “Newbie Questions”