[SOLVED]nVidia Drivers and Random Blank Screen?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Superewza
Level 4
Level 4
Posts: 205
Joined: Sun Oct 25, 2009 4:44 pm
Location: Newcastle upon Tyne, England, Europe, Earth, ZZ9 Plural Z Alpha, Milky Way, Universe, Multiverse

[SOLVED]nVidia Drivers and Random Blank Screen?

Post by Superewza »

Well i recently rebuilt my PC (clean up, swap some components out to make it quieter etc.) and in the process i changed the HDD, so i took the chance to do a fresh installation of Mint (i'll get round to dual-booting Arch again in a bit).

Anyway, most of it works great and it's even better than i remember it apart from a tendency for the whole screen to randomly go black for about a second. This seems to happen when i go onto a site with flash, like Youtube, but it will happen again when i close it. It seems to me a bit like the blank screen you get when changing the resolution (it also sometimes seems to offset the display a bit, like the auto button on the monitor does wrongly), which might mean it's a problem with Compiz or the drivers (proprietary nVidia). However the option to change back to Nouveau is no longer in the Additional Drivers program (which, incidentally, i just opened and the screen went black, maybe it's a resource allocation thing?) and since it's not Arch i wouldn't know how else to do it without harming something else, nor can i see a way of temporarily turning off Compiz.

Other than that i'm stumped, ideas? Thanks a lot :)
Last edited by Superewza on Thu Jun 23, 2011 12:16 pm, edited 1 time in total.

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: nVidia Drivers and Random Blank Screen?

Post by AlbertP »

If you downgrade Compiz, it usually works fine again.

http://www.webupd8.org/2011/05/how-to-d ... 86-in.html
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
Superewza
Level 4
Level 4
Posts: 205
Joined: Sun Oct 25, 2009 4:44 pm
Location: Newcastle upon Tyne, England, Europe, Earth, ZZ9 Plural Z Alpha, Milky Way, Universe, Multiverse

Re: nVidia Drivers and Random Blank Screen?

Post by Superewza »

Hmm, did that, rebooted and it doesn't look like Compiz is running, however the problem still persists - it just seems to be a little less predictable (as in, it might not happen every time or straight away). That leads me to think it's a problem with resources, so maybe with the nVidia driver. How do i revert back to Nouveau?

Thanks :)

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: nVidia Drivers and Random Blank Screen?

Post by AlbertP »

Open Software Manager from the menu. Type nvidia in the search bar at the top-right. Then click all packages with a green mark, except nvidia-common, and remove them. Reboot and Nouveau is back.

You can install Nouveau 3D if you wish. When using Mint 11 it's the experimental driver in 'Additional Drivers' and when using Mint 10 you can install libgl1-mesa-dri-experimental from Software Manager.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
Superewza
Level 4
Level 4
Posts: 205
Joined: Sun Oct 25, 2009 4:44 pm
Location: Newcastle upon Tyne, England, Europe, Earth, ZZ9 Plural Z Alpha, Milky Way, Universe, Multiverse

Re: nVidia Drivers and Random Blank Screen?

Post by Superewza »

Well i just switched to the other nVidia driver available in 'Additional Drivers', version 173? And it doesn't happen any more. Hmm... i'm going to flag this as solved but disappointed with nVidia. This is with an 8400GS 256MB? for anybody that cares to find this.

Would be interesting to see the performance difference between this and Nouveau though, just can't really be bothered at the minute :D Anyway, thanks for the help everyone, here's to a future without troubleshooting! :lol:

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: [SOLVED]nVidia Drivers and Random Blank Screen?

Post by AlbertP »

The 2D performance is quite close.

For 3D you first need to install the 3D part of the Nouveau driver as explained above.
There are benchmarks on Nouveau and many other drivers & hardware here: http://www.phoronix.com/scan.php?page=c ... %20Drivers

Note that the current repository package does not contain the files needed to run 32-bit programs on 64-bit systems; those programs (including Google Earth and Wine) cannot use the Nouveau 3D version in the repository. You can compile it manually (but I can't help you with that - I never managed to do it).
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Newbie Questions”