XChat not saving sound settings

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Tannn3r
Level 1
Level 1
Posts: 28
Joined: Tue Jul 05, 2011 7:30 pm

XChat not saving sound settings

Post by Tannn3r »

I downloaded my own sounds for XChat, and I set them up. But whenever I close it, I have to re-add them again. I tried changing the font and the timestamp format and those saved. But, the sound settings aren't saving. What's wrong?
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XChat not saving sound settings

Post by xenopeek »

Hi, sound files you should put in ~/.xchat2/sounds by default. There is a file ~/.xchat2/sound.conf that has the settings. Is this file updated after you make your changes?
Image
Tannn3r
Level 1
Level 1
Posts: 28
Joined: Tue Jul 05, 2011 7:30 pm

Re: XChat not saving sound settings

Post by Tannn3r »

The file remains blank after I have made the changes.
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XChat not saving sound settings

Post by xenopeek »

You could try XChat on another Linux version, or on Windows, and see if the file is changed there (for example of contents). For more help, I'd suggest the XChat forums: http://forum.xchat.org/viewforum.php?f=3.
Image
Tannn3r
Level 1
Level 1
Posts: 28
Joined: Tue Jul 05, 2011 7:30 pm

Re: XChat not saving sound settings

Post by Tannn3r »

I used Windows before and it worked fine. I just don't see why it isn't working now.

Would reinstalling help at all?
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XChat not saving sound settings

Post by xenopeek »

I tried to do it, and just as you said the program allows you to set the sounds, but it doesn't save them. No configuration files are changed upon setting the sounds. This looks like bug in the program. You can search for open XChat bugs, or log a new bug on this issue: http://xchat.org/cvs/
Image
Tannn3r
Level 1
Level 1
Posts: 28
Joined: Tue Jul 05, 2011 7:30 pm

Re: XChat not saving sound settings

Post by Tannn3r »

Oh ok, thanks! It looks like it's been a bug for a while now, though.
philinux
Level 1
Level 1
Posts: 1
Joined: Mon Jul 04, 2011 11:50 am

Re: XChat not saving sound settings

Post by philinux »

Tannn3r wrote:I downloaded my own sounds for XChat, and I set them up. But whenever I close it, I have to re-add them again. I tried changing the font and the timestamp format and those saved. But, the sound settings aren't saving. What's wrong?
It wasn't saving any settings for me. I found the cause. If you close xchat with the x button nothing is saved. However is you close it via xchat quit or ctrl q it saves settings.
Post Reply

Return to “Newbie Questions”