Page 1 of 1

XChat not saving sound settings

Posted: Sat Jul 09, 2011 1:42 pm
by Tannn3r
I downloaded my own sounds for XChat, and I set them up. But whenever I close it, I have to re-add them again. I tried changing the font and the timestamp format and those saved. But, the sound settings aren't saving. What's wrong?

Re: XChat not saving sound settings

Posted: Sat Jul 09, 2011 2:20 pm
by xenopeek
Hi, sound files you should put in ~/.xchat2/sounds by default. There is a file ~/.xchat2/sound.conf that has the settings. Is this file updated after you make your changes?

Re: XChat not saving sound settings

Posted: Sat Jul 09, 2011 10:34 pm
by Tannn3r
The file remains blank after I have made the changes.

Re: XChat not saving sound settings

Posted: Sat Jul 09, 2011 11:44 pm
by xenopeek
You could try XChat on another Linux version, or on Windows, and see if the file is changed there (for example of contents). For more help, I'd suggest the XChat forums: http://forum.xchat.org/viewforum.php?f=3.

Re: XChat not saving sound settings

Posted: Sun Jul 10, 2011 1:28 pm
by Tannn3r
I used Windows before and it worked fine. I just don't see why it isn't working now.

Would reinstalling help at all?

Re: XChat not saving sound settings

Posted: Sun Jul 10, 2011 2:33 pm
by xenopeek
I tried to do it, and just as you said the program allows you to set the sounds, but it doesn't save them. No configuration files are changed upon setting the sounds. This looks like bug in the program. You can search for open XChat bugs, or log a new bug on this issue: http://xchat.org/cvs/

Re: XChat not saving sound settings

Posted: Mon Jul 11, 2011 8:55 pm
by Tannn3r
Oh ok, thanks! It looks like it's been a bug for a while now, though.

Re: XChat not saving sound settings

Posted: Fri Sep 23, 2011 9:00 am
by philinux
Tannn3r wrote:I downloaded my own sounds for XChat, and I set them up. But whenever I close it, I have to re-add them again. I tried changing the font and the timestamp format and those saved. But, the sound settings aren't saving. What's wrong?
It wasn't saving any settings for me. I found the cause. If you close xchat with the x button nothing is saved. However is you close it via xchat quit or ctrl q it saves settings.