SDCard doesn't show after using diskutility to format/unmoun

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
pepperminty
Level 5
Level 5
Posts: 738
Joined: Thu Jun 23, 2011 10:51 pm

SDCard doesn't show after using diskutility to format/unmoun

Post by pepperminty » Tue Sep 06, 2011 10:33 pm

I used Disk Utility 2.32.1 (in administration) on a 32 GB SD card to "format a drive" and then to "unmount volume". I then put in the card again but now the card no longer shows in the Disk Utility program.

Also, in the past, whenever I put an SD card into the laptop SD slot, Linux Mint brings up a pop-up window that asks me what I want to do with the SD card. However, after using Disk Utility to format and unmount, there is no pop-up window anymore.


What can I do to fix this problem, without having to restart the computer?

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: SDCard doesn't show after using diskutility to format/un

Post by zombie » Tue Sep 06, 2011 10:44 pm

My guess is that the "Unmount Volume" command in Disk Utility is the same as "Safely Remove" in the right click context menu on the desktop. This has a bad tendency to cut the power to the card reader until the next reboot.
The work around is to use "Eject" instead. Just right click the icon on the desktop, and select "Eject".
Hope this works for you.

User avatar
pepperminty
Level 5
Level 5
Posts: 738
Joined: Thu Jun 23, 2011 10:51 pm

Re: SDCard doesn't show after using diskutility to format/un

Post by pepperminty » Tue Sep 06, 2011 10:50 pm

zombie,
thanks for your reply.

I'd like to respond to what you wrote. You wrote that my actions may have "cut the power to the card reader".
just to let you know, i wasn't using any external card reader. The card reader I was using was the laptop's "hole" in the front. Is it still likely that the built-in slot was powered off by my actions?
Last edited by pepperminty on Tue Sep 06, 2011 11:41 pm, edited 1 time in total.

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: SDCard doesn't show after using diskutility to format/un

Post by zombie » Tue Sep 06, 2011 11:32 pm

Yes. An external card reader wouldn't be a problem as long as it is connected with a USB cable. The problem is with some internal card readers. Including mine... :x

User avatar
pepperminty
Level 5
Level 5
Posts: 738
Joined: Thu Jun 23, 2011 10:51 pm

Re: SDCard doesn't show after using diskutility to format/un

Post by pepperminty » Tue Sep 06, 2011 11:42 pm

zombie
thanks for confirming that the problem is in fact with built-in card readers.

Must I restart the computer to get the built-in card reader to work again? Surely, there's a command we can run to make the built-in card reader work without having to restart the computer?.?.?

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: SDCard doesn't show after using diskutility to format/un

Post by zombie » Tue Sep 06, 2011 11:49 pm

Not that I know of. Sorry.
If you eject using the method I described it won't be a problem in the future tho...

Post Reply

Return to “Newbie Questions”