[SOLVED] Login customisation: Faenza icons not shown

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
maxheadway
Level 1
Level 1
Posts: 48
Joined: Sun Jan 24, 2010 9:12 pm
Location: MATE Ludditedom

[SOLVED] Login customisation: Faenza icons not shown

Post by maxheadway »

[Mint 9] My desktop has the Faenza icon set (and colour-variations thereof) installed. Yet when I enter this code (from Ubuntu Geek) to customise the login screen...

Code: Select all

sudo cp /usr/share/applications/gnome-appearance-properties.desktop /usr/share/gdm/autostart/LoginWindow
...the Icons menu within the theme customisation options doesn't include Faenza. How do you add Faenza (or other icon sets) to the menu there? I'm just trying to make the customisation screen consistent with the desktop.
Last edited by maxheadway on Fri Sep 09, 2011 10:06 pm, edited 1 time in total.
Linux Mint 13 LTS
User avatar
pluraldave
Level 5
Level 5
Posts: 705
Joined: Mon Sep 01, 2008 8:05 am

Re: Login customisation: Faenza icons not shown

Post by pluraldave »

Did you install the icons to /usr/share/icons or ~/.icons? They will need to be in /usr/share/icons.

*edit: Tested the code given in the link - Faenza icons work if they are in the right folder.
maxheadway
Level 1
Level 1
Posts: 48
Joined: Sun Jan 24, 2010 9:12 pm
Location: MATE Ludditedom

Re: Login customisation: Faenza icons not shown

Post by maxheadway »

pluraldave wrote:Did you install the icons to /usr/share/icons or ~/.icons? They will need to be in /usr/share/icons.
Tried dragging-and-dropping them from Downloads folder into /usr/share/icons, only to get a "permission denied" message.
Linux Mint 13 LTS
User avatar
pluraldave
Level 5
Level 5
Posts: 705
Joined: Mon Sep 01, 2008 8:05 am

Re: Login customisation: Faenza icons not shown

Post by pluraldave »

You have to so it as root. Either right-click on a folder and choose "open as administrator" to open Nautilus in root mode or do it via the command line:

Code: Select all

sudo cp -r ~/Downloads/Faenza /usr/share/icons
(assuming you extracted the icon theme so it is in a normal folder simply called "Faenza" not an archive, alter the name as appropriate)

alternatively copy all the icon themes you've installed to your user to the shared directory

Code: Select all

sudo cp -ru ~/.icons/* /usr/share/icons/
and themes as well while you're at it

Code: Select all

sudo cp -ru ~/.themes/* /usr/share/themes/
conslie
Level 4
Level 4
Posts: 366
Joined: Sun Oct 11, 2009 2:03 am

Re: Login customisation: Faenza icons not shown

Post by conslie »

To protect the basic Linux OS from unwanted intrusion, changing things there requires that the changes be done only by the system admin. If you right click on the /usr/share/icons folder, one option is to Open as Administrator. You will be asked to type your password, the one you login with, and then you can drag and drop.

This is the drag and drop way to do what was described in the previous post. You can see that command lines are more efficient, but this is the GUI alternative.
maxheadway
Level 1
Level 1
Posts: 48
Joined: Sun Jan 24, 2010 9:12 pm
Location: MATE Ludditedom

Re: Login customisation: Faenza icons not shown

Post by maxheadway »

Thanks! Solved.
Linux Mint 13 LTS
Post Reply

Return to “Newbie Questions”