A few questions from a relatively new user

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sun Dec 30, 2007 12:35 pm

A few questions from a relatively new user

Postby tyrion2323 » Sun Dec 30, 2007 12:55 pm

Hi guys,

Though I have dabbled with Linux for the past year, I still consider myself a new user. I just installed Mint as my primary OS (with Vista x64 as a backup).

I have done several searches, but a lot of the search links come up as 404 errors :( So I have some questions, and I would absolutely love if anyone might help me out :)

1) I have a 24" monitor; however, Mint doesn't seem to want to display 1920x1200, only 1600x1200. I have tried to find my monitor (Acer AL2416W) on the list, but alas - not there!

2) I would like to setup my Logitech MX310 5-button mouse. Should I do this exactly the same way that I would do so in Ubuntu, or is Mint slightly different?

Well, those are pretty much my only questions at the moment.

Thanks guys :)

User avatar
Level 1
Level 1
Posts: 46
Joined: Fri Dec 28, 2007 6:45 pm

Re: A few questions from a relatively new user

Postby ricky » Sun Dec 30, 2007 2:56 pm

i don't know about 1 but 2 i do know.
i'm pretty sure that you could set it up the exact same way.

Level 4
Level 4
Posts: 435
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: A few questions from a relatively new user

Postby cmost » Sun Dec 30, 2007 5:16 pm

The monitor resolution is easy, if you're willing to dig in and get your hands dirty. First, forget the graphical tools. Let's go straight to the text files shall we? Open a gnome-terminal and type
$sudo cp /etc/X11/xorg.conf /etc/X11/xorg.bak-mm-dd-yy (where mm-dd-yy equals the date)
$sudo gedit /etc/X11/xorg.conf

When gedit appears, with your xorg.conf file loaded up, scroll down to where your default color depth is and ensure it's set to 24. If you're running a fairly recent system (and if you ever want 3D compiz effects) this is what you'll want. The section might resemble this:
Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5200]"
Monitor "Generic"
DefaultDepth 24

Note: In the above example, my particular video card and monitor are listed. Your file may look different. The important part is to make sure the DefaultDepth = 24.

Now, scroll down to the depth you specified above (24) and make sure your lines have your desired resolution first. They should look something like this:

SubSection "Display"
Depth 24
Modes "1920x1200" "1440x900" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "256x160"
Virtual 1920 1200

Note: There is purposely no "x" between 1920 and 1200 in the Virtual line. Also, your lines might not look exactly like mine.

Save the file; reboot your computer (or restart X manually.)

You should now be at your desired resolution. If for some odd reason you cannot boot to a graphical GDM, then don't despair. You can undo the changes you made at the command terminal. (It's good to know your way around a command line if ever you're stuck.) Log in by entering your username and password. Then type:
$sudo nano /etc/X11/xorg.conf

Use the arrow keys to scroll up and down the file to undo the changes. Then type CTRL+X followed by SHIFT+Y to save the changes. Then type:
$sudo reboot
...to reboot the computer again with your old settings.

Alternately, you could always type:
$sudo cp /etc/X11/xorg.conf.bak-mm-dd-yy /etc/X11/xorg.conf

As to your mouse problem, I don't have such a mouse myself, so I can't assist with that. Good luck.

Return to “Newbie Questions”