keypad / numlock problem?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Surreal
Level 1
Level 1
Posts: 23
Joined: Fri Jan 07, 2011 10:24 am
Location: the Netherlands

keypad / numlock problem?

Post by Surreal » Fri Oct 28, 2011 11:28 am

Hello,

I have Linux Mint 11 x64 installed on my laptop and i'm encountering a problem with my keypad.

Normally under Windows Numlock is enabled by default and under Linux it's all messed up.

For example; if i type text and i press 'Home' to go to the beginning of a sentence i get the number 7 instead,
and when i press 'Shift + Home' i go to the beginning of the sentence but without selecting it :S

After some googling i came across the following solution;

Installing Numlockx, adding the code below to /etc/gdm/Init/Default

Code: Select all

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi
Now Numlock is enabled after rebooting but it's not functioning as it should be,
which i find incredibly annoying :P

Has anyone found a solution to this problem or will i have to live with this?
Last edited by Surreal on Fri Oct 28, 2011 3:38 pm, edited 1 time in total.
'There are only 2 kinds of opinions in this world, mine and the wrong one', -Jeremy Clarkson

User avatar
xenopeek
Level 24
Level 24
Posts: 22082
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: keypad / nunlock problem?

Post by xenopeek » Fri Oct 28, 2011 12:53 pm

Numlock acts just the same as Capslock on Windows. That is, the shift key is a modifier to it.

With Capslock enabled you type in upper case letters, but you can press and hold the shift key to temporarily disable Capslock and type one or more letters in lower case. The same with Capslock disabled, you press and hold the shift key to temporarily enable Capslock and type one or more letters in upper case.

Numlock acts exactly like that on Linux. There is nothing messed up about this, it is just different than Windows.

Using the keypad without Numlock enabled gives you directional keys, pressing shift temporarily enables Numlock so you can type digits. With Numlock enabled you can press and hold shift to temporarily disable Numlock and you get directional keys again instead of digits.

To enable the Numlock at boot, you may just want to switch it on in the BIOS.
Image

Post Reply

Return to “Newbie Questions”