No sound on linux

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
whirly
Level 2
Level 2
Posts: 68
Joined: Tue Jul 05, 2011 7:20 pm

Re: No sound on linux

Post by whirly » Mon Mar 05, 2012 6:26 pm

if you are using usb for speakers
then show us lsusb ( just put it in terminal) with unit plugged in
i'll assume the computer's volume is turned up if it has a physical volume control, this includes usb units

User avatar
bimsebasse
Level 7
Level 7
Posts: 1700
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: No sound on linux

Post by bimsebasse » Mon Mar 05, 2012 6:30 pm

Don't know if this has been solved but very often, about once a week, my mint 12 without warning decides to use a different device for sound output leaving all sound mute. It's a matter of simply selecting the right one again from the sound settings but I wonder how many not so PC savvy users out there experience the same and think their sound is gone for good.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Mon Mar 05, 2012 6:45 pm

undercom wrote:I still need help. I tried clicking on the ftp.us.debian.org/debian link, while holding the shift key. It seemed to have downloaded, but I don't know how to activate it. Please respond!
Use the Package Manager (Synaptic) to install the gnome-alsamixer package. You can then start GNOME ALSA Mixer from the menu to choose the sound device and adjust the input and output levels.
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Tue Mar 06, 2012 9:27 am

whirly wrote:We (anyone who might be of help) still don't know what your computer thinks is your sound card
how about
terminal
arecord -l
then arecord -L
or cat /proc/asound/cards
This is what it gave me.
mint@mint ~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 1: Intel ICH - MIC ADC [Intel ICH5 - MIC ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 2: Intel ICH - MIC2 ADC [Intel ICH5 - MIC2 ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 3: Intel ICH - ADC2 [Intel ICH5 - ADC2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0353]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0353]], device 1: emu10k1 mic [Mic Capture]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0353]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0353]], device 4: p16v [p16v]
Subdevices: 1/1
Subdevice #0: subdevice #0
mint@mint ~ $ arecord -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=ICH5
Intel ICH5, Intel ICH5
Default Audio Device
front:CARD=ICH5,DEV=0
Intel ICH5, Intel ICH5
Front speakers
surround40:CARD=ICH5,DEV=0
Intel ICH5, Intel ICH5
4.0 Surround output to Front and Rear speakers
surround41:CARD=ICH5,DEV=0
Intel ICH5, Intel ICH5
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=ICH5,DEV=0
Intel ICH5, Intel ICH5
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=ICH5,DEV=0
Intel ICH5, Intel ICH5
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
default:CARD=Audigy2
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
Default Audio Device
front:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
Front speakers
rear:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
Rear speakers
center_lfe:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
Center and Subwoofer speakers
side:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
Side speakers
surround40:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
4.0 Surround output to Front and Rear speakers
surround41:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Audigy2,DEV=0
SB Audigy 2 ZS [SB0353], ADC Capture/Standard PCM Playback
IEC958 (S/PDIF) Digital Audio Output

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Tue Mar 06, 2012 9:35 am

So, where would it tell me what sound card is to be used. Also, I tried installing gnome-alsamixer, but i can't seem to find it in the menu. Was it supposed to be the desktop menu, or some other menu.

Just to let you know, I do appreciate the help. :D

spandey
Level 4
Level 4
Posts: 439
Joined: Sat Feb 20, 2010 1:23 pm

Re: No sound on linux

Post by spandey » Tue Mar 06, 2012 9:40 am

In mint menu search for 'Terminal'. Select in by double clicking it. Type Alsamixer and press Enter. You will get Alsamixer Menu.
Linux Mint 17 - Mate 64 Bit

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Tue Mar 06, 2012 9:59 am

undercom wrote:So, where would it tell me what sound card is to be used. Also, I tried installing gnome-alsamixer, but i can't seem to find it in the menu. Was it supposed to be the desktop menu, or some other menu.

Just to let you know, I do appreciate the help. :D
GNOME ALSA Mixer should be in the Sound & Video section of the menu.
Attachments
GNOME ALSA Mixer in menu.jpg
GNOME ALSA Mixer in menu.jpg (64.18 KiB) Viewed 1518 times
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Wed Mar 07, 2012 7:49 am

It didn't show up in the menu. I selected it for installation in the package manager, and applied the change, but it doesn't seem to show up, except when I use search to find it's files.

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Wed Mar 07, 2012 1:13 pm

undercom wrote:It didn't show up in the menu. I selected it for installation in the package manager, and applied the change, but it doesn't seem to show up, except when I use search to find it's files.
You can start it by going to the Menu, then Accessories, then Terminal. Once the terminal has opened, type: gnome-alsamixer and hit Enter.

You can create a launcher for it by right-clicking on the desktop and selecting create launcher. The command is: /usr/bin/gnome-alsamixer .
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Wed Mar 07, 2012 6:44 pm

I opened it in the terminal, and it opened the mixer, but the terminal itself lists a bunch of stuff that it "has no idea what to do with".

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Wed Mar 07, 2012 9:08 pm

Don't worry about the text in the terminal. Just use the controls of the mixer to get what you want. Once you quit the mixer app. , you can close the terminal without having to know anything about the text. Try to create a launcher for the GNOME ALSA Mixer. Once you do, you won't have to worry about starting it from a terminal. With GNOME ALSA Mixer started, see if you can go in to Edit -> Program Perferences and put a check mark next to your sound card (Realtek ALC658D in my case). Go to Edit -> Souncard Properties and put check marks next to Master, PCM , Line, CD, Mic, Capture, Mix and External Amplifier. After putting the check marks, click Close. Push up the sliders on PCM and Master and see if you can get sound when playing a YouTube music video.
Attachments
GNOME ALSA Mixer Program Preferences.jpg
GNOME ALSA Mixer Program Preferences.jpg (66.42 KiB) Viewed 1473 times
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

3fRI
Level 4
Level 4
Posts: 229
Joined: Sat Nov 20, 2010 10:25 am
Location: State of Confusion

Re: No sound on linux

Post by 3fRI » Wed Mar 07, 2012 9:39 pm

One of my biggest complaints with Ubuntu and Mint are unnecessary sound issues relating to Pulse vs. Gnome Alsa MIxer. Why did the developers replace Alsa with Pulse? Another question is why is the necessary headphone speaker and the mic muted in Alsa by default?

I don't know how to fix the problem with either command line or with Pulse, and I'm sure I'm not alone. Here's what I do to fix the problem after a clean install: I go to Synaptic Package Manager and install Gnome Alsa Mixer. Once you open the program, all you have to do is unclick the muter sliders for both speakers and rec and both your headphones and mic should work.

Good luck!
System 76 Pangolin: 4x Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, Manjaro 15.12 Capella Xfce/Cinnamon 64-bit
iMac 21.5: Intel Core 2 Duo 3.06 GHz, Mac OS 10.11

[iWhat? Me worry?[/i]

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Wed Mar 07, 2012 10:17 pm

3fRI wrote:One of my biggest complaints with Ubuntu and Mint are unnecessary sound issues relating to Pulse vs. Gnome Alsa MIxer. Why did the developers replace Alsa with Pulse? Another question is why is the necessary headphone speaker and the mic muted in Alsa by default?

I don't know how to fix the problem with either command line or with Pulse, and I'm sure I'm not alone. Here's what I do to fix the problem after a clean install: I go to Synaptic Package Manager and install Gnome Alsa Mixer. Once you open the program, all you have to do is unclick the muter sliders for both speakers and rec and both your headphones and mic should work.

Good luck!
I do the same, but depending on which version of Linux (even Mint) is being run, sometimes the sliders and checkboxes aren't there. I've been hopping around different distros lately, so I gave all that information in case the version undercom is using didn't have them.
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Thu Mar 08, 2012 4:23 pm

I tried nearly everything on alsamixer and nothing happened. Also my computer slowed down, or at least the web browser, after I installed it.

yaye
Level 4
Level 4
Posts: 238
Joined: Sat Feb 26, 2011 6:38 pm
Location: Dallas, Texas

Re: No sound on linux

Post by yaye » Thu Mar 08, 2012 8:27 pm

undercom wrote:I tried nearly everything on alsamixer and nothing happened.
Not enough feedback here for anyone to be able to help you further.
undercom wrote: Also my computer slowed down, or at least the web browser, after I installed it.
Never had this happen to me in all the years I've used GNOME ALSA Mixer.
Unregistered Desktop Linux User since 1998 (Redhat 5.0 "Hurricane").

misfitplanet
Level 2
Level 2
Posts: 70
Joined: Wed Nov 17, 2010 6:24 pm

Re: No sound on linux

Post by misfitplanet » Thu Mar 08, 2012 10:16 pm

Do you still have the Mint install disk? Would you give that a try? If so, then with no answers, back up your data and reinstall. Everythin will be restore and probably have sound. If it doesn't work Live, then you may want to try another release. I would never go without sound this long.
Maling
I read the books. And learn. I make it work.
Montgomery
Not without this you don't.

- The Island of Dr. Moreau

undercom
Level 1
Level 1
Posts: 17
Joined: Fri Nov 25, 2011 12:57 am

Re: No sound on linux

Post by undercom » Sat Mar 10, 2012 8:28 am

I didn't use a cd. The Linux I'm using is all on a memory stick.

Post Reply

Return to “Newbie Questions”