WD external drive

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
iironjade
Level 4
Level 4
Posts: 241
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

WD external drive

Postby iironjade » Fri Jan 18, 2008 12:01 pm

Mint 4.0 seems to be doing everything except allowing me to access my Western Digital external hard drive. Normally, installing ntfs-3g cures this but not today. I can't even open the drive read only, let alone create files or folders etc. Am I missing something obvious or is there a solution everyone knows but me? :?
"A good many dramatic situations begin with screaming."

McLovin
Level 5
Level 5
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: WD external drive

Postby McLovin » Fri Jan 18, 2008 12:36 pm

try unplugging and replugging th drive, that's what I have to do sometimes, then it automounts for me.

iironjade
Level 4
Level 4
Posts: 241
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: WD external drive

Postby iironjade » Fri Jan 18, 2008 1:33 pm

If only. I get the "cannot mount drive" message.
"A good many dramatic situations begin with screaming."

paradigmX
Level 1
Level 1
Posts: 14
Joined: Fri Jan 18, 2008 12:53 pm

Re: WD external drive

Postby paradigmX » Fri Jan 18, 2008 2:09 pm

I don't have a link but I read an Article about WD purposely making some of their external Hard Drives compatable with windows only

If your lucky and it won't mount because it wasn't properly unmounted previously from either Linux or Windows, you might be able to force mount it, though force mounting might cause data loss, so if you have anything important on it i would transfer the files off with windows or something

Code: Select all

sudo mount -t ntfs-3g /dev/<Your HD> /media/<your mount point> -o force

iironjade
Level 4
Level 4
Posts: 241
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: WD external drive

Postby iironjade » Fri Jan 18, 2008 2:18 pm

Force mounting hasn't worked so far but I'll give it another try. This drive was perfectly accessible with Ubuntu 7.04 but not with 7.10. It was also ok with the Mint and Ubuntu Live cds but not when installed. It's not life threatening but it's an annoying little quirk.
"A good many dramatic situations begin with screaming."

MagnusB
Level 6
Level 6
Posts: 1253
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: WD external drive

Postby MagnusB » Fri Jan 18, 2008 3:13 pm

Have you tried pmount?

Code: Select all

pmount /dev/sxx disk

This mount /dev/sxx to /media/disk. This does NOT require sudo :)
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin

seba
Level 1
Level 1
Posts: 42
Joined: Fri Nov 30, 2007 9:23 am

Re: WD external drive

Postby seba » Fri Jan 18, 2008 7:56 pm

My WD 320GB external (MyBook Essential USB 2.0) works flawless so it's not necessarily a WD/Mint issue
Maya Mate x32 on a PentiumM 1,7 GHz.

iironjade
Level 4
Level 4
Posts: 241
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: WD external drive

Postby iironjade » Sat Jan 19, 2008 10:26 am

The problem appears to have been solved. How, I don't know, but Mint is now running perfectly. Thanks for your suggestions. :D
"A good many dramatic situations begin with screaming."

User avatar
mikpap
Level 2
Level 2
Posts: 69
Joined: Thu May 24, 2007 5:36 am
Location: Korinthos, Greece

Re: WD external drive

Postby mikpap » Sat Jan 19, 2008 10:45 am

iironjade wrote:The problem appears to have been solved. How, I don't know, but Mint is now running perfectly. Thanks for your suggestions. :D


Do you have a dual boot machine with either XP or Vista? In that case if you hot unplug the external hdd when you are using MS OS you get this message when you boot into linux. If you encounter the same problem once again, try booting into XP (or Vista) and use Safely Remove feature (after having connected your external HDD to your pc) in order to disconnect your external HDD. After that boot into linux. I had the same problem several times because I used to hot unplug my external HDDs.

iironjade
Level 4
Level 4
Posts: 241
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: WD external drive

Postby iironjade » Sat Jan 19, 2008 11:23 am

Completely forgot to mention that this laptop is dual booted with XP. Today was the first time I booted XP and clearly that's what fixed it. I feel like seven kinds of idiot. :oops:
"A good many dramatic situations begin with screaming."

User avatar
yamawho
Level 3
Level 3
Posts: 183
Joined: Tue Dec 04, 2007 8:53 pm

Re: WD external drive

Postby yamawho » Sat Jan 19, 2008 12:21 pm

paradigmX wrote:I don't have a link but I read an Article about WD purposely making some of their external Hard Drives compatable with windows only


I read some recently but it was for Seagate external drives ...

http://www.theinquirer.net/gb/inquirer/ ... nubs-linux
ImageImage


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 13 guests