Page 1 of 1

[SOLVED] No sound in VLC in Mint 12

Posted: Thu Dec 01, 2011 10:10 am
by lexx
I’m new to mint and just installed mint 12 64bit. But I’v been playing with Ubuntu for about a year.
Can’t get VLC to play sound. I’ve tried play mp3 and 3 or 4 different video formats. I’ve tried same files in other programs and they work fine. I’ve looked at the settings and tried changing the output modules which had no effect. I could have made a stupid misstake.
What should I try next?

Re: No sound in VLC in Mint 12

Posted: Thu Dec 01, 2011 7:25 pm
by lmike
Try setting 'output module' to ALSA audio output in settings dialog under audio tab.
I also have set my output device.

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 12:33 am
by crazybilly
I just gave that a go without much luck--still no sound. Bizarre. Not really sure how to troubleshoot it either.

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 1:13 am
by Grozours
I have exactly the same problem, and I don't think it comes from the config because, I copied the .config/vlc/vlcrc file from my working ubuntu system, and after ensuring the vlc configuration was updated, I still has no sound :cry:

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 7:06 am
by mystic_v
Try this instead:
In the vlc audio settings,
Select UNIX OSS audio as the output and ex: /dev/dsp or whatever your sound device mount point is.
It solved the issue for me.

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 10:12 am
by lexx
How do I find out what my mount point is.

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 4:46 pm
by BobSongs
System: Mint Linux 12 32-bit
(Audio Card = SoundBlaster 5.1 Live! Value) - List of software tweaks:

For VLC Media Player:
  • Tools
  • Preferences
  • Audio tab (left side)
  • under Output selected: ALSA audio output.
  • under Device selected: SB Live! 5.1 ADC Capture/Standard PCM Playback (hw:2,0)
  • clicked Save
Started the sound file: worked perfectly. Note: None of the other soundcard options worked.

For Audacity:
  • Edit
  • Preferences
  • Host: ALSA
  • Playback: SB Live! 5.1 ADC Capture/Standard PCM Playback (hw:2,0)
  • clicked OK
Started the sound file: worked perfectly.

For GNOME MPlayer:
  • Edit
  • Preferences
  • Player tab
  • Audio Output: SB Live! 5.1 (ADC Capture/Standard PCM Playback) (alsa)
  • clicked Close
Started the sound file: worked perfectly. Note: Video didn't require any adjusting, worked immediately.

Now, I'd love to know how I can get sound going in Firefox (YouTube, Grooveshark... none of these work).

Interestingly, Movie Player (Totem) worked flawlessly out of the box.

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 6:45 pm
by cristigm
I had the same problem. no sound with vlc.

I used software manager to search for "vlc" and I installed the plugins/packages that were audio-related (aka mentioned audio in the description :D )
Sorry but I can't single out the one that did the trick, because I installed them all.
You can try them one by one if you don't want to install them all.

Hope this helps you

Re: No sound in VLC in Mint 12

Posted: Fri Dec 02, 2011 6:59 pm
by z06gal
I had the same problem until I installed vlc-pulse plugin via synaptic :wink:

Re: No sound in VLC in Mint 12

Posted: Sat Dec 03, 2011 4:46 am
by lexx
Thanks for the help cristigm and z06gal. I installed the vlc-plugin-pulse and it worked. :D

Re: [SOLVED] No sound in VLC in Mint 12

Posted: Sat Dec 03, 2011 11:12 am
by eddygordo2011
Hello guys,

I had the same problem after installing Linux Mint 12 from fresh. I have uninstall VLC from Sotfware manager and then reinstall the same program from removed.
I am watching an AVI file without any problem.
I hope that will help you...

Re: No sound in VLC in Mint 12

Posted: Sun Jan 22, 2012 6:38 am
by Drake2k
z06gal wrote:I had the same problem until I installed vlc-pulse plugin via synaptic :wink:
Such an odd issue. VLC worked just fine for me...until one day POOF audio go bye bye.

z06gal posted above about vlc pulse plugin... That did the trick.
My steps:
Open Software Manager
search VLC
click on VLC Pulse Plugin and 'install'

Alternatively if you like the command line (I usually do) you can do the following

Code: Select all

sudo apt-get install vlc-plugin-pulse

Re: No sound in VLC in Mint 12

Posted: Sat Apr 07, 2012 10:41 pm
by Omaru
Drake2k wrote:
z06gal wrote:I had the same problem until I installed vlc-pulse plugin via synaptic :wink:
Such an odd issue. VLC worked just fine for me...until one day POOF audio go bye bye.

z06gal posted above about vlc pulse plugin... That did the trick.
My steps:
Open Software Manager
search VLC
click on VLC Pulse Plugin and 'install'

Alternatively if you like the command line (I usually do) you can do the following

Code: Select all

sudo apt-get install vlc-plugin-pulse

Thank you!!! :)

Sorry my English is not very good.
Same thing happened to me when upgrading to version 2.0 VLC ran out audio :( . Apply this solution from command line, but it did not work until I rebooted. Now it works perfect :D :D



Re: [SOLVED] No sound in VLC in Mint 12

Posted: Sun Apr 08, 2012 2:20 am
by 40ozskills
z06gal,

Thank you very much for your response, that plug in was just what I needed. I hated having to use banshee, I'm very glad to have my VLC back. Thanks again.

Re: [SOLVED] No sound in VLC in Mint 12

Posted: Sun May 06, 2012 5:39 pm
by OrthoSteven
I had to take it one step further. I kept getting a segment violation after install the pulse audio option. It was not until I re-installed VLC that the sound finally worked.