serial port missing

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
thomase
Level 1
Level 1
Posts: 40
Joined: Wed Jan 02, 2008 5:52 am

serial port missing

Postby thomase » Tue Jan 22, 2008 8:05 pm

Hi all, how do I install my serial port ttyS0, I thought it might have been detected on boot up?

Husse
Level 23
Level 23
Posts: 19595
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: serial port missing

Postby Husse » Fri Jan 25, 2008 7:49 pm

Image
Don't fix it if it ain't broken, don't break it if you can't fix it

thomase
Level 1
Level 1
Posts: 40
Joined: Wed Jan 02, 2008 5:52 am

Re: serial port missing

Postby thomase » Tue Jan 29, 2008 4:19 pm

Thanks for the link (a very in depth one) one of the results shows the port is there.
tomh@tomh-Mustang:~$ setserial -g /dev/ttyS*
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3
/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
/dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
maybe have to dig out a serial dialup modem and try that on the port to confirm if Mint or EasyGPS software is the problem.
Cheers TomH

Husse
Level 23
Level 23
Posts: 19595
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: serial port missing

Postby Husse » Tue Jan 29, 2008 6:39 pm

I don't have anything to test with. There is an old serial modem somewhere in the remains of my workshop, but to find it...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it


Return to “Newbie Questions”

Who is online

Users browsing this forum: Charles123 and 31 guests