Software manager not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
kruz
Level 1
Level 1
Posts: 2
Joined: Wed Jan 18, 2012 5:37 pm

Software manager not working

Postby kruz » Wed Jan 18, 2012 5:48 pm

i am very new to Linux, i just downloaded and installed linux mint KDE version, i opened up software manager to do the obvious of installing new software, but the application exits/closes on its own within seconds, i dont know why, kindly help..

-Krupakar, from India

User avatar
RETNUH
Level 4
Level 4
Posts: 451
Joined: Fri Jul 15, 2011 10:55 pm
Location: Nebraska, USA

Re: Software manager not working

Postby RETNUH » Wed Jan 18, 2012 7:16 pm

Open a terminal and input

Code: Select all

mintinstall


After it closes give us the errors the terminal gives.
We all know that light travels faster than sound. That's why certain people appear bright until you hear them speak. -Albert Einstein

Formerly known as Luckydog.

Looking for me? Check the IRC I've been hanging out there.

chris0161
Level 1
Level 1
Posts: 1
Joined: Wed Jan 18, 2012 7:11 pm

Re: Software manager not working

Postby chris0161 » Wed Jan 18, 2012 7:29 pm

Having same problem and also with Synaptic.
Re installed Synaptic and it stopped auto closing but no joy with Mint Install.

Here is the output :

/usr/lib/linuxmint/mintInstall/mintinstall.py:252: SyntaxWarning: import * only allowed at module level
def get_status_description(self, transaction):
/usr/lib/linuxmint/mintInstall/mintinstall.py:260: SyntaxWarning: import * only allowed at module level
def get_role_description(self, transaction):
add_categories took 1.522 ms
build_matched_packages took 0.247 ms
4291
add_packages took 1794.381 ms
add_reviews took 0.028 ms

(mintinstall.py:4284): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
__init__ took 2028.343 ms
/usr/lib/linuxmint/mintInstall/mintinstall.py:1137: GtkWarning: Theme directory scalable/animations/small/16x16 of theme Mint-KDE has no size field

if theme.has_icon(cat.icon):
/usr/lib/linuxmint/mintInstall/mintinstall.py:1137: GtkWarning: Theme directory scalable/animations/small/22x22 of theme Mint-KDE has no size field

if theme.has_icon(cat.icon):
show_category took 17.474 ms
Segmentation fault

kruz
Level 1
Level 1
Posts: 2
Joined: Wed Jan 18, 2012 5:37 pm

Re: Software manager not working

Postby kruz » Thu Jan 19, 2012 12:06 am

Luckydog wrote:Open a terminal and input

Code: Select all

mintinstall


After it closes give us the errors the terminal gives.


The error it displays is: Segmentation fault

attached the screendump: http://imageshack.us/photo/my-images/26 ... ot1ar.png/

akeuning
Level 1
Level 1
Posts: 1
Joined: Fri Jan 27, 2012 7:19 am

Re: Software manager not working

Postby akeuning » Fri Jan 27, 2012 7:49 am

Hi,

I have the same problem. I did a fresh install on a Macbook Pro 5.5, everything works out of the box. But when I start the software manager I got this;

~ $ mintinstall
/usr/lib/linuxmint/mintInstall/mintinstall.py:252: SyntaxWarning: import * only allowed at module level
def get_status_description(self, transaction):
/usr/lib/linuxmint/mintInstall/mintinstall.py:260: SyntaxWarning: import * only allowed at module level
def get_role_description(self, transaction):
add_categories took 1.449 ms
build_matched_packages took 0.225 ms
3398
add_packages took 4130.249 ms
add_reviews took 597.921 ms

(mintinstall.py:3373): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
__init__ took 4881.365 ms
/usr/lib/linuxmint/mintInstall/mintinstall.py:1137: GtkWarning: Theme directory scalable/animations/small/16x16 of theme Mint-KDE has no size field

if theme.has_icon(cat.icon):
/usr/lib/linuxmint/mintInstall/mintinstall.py:1137: GtkWarning: Theme directory scalable/animations/small/22x22 of theme Mint-KDE has no size field

if theme.has_icon(cat.icon):
show_category took 24.806 ms
Segmentation fault

I shut down finger tapping for the touchpad, it works a bit better but after choosing a program to install the software manager crash with the same segmentation fault.

Please help,

Andre

schnorg
Level 1
Level 1
Posts: 1
Joined: Fri Jan 27, 2012 4:05 pm

Re: Software manager not working

Postby schnorg » Fri Jan 27, 2012 4:06 pm

me too!!!!

EricRanders
Level 1
Level 1
Posts: 2
Joined: Tue Jan 17, 2012 3:16 pm

Re: Software manager not working

Postby EricRanders » Thu Feb 02, 2012 4:08 am

I have had this problem with both Mint12 Gnome and KDE Anyone with any ideas ? I have also tried to change the software sever from Main to a few others with no luck.

User avatar
sagirfahmid3
Level 6
Level 6
Posts: 1044
Joined: Sun Sep 04, 2011 12:39 pm

Re: Software manager not working

Postby sagirfahmid3 » Fri Feb 03, 2012 4:18 pm

Open the terminal and put

Code: Select all

sudo apt-get install --reinstall mintinstall

That should reinstall Software Manager properly.
(Lol, so many "install"s in that line!)

jut754
Level 1
Level 1
Posts: 1
Joined: Wed Feb 08, 2012 4:28 pm

Re: Software manager not working

Postby jut754 » Wed Feb 08, 2012 4:32 pm

sagirfahmid3 wrote:Open the terminal and put

Code: Select all

sudo apt-get install --reinstall mintinstall

That should reinstall Software Manager properly.
(Lol, so many "install"s in that line!)


Tried this and still having problems after reboot. I have attached the snapshot of the terminal process. Not sure if that will help or not.
Attachments
snapshot1.png
Snapshot of "mintinstall reinstall" attempt
snapshot1.png (51.8 KiB) Viewed 6977 times

scherzox
Level 1
Level 1
Posts: 1
Joined: Sun Feb 12, 2012 10:12 am

Re: Software manager not working

Postby scherzox » Sun Feb 12, 2012 10:16 am

I installed LM 12 KDE 32 bit yesterday and experiencing the exact same problem with Software Manager. I'm fine with using Muon or Synaptic for now but wanted to give the official Software Manager a try. I'm subscribing to this thread for updates on the problem. Thanks.

pvbrandes
Level 1
Level 1
Posts: 6
Joined: Sun Sep 18, 2011 9:44 pm
Location: San Diego, California

Re: Software manager not working

Postby pvbrandes » Mon Mar 05, 2012 8:57 pm

Not working for me either. After initial install, the Software Manger panel would open for a split second then close. Now it opens and stays open, but none of the icons show, except the "Featured" category icon. Also, none of the listings show an "Install" option.

This is a Mint 12 KDE 32-bit installation.

Bunce
Level 1
Level 1
Posts: 1
Joined: Mon Mar 19, 2012 7:14 am

Re: Software manager not working

Postby Bunce » Mon Mar 19, 2012 7:33 am

I have the same issue fresh install Mint 12 KDE 32 bit version. Software manager Starts says gathering imformation for packages and then when it should go to the next screen it closes.

While writing this I tried Software Manager again to make sure I got the description of events right and it worked fine. I have not changed anything on my system in the few hours since I initially encountered this problem.

Interim activitites included:
Web browsing
Installed chrome via web deb package download
Installed xchat via apt-get
Watched a movie in VLC
Can't think of anything else I did in that time. I don't think any of these would solved the issue

Wait one more thing I installed Nautilus via apt-get maybe that did it? I did not let it overwrite my defualt file extension associations I kept the file that was already present on the system.

bobbill
Level 1
Level 1
Posts: 1
Joined: Fri Jan 25, 2013 1:53 pm

Re: Software manager not working

Postby bobbill » Fri Jan 25, 2013 1:58 pm

i have the same problem my software manager is not working but when i try to use the terminal all i get is this


Depends: libsmpeg0 but it is not going to be installed
libavcodec53 : Depends: libavutil51 (< 4:0.8.1-99) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed or
libavutil-extra-51 (< 4:0.8.1.99) but it is not going to be installed
libavformat53 : Depends: libavcodec53 (>= 4:0.8.4-0ubuntu0.12.04.1) but 4:0.8.1-0ubuntu1 is to be installed or
libavcodec-extra-53 (>= 4:0.8.4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

if i could get some help that would be great :D


Return to “Newbie Questions”

Who is online

Users browsing this forum: jimwg, Neil Edmond, tphard1n and 12 guests