My desktop (v12 gnome) doesn't look right

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

My desktop (v12 gnome) doesn't look right

Post by sabby »

I downloaded the CD version , 64bit. Partitioned my HDD (I have a Toshiba Qosmio x505-8100x - brand new) so I could dual boot with W7.

I installed Mint from the live CD and then upgraded to the DVD version, did all updates.

Also install Cinammon.

But my desktop doesn't look like the screenshots from the Mint website. (attached)

I have no Menu button on the bottom panel and I have a top panel with Application and Places.

Did I do something wrong? I'm happy to provide more info.

Thanks,

sabby
Attachments
Screenshot.png
Screenshot.png (332.09 KiB) Viewed 1641 times
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: My desktop (v12 gnome) doesn't look right

Post by xenopeek »

This is caused by your graphics card drivers. What graphics card do you have? Following command output will help us:

Code: Select all

inxi -Gc 0
Image
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

Thank you, Vincent, for your reply. I know my card is an Nvidia one but here is the result from the code you provided:

sabby@sabby-Qosmio-X505 ~ $ inxi -Gc 0
Graphics: Card: nVidia GF106 [GeForce GTX 460M]
X.Org 1.10.4 drivers nouveau unloaded: vesa,fbdev Resolution 1680x945@60.0hz
GLX Renderer Rasterizer GLX Version 2.1 Mesa 7.11
sabby@sabby-Qosmio-X505 ~ $
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: My desktop (v12 gnome) doesn't look right

Post by xenopeek »

Looks like you the Nouveau driver for your Nvidia graphics card has been disabled. That is the open-source driver. You can trying switching to the proprietary/binary driver, or did you already try to install that? Launch Additional Drivers from the menu to see if your card is detected. (Just type that in the search box in the menu to find it.)
Image
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

I did as you suggested and it seemed to "Activate" the nVidia drivers (no errors) but everything looks the same.
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

Also, I downloaded the driver NVIDIA-Linux-x96_64-290.10.run but when I try to install it I get an error telling me I have an X server running.

I don't know how to turn an X server off (or much else in Linux, as I am obviously new to it).

I also may be on the wrong path altogether.
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

I tried to install it by going to CTRL+ALT+F1 to get out of X but I got the same error saying I was running an X server and the drivers failed to install...
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

OK, let's back up.

After I did your first suggestion, which was to go to "Additional Drivers" and install the nVidia drivers from there I thought it didn't work because the desktop still looks like what I attached.

But after running your commands again I get:

sabby@sabby-Qosmio-X505 ~ $ inxi -Gx 0
Graphics: Card: nVidia GF106 [GeForce GTX 460M] bus-ID: 01:00.0
X.Org 1.10.4 drivers nvidia unloaded: nouveau,vesa,fbdev Resolution 1680x945@50.0hz
GLX Renderer GeForce GTX 460M/PCI/SSE2 GLX Version 4.1.0 NVIDIA 280.13 Direct Rendering Yes

So, it looks like the graphics drivers are installed.

But why does my desktop look so wrong?
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

Okay, okay, okay, I think I figured it out.

1. Use "Additional Drivers" in System Settings to download and activate the nVidia drivers (it seems to offer two and I can't yet tell which is better).

2. Go to /etc/x11 and open xorg.conf. Open it as an administrator (ie, right click and choose Open as administrator, just like in Windows). There's probably a console way to do this but I'm not savvy enough yet.

3. If the file looks like this (or similar):


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 280.13 (buildmeister@swio-display-x86-rhel47-03.nvidia.com) Wed Jul 27 17:15:58 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection



Add this to the bottom of the file (if it's not there):

Section "Module"
Load "extmod"
Load "dbe"
Load "type1"
Load "freetype"
Load "glx"
EndSection

4. The hit CTRL+ALT+BACKSPACE to restart X

The driver listed isn't the latest as the latest for my card is 290.1, but I have yet to successfully install it. However, by doing the above I am now able to have a menu that looks right.



Source: http://us.download.nvidia.com/XFree86/L ... fig.html[i][/i]
User avatar
colyn
Level 6
Level 6
Posts: 1230
Joined: Sat Aug 14, 2010 1:37 pm
Location: ¿ǝɯ ǝǝs ɐʎ ʇ,uɐƆ ˙ǝɹǝɥ ʇɥƃᴉɹ ɯ,I
Contact:

Re: My desktop (v12 gnome) doesn't look right

Post by colyn »

sabby wrote: But why does my desktop look so wrong?
There's nothing wrong with the look of your desktop. The one pictured on the site is Gnome 3 and since you installed Cinammon your desktop looks more like Gnome 2 which is the purpose of Cinammon..

Reboot and at the password prompt click the gear. You can then choose which desktop you want to log into such as Cinammon or Mate etc...
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

Hi Colyn,

I'd noticed those options before but selecting the others didn't change the look of the desktop. No matter which one I selected I only got the one in my screenshot.

After I added to the file as described in my last post I was able to get the gnome 3 desktop. Also, I am not getting an nVidia splash screen at logon, which I wasn't getting before.

The only think I have left is to figure out how to install the updated driver (the 290.1 version).
User avatar
colyn
Level 6
Level 6
Posts: 1230
Joined: Sat Aug 14, 2010 1:37 pm
Location: ¿ǝɯ ǝǝs ɐʎ ʇ,uɐƆ ˙ǝɹǝɥ ʇɥƃᴉɹ ɯ,I
Contact:

Re: My desktop (v12 gnome) doesn't look right

Post by colyn »

sabby wrote:
The only think I have left is to figure out how to install the updated driver (the 290.1 version).
I have an ATI machine that I could not get the current driver to install to until I upgraded the kernel. Then I was able to install.

Try

Code: Select all

sudo apt-get update
then

Code: Select all

sudo apt-get dist-upgrade
Afterward try to install..
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: My desktop (v12 gnome) doesn't look right

Post by mank_in »

Maybe you need to purge nouveau driver :

Code: Select all

sudo apt-get --purge remove xserver-xorg-video-nouveau
see : https://help.ubuntu.com/community/Binar ... wto/Nvidia

install update driver 290.10 from ppa:ubuntu-x-swat/x-updates

Code: Select all

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
run update manager or use synaptic package manager : search nvidia
sabby
Level 1
Level 1
Posts: 13
Joined: Mon Jan 30, 2012 3:22 pm

Re: My desktop (v12 gnome) doesn't look right

Post by sabby »

OK!!! A combo of the last two posts seemed to do the trick. One thing I had to do in the synaptic package installer to uninstall some 280 driver stuff. I just selected everything that was 290 and unselected everything that was 280.

I have an email out to nVidia for details. I'll correspond about what I've done and see if they think it's okay, too. And come back and post their suggestion.

Thanks, all, for helping me with this!
gtr1957
Level 1
Level 1
Posts: 17
Joined: Sat Apr 16, 2011 11:17 am

Re: My desktop (v12 gnome) doesn't look right

Post by gtr1957 »

My cinammon desktop has nothing except the background. No menus or icons of any kind and mouse clicks have no effect. The system works fine with MATE, but cinammon is unusable. I'm not sure what to do with the above hints since they all seem to imply going through some menu options. I get back to MATE with CTL-ALT-BACKSPACE and setting up to login with MATE. From a MATE desktop should i then do the update nvidia stuff (which doesn't seem reasonable as I have ATI0 or,..?

inxi -Gx 0 returned:
Graphics: Card: ATI Radeon RV250 [Mobility FireGL 9000] bus-ID: 01:00.0
X.org 1.10.4 drivers ati, radeon unloaded fbdev,vesa Resolution 1024x768@60.0hz
GLX Renderer Mesa DRI 200 (RV250 4C66) x86/MMX/SSE2 TCL DRI2 GLX Version
1.3 Mesa 7.11 Direct Rendering Yes
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: My desktop (v12 gnome) doesn't look right

Post by mank_in »

@gtr1957, you are using open source driver , but i think you cannot install proprietary driver from "additional driver"
ATI dropped support for card before R600 (radeon HD 2xxx) , the only driver you can use is open source driver.
usually if radeon driver in use, GLX renderer is gallium 3D.
are you have problem in GNOME ( MGSE ) :?:

edit :
quote from https://help.ubuntu.com/community/RadeonDriver :
For r300-r500 (Radeon 9500 - X2300) cards, the r300g driver is a newer 3D driver based on Gallium3D. It is the default 3D driver in Ubuntu Natty/11.04 and newer releases.
gtr1957
Level 1
Level 1
Posts: 17
Joined: Sat Apr 16, 2011 11:17 am

Re: My desktop (v12 gnome) doesn't look right

Post by gtr1957 »

The desktop looks fine in the other options that I have (Gnome, Gnome Classic, Gnome Classic (No effects), MATE). I am not sure which is Gnome (MGSE) from the above names. I infer that there is not an easy fix since radeon is not supporting my older driver for my Dell Inspiron 600m).
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: My desktop (v12 gnome) doesn't look right

Post by mank_in »

@ gtr1957, maybe you are using customized theme.
login to gnome , change theme to default ( adwaita :?: ) , login to cinnamon again.
If didn't success try :

Code: Select all

cinnamon --replace
gtr1957
Level 1
Level 1
Posts: 17
Joined: Sat Apr 16, 2011 11:17 am

Re: My desktop (v12 gnome) doesn't look right

Post by gtr1957 »

I have set a custom background (from one of my own photos), otherwise I haven't touched the session. In a gnome classic session it shows that I am using the default theme adwaita. I don't know how to bring up a terminal to invoke cinnamon --replace from within a cinnamon session. If I try it from CTL-ALT-F1 Term I get a message about not being able to start the xserver. Returning to the cinnamon session with CTL-ALT-F7 leaves me with nothing but a background screen. Is there a chance that this is an issue with the Mesa render engine, and if so, are there plans for a cinnamon without an effects option? For now, I guess I will use MATE which seems to work fine. I tried cinnamon because I thought it was the direction the Mint team was headed. I may look at cinnamon on my desktop machine which is currently running the Mint 12 KDE RC (which is pretty nice by the way).
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: My desktop (v12 gnome) doesn't look right

Post by mank_in »

Quote from : http://blog.linuxmint.com/?paged=2

Our new partnership with Blue Systems improved the quality of the Linux Mint KDE edition as well as the Netrunner distribution and brought in a significant and predictable source of income, allowing us to welcome an extra full-time developer

Following the feedback we gathered on Gnome Shell after the release of Linux Mint 12, it was clear that despite our efforts with MATE and MGSE, we still didn’t manage to reach our goals and to offer Gnome 2 a valid alternative. Some people were enthusiastic about the new alternatives, others were disappointed. For this reason and in an effort to please a wider portion of our user base, we decided to continue to support MATE and to develop a new desktop called Cinnamon

KDE, cinnamon and MATE will be future of LM, if you have problem with cinnamon you can use another desktop :D
And LM 12 KDE stable has been release : http://blog.linuxmint.com/?p=1927
Post Reply

Return to “Newbie Questions”