FIX MY FIX or boot windows?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 15
Joined: Wed Oct 31, 2007 3:38 pm

FIX MY FIX or boot windows?

Postby dylan1055 » Tue Feb 12, 2008 1:50 am

ok this has stopped being fun now.

after some grate community support i found the solution to getting my wifi up and running .
As it happens my noobness was due to a bug in Ubuntu, bug 139070.

so some Ninja provided this work around :

Code: Select all

tar zxvf rt73-cvs-daily.tar.gz
cd rt73*
cd M*
sudo make install
sudo gedit /etc/modprobe.d/blacklist
append this to the end of the file:
# rt73 blacklisted drivers
blacklist rt2500usb
blacklist rt73usb
blacklist rt2x00usb
blacklist rt2x00lib
blacklist ipv6
now sudo /etc/init.d/networking restart and we shall be connected if
/etc/network/interfaces file is configured correctly, here is an example of
#auto wlan0
#iface wlan0 inet static
#pre-up ifconfig wlan0 up
#pre-up iwconfig wlan0 essid 2WIRE
#pre-up iwconfig wlan0 mode managed
#pre-up iwpriv wlan0 set Channel=9
#pre-up iwpriv wlan0 set AuthMode=WPAPSK
#pre-up iwpriv wlan0 set EncrypType=AES
#pre-up iwpriv wlan0 set WPAPSK=yourwpapasswd
#pre-up iwpriv wlan0 set TxRate=0

auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up iwconfig wlan0 essid 2WIRE
pre-up iwconfig wlan0 mode managed
pre-up iwpriv wlan0 set Channel=10
pre-up iwpriv wlan0 set AuthMode=WPAPSK
pre-up iwpriv wlan0 set EncrypType=TKIP
pre-up iwpriv wlan0 set WPAPSK=yourwpapasswd
pre-up iwpriv wlan0 set TxRate=0
mtu 1500
There we go rt73 working perfectly, now, lets watch and see if the Ubuntu
developers can add this wonderful driver to Gutsy and Heron...
Kyle Weller

ok kool ???????????????


this fix works grate until i reboot and then i cant get it working again and the only solution i have found is to reformat.

help please

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: FIX MY FIX or boot windows?

Postby Husse » Wed Feb 13, 2008 6:10 am

ipv6 is blacklisted in Mint by default, so if you added that as in this solution it's done twice. I have no knowledge of what that could do, but it's not right.
That's the only thing I see at a first glance
BTW did
/etc/init.d/networking restart
I have not been able to get it to work in Daryna
This is so strange that I have to study it closer
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 15
Joined: Wed Oct 31, 2007 3:38 pm

Re: FIX MY FIX or boot windows?

Postby dylan1055 » Sat Feb 16, 2008 11:37 pm

no, this is driving me mad.

yer i tried /etc/init./networking restart

responds with [ok]

but still not working

i am a total linux noob , is their a way to compare settings before and after reboot ? so i know what changed.

what gets my goat, is it works perfect if i run from live disk.

Return to “Newbie Questions”

Who is online

Users browsing this forum: bakata, Bing [Bot] and 5 guests