<SOLVED> Biostar 8200 with Nvidia and dual monitor problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
lotharjade
Level 2
Level 2
Posts: 58
Joined: Thu Mar 10, 2011 5:43 pm
Location: Alaska

<SOLVED> Biostar 8200 with Nvidia and dual monitor problem

Post by lotharjade »

I had my dual monitors working great in Mint 10, and when I try Mint 12 I get nothing but problems. It doesn't register the menus at top and bottom of the screen with Separate X Screens. It should be noted I am running two different types of monitors, a Dell 17" and a Samsung 23" widescreen. I also have my xorg.conf looking like it did on Mint 10, which didn't solve my problems either. I think I see a bit of a problem with the following outputs (anfter doing some research) but I don't know what it means or how to fix it.

Here is my xorg.conf

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 290.10  (buildd@charichuelo)  Wed Nov 23 07:50:49 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 56
    Screen      1  "Screen1" 1280 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL E173FP"
    HorizSync       31.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung SMS23A350H"
    HorizSync       31.0 - 81.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8200"
    BusID          "PCI:2:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8200"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0; DFP: 1920x1080 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Here is what happens when I enter "inxi -Gxc 0".

Code: Select all

inxi -Gxc 0
Graphics:  Card: nVidia C77 [GeForce 8200] bus-ID: 02:00.0 X.Org 1.10.4 driver nvidia Resolution 1280x1024, 1920x1080 
           GLX Renderer GeForce 8200/PCI/SSE2 GLX Version 3.3.0 NVIDIA 290.10 Direct Rendering Yes
Here is when I enter "xrandr".

Code: Select all

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    51.0  
   1280x960       52.0  
   1152x864       53.0     54.0     55.0     56.0  
   1024x768       57.0     58.0     59.0  
   960x600        60.0  
   960x540        61.0  
   840x525        62.0     63.0     64.0  
   832x624        65.0  
   800x600        66.0     67.0     68.0     69.0  
   720x450        70.0  
   700x525        71.0  
   680x384        72.0     73.0  
   640x480        74.0     75.0     76.0     77.0  
   512x384        78.0     79.0  
   400x300        80.0  
   320x240        81.0     82.0 
It seemed to have an error there and following the advice of http://forums.linuxmint.com/viewtopic.p ... or#p538389, I installed the following with the command:

Code: Select all

sudo apt-get install xresprobe
The result was:

Code: Select all

sudo ddcprobe
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: MCP77 Board - mcp78so Chip Rev
memory: 14336kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid: 
edidfail
From reading, that edidfail bit is bad, but I am not sure what to do. How can I fix this? :(
Have you tried turning it off and on again, then hitting it repeatedly? :/

lotharjade
Level 2
Level 2
Posts: 58
Joined: Thu Mar 10, 2011 5:43 pm
Location: Alaska

Re: <SOLVED> Biostar 8200 with Nvidia and dual monitor probl

Post by lotharjade »

Ok, I got this for the most part solved. I had problems with my hard drive and had to do a fresh install again, and somewhere along the way got it all to work. I will list different things I did, although many may not relate to this issue.

First off I have a OCZ Vertex 3 hard drive that has been having lots of issues (doing HD0 out of disk errors and other problems), but found out that drive and my Biostar 8200 motherboard might have been having a fit together. (and may still *dread*) So what I did was this:
  • Updated the BIOS on my Biostar motherboard to a new version that detects hard drives better. (as found on Biostar website)
  • Updated the firmware on my OCZ Vertex 3 SSD, including lowering the SSD temp, and setting the SATA speed to SATA2 (my mother board sets it down to SATA1, because it doesn't recognize its SATA3 top speed). (as found on OCZ website)
  • Formatted my SSD to use a GPT partition table, and manually created two primary partitions. One was ext4 for the "/" location, and one as linux-swap.
  • Entered installer, clicked advanced partitioning, then set both partititions to their respected locations (and formatted the ext4 partition).
  • Proceded with install.
  • Updated the system with all necessary updates.
  • Added this PPA (provides latest Nvidia and Xorg drivers. 295 for nvidia) following the directions at the https://launchpad.net/~ubuntu-x-swat/+archive/x-updates site. Click the "Technical Details about this PPA" and "Read about Installing" for more details.
  • Went to "Additional Drivers" and installed "NVIDIA accelerated graphics driver (version current) [Recommended]" drivers. Then when done installing, rebooted as directed.
  • Then I went into nvidia-settings (or NVIDIA X Server Settings) and turned on "TwinView" instead of "Separate X Screen". (I may have rebooted after everything was applied and saved to X configuration File)
  • BOOM! Suddenly everything just works. Previous Linux Mint installs only worked in "Separate X screen" and not "TwinView", but now it was the other way around.
To help others, I will also post my xorg.conf below to help others get their systems right. (wish they would just get this all fixed in the drivers for everyone. seems there is still lots of problems with the nvidia-settings auto setup with regards to the config file)
Also of note, not sure why but at the top of xorg.conf, it lists the version as 280.13. That is not accurate, as the driver I am using is version 295.20. So be aware.

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@allspice)  Thu Aug 11 20:54:45 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL E173FP"
    HorizSync       31.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8200"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1280x1024 +0+56, DFP: 1920x1080 +1280+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Have you tried turning it off and on again, then hitting it repeatedly? :/

Post Reply

Return to “Newbie Questions”