Another Zotac with no HDMI Audio

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 7
Joined: Sat Feb 04, 2012 8:14 pm

Another Zotac with no HDMI Audio

Post by 01sporty » Fri Feb 17, 2012 8:19 pm

I recently purchased a Zotac Nano A-10. Their website said Linux ready so, it looked to me like a perfect platform for my first foray into Linux. I installed Mint 12 KDE 64 bit and all went well except for the HDMI audio. The audio from the headphone jack is good. After trying everything I could think of, I emailed their tech support only to be told they only support Windows. I checked around different forums and it appears Zotac has a reputation for saying they are Linux friendly then leaving you on your own. Great for suckering us noobs. But enough whining.

Lots of posts mention opening alsamixer and making sure everything is unmuted. Alasamixer lists my audio as HD-Audio Generic.
If I do f6, it lists -Default, 0 HD-Audio Generic and 1 HDA ATI SB.
Selecting 0 just gives me a little box that lets me know its not muted.
Selecting 1 gives me volume bars which I set to 100%. But 1 doesn't stay selected.
When I exit alsamixer and re-open it, it once again shows my audio as HD-Audio Generic.

Phonon recognizes Internal Audio Digital Stereo (HDMI) and Internal Audio Analog Stereo. I set the HDMI as the preferred source on everything. Testing the former does nothing, testing the latter works fine.

With a bit of sluthing, I found the Nano uses a Realtek ALC892 for its audio. Realtek has Linux drivers on its site so I downloaded the file. This is from the readme file:

Code: Select all

This Source Code is from
For OS installation, please remember add the Development tool kit.
For driver installation, please follow below steps. 

Automatic install: 


Note: Please check Development tool kit on your OS.   

[b]Manual install:
Step 1. unzip source code
        tar xfvj alsa-driver-1.0.xx.tar.bz2

Step 2. Complied source code
	a. cd alsa-driver-1.0.xx
	b. ./configure --with-cards=hda-intel
	c. make
	d. make install

Step 3. reboot your machine[/b]

Step 4. Use the alsamixer the disable mute (All audio line default is mute)
        Must to compile and to install the ALSA library and utility. (Use automatic install is already install)
        excute alsamixer

Note: 	1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2.
	2. Kernel Version must be 2.6 or later.
	3. All mixer channels are muted by default. You must use a native
		or OSS mixer program to unmute appropriate channels.
	4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.
	5. The driver added to support the SPDIF functoin. 	
	6. a. You can download the alsa-lib-1.0.x and alsa-utils-1.0.x form the, then unzip and install them. 
	   b. Suggest use "alsamixer" to control mixer function.
	   c. Used "alsaconf" can autodetect which drive you need to install (step 4). 	
        7. SUSE Distribution must install the ncurses package. 
I first tried the ./install. Got lots of errors and no sound.
I then tried the manual install. I got as far as 2.b. and had enough errors and warnings that I decided I'd best check with people that know what they are doing before proceeding with c. make and d. make install.

Here is the output from 2.b. ./configure --with-cards=hda-intel:

Code: Select all

don@tv ~ $ cd 
don@tv ~ $ Downloads
Downloads: command not found
don@tv ~ $ cd home
bash: cd: home: No such file or directory
don@tv ~ $ cd don
bash: cd: don: No such file or directory
don@tv ~ $ cd Downloads
don@tv ~/Downloads $ cd realtek
don@tv ~/Downloads/realtek $ cd alsa-driver-1.0.24
don@tv ~/Downloads/realtek/alsa-driver-1.0.24 $ ./configure --with-cards-=hda-intel
configure: WARNING: unrecognized options: --with-cards-
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/don/Downloads/realtek/alsa-driver-1.0.24
checking cross compile... 
checking for directory with ALSA kernel sources... /home/don/Downloads/realtek/alsa-driver-1.0.24/alsa-kernel
checking for directory with kernel source... /lib/modules/3.0.0-16-generic/build
checking for directory with kernel build... /lib/modules/3.0.0-16-generic/build
checking for kernel linux/version.h ... linux/version.h
checking for kernel linux/autoconf.h generated/autoconf.h... generated/autoconf.h
checking for kernel linux/utsrelease.h generated/utsrelease.h... generated/utsrelease.h
checking for kernel version... 3.0.0-16-generic
checking for GCC version... Kernel compiler:  Used compiler: gcc (Ubuntu/Linaro 4.6.1-9ubuntu3) 4.6.1

*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

checking for built-in ALSA... no
checking for existing ALSA module... yes
checking for Red Hat kernel... auto
checking for Red Hat kernel... no
checking for SUSE kernel... auto
checking for SUSE kernel... no
checking for updating alsa-kernel version.h... yes
checking for CONFIG_EXPERIMENTAL... yes
checking for directory to store kernel modules... /lib/modules/3.0.0-16-generic/kernel/sound
checking for verbose procfs... on
checking for verbose printk... on
checking for debug level... none
checking for processor type... x86_64
checking for kernel linux/config.h... no
Creating <linux/config.h>...
checking for deprecated linux/config.h... checking to modify of kernel linux/kmod.h... no
checking for kernel linux/utsrelease.h... no
Creating a dummy <linux/utsrelease.h>...
checking for kernel linux/compiler.h... yes
checking for kernel linux/pm.h... yes
checking for kernel linux/spinlock.h... yes
checking for kernel linux/irq.h... yes
checking for kernel linux/threads.h... yes
checking for kernel linux/rwsem.h... yes
checking for kernel linux/gameport.h... yes
checking for kernel media/v4l2-dev.h... yes
checking for kernel linux/devfs_fs_kernel.h... no
Creating a dummy <linux/devfs_fs_kernel.h>...
checking for kernel linux/highmem.h... yes
checking for kernel linux/workqueue.h... yes
checking for kernel linux/dma-mapping.h... yes
checking for kernel asm/hw_irq.h... yes
checking for kernel linux/device.h... yes
checking for kernel linux/platform_device.h... yes
checking for kernel linux/isa.h... yes
checking for kernel linux/jiffies.h... yes
checking for kernel linux/compat.h... yes
checking for kernel linux/log2.h... yes
checking for kernel linux/adb.h... yes
checking for kernel linux/cuda.h... yes
checking for kernel linux/pmu.h... yes
checking for kernel linux/io.h... yes
checking for kernel linux/moduleparam.h... yes
checking for kernel linux/syscalls.h... yes
checking for kernel linux/firmware.h... yes
checking for kernel linux/err.h... yes
checking for kernel linux/bitmap.h... yes
checking for kernel linux/mutex.h... yes
checking for kernel linux/pm_qos_params.h... yes
checking for kernel linux/kthread.h... yes
checking for kernel asm/irq_regs.h... yes
checking for kernel linux/seq_file.h... yes
checking for kernel linux/debugfs.h... yes
checking for kernel linux/gpio.h... yes
checking for kernel linux/bug.h... yes
checking for kernel linux/math64.h... yes
checking for kernel linux/regulator/consumer.h... yes
checking for kernel linux/dmi.h... yes
checking for kernel linux/bitrev.h... yes
checking for kernel linux/hrtimer.h... yes
checking for kernel linux/gcd.h... yes
checking for kernel linux/gfp.h... yes
checking for kernel pcmcia/cs_types.h... no
Creating <pcmcia/cs_types.h>...
checking for kernel pcmcia/cs.h... no
Creating <pcmcia/cs.h>...
checking for kernel trace/events/asoc.h... yes
checking for kernel linux/lzo.h... yes
checking for exported symbol dump_stack... grep: /lib/modules/3.0.0-16-generic/build/kernel/ksyms.c: No such file or directory
checking for kernel module symbol versions... yes
checking for has ioport support... yes
checking for PCI support in kernel... yes
checking for I2C driver in kernel... yes
checking for I2C_POWERMAC in kernel... unknown
checking for firmware loader... yes
checking for SMP... yes
checking for ISA PnP driver in kernel... yes
checking for PnP driver in kernel... yes
checking for Kernel ISA-PnP support... no
checking for Kernel ISA-PnP module support... no
checking for strlcpy... yes
checking for snprintf... yes
checking for vsnprintf... yes
checking for scnprintf... yes
checking for sscanf... yes
checking for vmalloc_to_page... yes
checking for old kmod... no
checking for PDE... yes
checking for pci_set_consistent_dma_mask... yes
checking for pci_dev_present... yes
checking for msleep... yes
checking for msleep_interrupt... yes
checking for msecs_to_jiffies... yes
checking for tty->count is the atomic type... yes
checking for io_remap_pfn_range... yes
checking for kcalloc... yes
checking for kstrdup... yes
checking for kstrndup... yes
checking for kzalloc... yes
checking for pci_ioremap_bar... yes
checking for saved_config_space in pci_dev... yes
checking for new pci_save_state... yes
checking for register_sound_special_device... yes
checking for old kill_fasync... no
checking for dma_addr_t... no
checking for MUTEX macros... no
checking for driver extra-version... 
checking for driver version... 1.0.24-5.16rc24
checking for dynamic minor numbers... no
checking for sequencer support... yes
checking for OSS/Free emulation... yes
checking for OSS PCM plugin system inclusion... yes
checking for RTC support... no
checking for HPET support... yes
checking for Procfs support... yes
checking for USB support... yes
checking for kernel linux/usb/audio-v2.h... yes
checking for kernel linux/usb/audio.h... yes
checking for valid v1 in linux/usb/audio.h... yes
checking for invalid v2 in linux/usb/audio.h... no
checking for valid linux/usb/audio-v2.h... no
Creating <linux/usb/audio-v2.h>...
checking for kernel linux/usb/ch9.h... yes
checking usb_alloc_coherent... no
checking for gfp_t... yes
checking for GFP_DMA32... yes
checking for page_to_pfn... yes
checking for init_utsname... yes
checking for is_power_of_2... no
checking for __ffs... yes
checking for PnP suspend/resume... yes
checking for builtin _Bool support... yes
checking for x86-compatible PC... no
checking for kernel PCMCIA
checking for PCMCIA support... yes
checking for PC9800 support in kernel... no
checking for parallel port support... yes
checking for power management... yes
checking for cards to compile driver for... all
checking for additonal options to compile driver for... all
configure: creating ./config.status
config.status: creating version
config.status: creating Makefile.conf
config.status: WARNING:  '' seems to ignore the --datarootdir setting
config.status: creating snddevices
config.status: creating utils/alsa-driver.spec
config.status: creating utils/buildrpm
config.status: creating toplevel.config
config.status: creating utils/alsasound
config.status: creating utils/alsasound.posix
config.status: creating include/pci_ids_compat.h
config.status: creating include/i2c-id_compat.h
config.status: creating include/config.h
config.status: creating include/config1.h
config.status: creating include/version.h
config.status: include/version.h is unchanged
config.status: creating include/autoconf-extra.h
configure: WARNING: unrecognized options: --with-cards-
Hacking autoconf.h...
don@tv ~/Downloads/realtek/alsa-driver-1.0.24 $ 

So, the question is, do I proceed with the install or is it just an exercise in futility?


Level 1
Level 1
Posts: 1
Joined: Sun Feb 19, 2012 7:33 pm

Re: Another Zotac with no HDMI Audio

Post by cph » Sun Feb 19, 2012 7:38 pm

you have a typo. in your comment you correctly write:
Here is the output from 2.b. ./configure --with-cards=hda-intel
whereas you seem to make a mistake here in your execution:

Code: Select all

don@tv ~/Downloads/realtek/alsa-driver-1.0.24 $ ./configure --with-cards-=hda-intel
configure: WARNING: unrecognized options: --with-cards-
run that as

Code: Select all

./configure --with-cards=hda-intel
and it should work..

Level 1
Level 1
Posts: 7
Joined: Sat Feb 04, 2012 8:14 pm

Re: Another Zotac with no HDMI Audio

Post by 01sporty » Sun Feb 19, 2012 8:32 pm

Thank you for that.

The good news is that correcting the typo allowed it to compile and run.

The bad news is it appears to have left me worse off. My volume now show dummy output.

When I bring up the mixer, Phonon - KDE Control Module sees all my old stuff as internal devices that have been removed.
The old stuff being the HDA ATI SB (ALC892) and the HD-Audio Generic, HDMI 0
They are still shown in the mixer but are grayed out and nothing can be done with them.

And, when I try to open alsamixer, it wants an argument. Previously, alsamixer would open with just the alsamixer command.
I have no clue how to obtain the argument it wants. Any Suggestions???

Level 1
Level 1
Posts: 1
Joined: Fri Mar 09, 2012 1:06 am

Re: Another Zotac with no HDMI Audio

Post by jimsbrain » Fri Mar 09, 2012 1:20 am

i am having the same issue nothing is muted in alsamixer and the wierdest thing is if i select hdmi audio output from the top bar it fast forwards my movies in hulu without sound i switch sound back to internal and the speed goes back to normal. anyone have a fix for this.

Level 4
Level 4
Posts: 439
Joined: Sat Feb 20, 2010 1:23 pm

Re: Another Zotac with no HDMI Audio

Post by spandey » Fri Mar 09, 2012 1:43 am

Can you please try removing Pulseaudio by following the post here.. ... 85&start=0.
Linux Mint 17 - Mate 64 Bit

Level 1
Level 1
Posts: 1
Joined: Fri Jun 15, 2012 8:03 am

Re: Another Zotac with no HDMI Audio

Post by jermak » Fri Jun 15, 2012 8:06 am

Have you been able to solve it ? to get the audio via HDMI output ?

Post Reply

Return to “Newbie Questions”