My wireless keeps dropping!!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

My wireless keeps dropping!!

Post by yinyang37 » Sat Mar 03, 2012 10:37 am

Hello all,

I have seen numerous posts on this topic, but no clear cut answer (at least to me). I am very very new to Linux and have zero knowledge , so please bear with me.

My wireless keeps dropping randomly. It can be within 10 minutes of loggin on, or an hour, almost always when idle, and often when the computer seems to be running "busy". I set the power to never suspend, but that hasn't helped. Any suggestions?

I also downloaded Wicd Network Manager which hasn't seemed to make any difference. And since I don't know how to disable the original network manager, both are active in my upper toolbar. Once I am disconnected during a session, it seems the ONLY way to reconnect is to completely restart my computer. Otherwise I get a "bad password" error, even with the correctly stored passwords used to log me in originally.

Please help! This could be a Linux dealbreaker :? !!

I'm on Mint 12 with an old Dell Latitude D610 Laptop. Any other info you need I will gladly provide, please keep in mind, you may have to help with instructions on how to get such info.

Thanks in advance!! :mrgreen:

User avatar
vanDoom
Level 1
Level 1
Posts: 47
Joined: Sun Feb 26, 2012 7:25 pm
Location: USA

Re: My wireless keeps dropping!!

Post by vanDoom » Sat Mar 03, 2012 10:58 am

I don't have a definitive answer, but I can certainly empathize. Being a new user, these will be of good use

http://tldp.org/LDP/intro-linux/html/index.html
http://tldp.org/LDP/GNU-Linux-Tools-Sum ... index.html

Are you able to open a terminal? Go ahead and try:

Code: Select all

cd .gnome2/keyrings
sudo rm -rf login.keyring user.keyring
sudo reboot
This will delete the password access requirement for your wireless (from your system, not the wireless security :wink:); when you reboot it will ask you to re-enter them, but leave them blank! Even when asks if you are sure, say yes. See how that works out for you.

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Sat Mar 03, 2012 11:08 am

I don't think the removal of the password is really helpful. This sounds more like a driver issue.

Please open a terminal, run this command and paste the output:

Code: Select all

inxi -N
Edit: sorry, that was the wrong command... inxi -Gx of course tells about graphics instead of network.
Last edited by AlbertP on Sat Mar 03, 2012 2:32 pm, edited 1 time in total.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sat Mar 03, 2012 12:13 pm

Thanks so much for both prompt replies. Here's the terminal output:

diana@diana-Latitude-D610 ~ $ inxi -Gx
Graphics: Card: ATI M22 [Mobility Radeon X300] bus-ID: 01:00.0
X.Org 1.10.4 drivers ati,radeon unloaded: fbdev,vesa Resolution 1024x768@60.0hz
GLX Renderer Gallium 0.4 on ATI RV370 GLX Version 2.1 Mesa 7.11 Direct Rendering Yes
diana@diana-Latitude-D610 ~ $

User avatar
vanDoom
Level 1
Level 1
Posts: 47
Joined: Sun Feb 26, 2012 7:25 pm
Location: USA

Re: My wireless keeps dropping!!

Post by vanDoom » Sat Mar 03, 2012 1:02 pm

It will be useful to know what kind of wireless card you have, so please post the output from

Code: Select all

sudo modprobe -l | grep ipw
Can you also take a screenshot if the 'bad password' comes up again? Meanwhile, instead of restarting, why don't you try

Code: Select all

sudo ifconfig wlan0 down
sudo ifconfig wlan0 up
to restart the wifi.

AlbertP, are you assuming a timing issue, leading you to suspect drivers? The 'bad password' information seems more like a failure to renew a DHCP lease.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sat Mar 03, 2012 2:01 pm

vanDoom wrote:It will be useful to know what kind of wireless card you have, so please post the output from

Code: Select all

sudo modprobe -l | grep ipw

Here's the output:
diana@diana-Latitude-D610 ~ $ sudo modprobe -l | grep ipw
[sudo] password for diana:
kernel/drivers/tty/ipwireless/ipwireless.ko
kernel/drivers/net/wireless/ipw2x00/ipw2100.ko
kernel/drivers/net/wireless/ipw2x00/ipw2200.ko
kernel/drivers/net/wireless/ipw2x00/libipw.ko
kernel/drivers/usb/serial/ipw.ko
diana@diana-Latitude-D610 ~ $

I will try & take a screenshot of "bad password", and then try your command suggestion rather than restart when wifi drops. Thanks again for your help!

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Sat Mar 03, 2012 2:34 pm

Oops, sorry, I posted a wrong command. Instead of inxi -Gx which gave graphics data, I meant:

Code: Select all

inxi -N
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sat Mar 03, 2012 3:19 pm

AlbertP wrote:Oops, sorry, I posted a wrong command. Instead of inxi -Gx which gave graphics data, I meant:

Code: Select all

inxi -N
no problem, here ya go:

diana@diana-Latitude-D610 ~ $ inxi -N
Network: Card-1 Broadcom NetXtreme BCM5751 Gigabit Ethernet PCI Express driver tg3
Card-2 Intel PRO/Wireless 2915ABG [Calexico2] Network Connection driver ipw2200
diana@diana-Latitude-D610 ~ $

User avatar
vanDoom
Level 1
Level 1
Posts: 47
Joined: Sun Feb 26, 2012 7:25 pm
Location: USA

Re: My wireless keeps dropping!!

Post by vanDoom » Sat Mar 03, 2012 6:09 pm

I think the answer lies here:

http://manpages.ubuntu.com/manpages/har ... iwi.4.html

however I'm on Mint 12 and it seems my loader.conf and kernel .config are not where I'd expect :shock: ...I'll keep looking though

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sun Mar 04, 2012 1:09 am

ok, update~

I didn't try that last bit of info yet because as Murphy's Law would have it, my wireless was doing pretty well today, and I thought maybe somehow by typing those commands it fixed itself, but no such luck. It just went out again. But here are the screen shots as requested.

You will notice first that my wireless was "unavailable" I had to turn it off and then on again in order for it to find my router, but it wouldn't connect, then the password error messages. I tried with both network managers.

I also tried the commands to get back online from the terminal, but no luck there either. Had to reboot. Screenshot attached.

Thanks again to everyone for their help!
Attachments
Workspace 1_005.jpeg
Workspace 1_005.jpeg (105.22 KiB) Viewed 1570 times
Workspace 1_003.jpeg
Workspace 1_003.jpeg (87.86 KiB) Viewed 1570 times
Workspace 1_002.jpeg
Workspace 1_002.jpeg (98.21 KiB) Viewed 1570 times

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sun Mar 04, 2012 1:11 am

It only let me post 3 attachments, here's the last one
Attachments
Workspace 1_006.jpeg
Workspace 1_006.jpeg (89.27 KiB) Viewed 1569 times

chipbuster
Level 4
Level 4
Posts: 238
Joined: Wed Feb 08, 2012 1:34 am

Re: My wireless keeps dropping!!

Post by chipbuster » Sun Mar 04, 2012 5:26 am

whoa, you don't have a wlan0 interface o.0

Not neccesarily bad, but certainly unusual. Can you post the output of

Code: Select all

sudo ifconfig
sudo iwconfig
for us? That'll help figure out what interfaces you do have available to you.

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Sun Mar 04, 2012 8:10 am

It happens sometimes that the wifi interface is not named wlan0 but wlan2 or eth1. This depends on the wifi driver used, IIRC ipw2200 uses eth names instead of wlan0 (I'm having an old laptop which has a 2200 card, seem to recall that eth1 was used for wifi on that computer).
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sun Mar 04, 2012 9:14 am

wow, you guys are great...I go to sleep for a few hours, and wake up to more help! Thank you!!

screenshot attached
Attachments
Workspace 1_008.jpeg
Workspace 1_008.jpeg (114.31 KiB) Viewed 1552 times

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Sun Mar 04, 2012 11:20 am

These outputs look like you're just connected to the network named AIW52. Intel wifi cards generally work well with Mint, especially the older generations; I've never seen any complaint about the 2915 card.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sun Mar 04, 2012 11:43 am

AlbertP wrote:These outputs look like you're just connected to the network named AIW52. Intel wifi cards generally work well with Mint, especially the older generations; I've never seen any complaint about the 2915 card.
Thanks AlbertP,

Yes I am on AIW52 now, but I've been on other newtworks with the same dropping issue. The Intel wifi card 2915 you mentioned, I assume that is NOT what I have, but one that you are recommending? I'm sorry, the outputs are greek to me :)

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Sun Mar 04, 2012 12:04 pm

I didn't recommend anything. Your card is listed as an Intel 2915 in the inxi -N output you gave.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

yinyang37
Level 1
Level 1
Posts: 12
Joined: Fri Mar 02, 2012 11:40 pm

Re: My wireless keeps dropping!!

Post by yinyang37 » Sun Mar 04, 2012 2:08 pm

I'm sorry AlbertP, I misunderstood. So if my card should be ok, any other suggestions? I really appreciate everyone's input and patience with my attempts to learn.

User avatar
vanDoom
Level 1
Level 1
Posts: 47
Joined: Sun Feb 26, 2012 7:25 pm
Location: USA

Re: My wireless keeps dropping!!

Post by vanDoom » Tue Mar 06, 2012 10:46 am


AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: My wireless keeps dropping!!

Post by AlbertP » Tue Mar 06, 2012 3:58 pm

iwi is a driver for BSD & Solaris, instead of Linux. It won't help you much. Linux's ipw2200 should just work here. This is really the first time I see somebody having connection problems with Intel 2xxx.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Newbie Questions”