Formatting SATA drive

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 11
Joined: Sun Jan 13, 2008 3:21 am

Formatting SATA drive

Postby Kommy000 » Wed Feb 27, 2008 12:00 pm

Ok Im still new to this. I have linux mint 4.0 gnome edition running fine on my IDE hard drive. I'm using this pc as a media center. I'm still new to this and I managed to get everything running fine mostly without using terminal commands.
Now I was using also external hard drive but after putting bunch of movies on it after 2 months it crashed so instead of new external I decided to get a new SATA internal drive about 320 gigs since I never really had any problems with internals. I've installed internal SATA drive with no problems. My bios recongnizes it and recognizes my IDE drive too with Linux OS on it too.
After I start the PC and my linux desktop comes on I check for my SATA drive and its nowhere to be found. Gparted software for some reason never worked for me it just hangs, so I tried using QTparted and it would not find my hard drive. So I thought about it and opend terminal and typted in sudo qtparted and now it found it. I created partition on sda drive as a primatry in ext3 format and formatted it.
Now when I browse my folders I see my new drive, but now for some reason my SATA drive is read only or it tells me root read and write but if I sudo myself it shows as owner unknown and read only. If I try to change permissions it will not let me. I can not create any folders nothing. What the heck is going on? I'm just trying to install extra drive have it formatted and just use it with my user. I do not want to login onto it as root every time I have to use it and also its not working under root anyway.
Can anybody explain in plain english to me what am I supposed to do. Do I have to use terminal to formatt stuff and how do I do it.
Seems like I can't find GUI application to assign my user rights to that hard drive if that fixes the problem?
I remember having same problems with my external drive and I ended up booting off the live cd and using qtparted from KDE live cd to format my external drive to make it work but then it was giving me same permission problems,so I installed qtparted and did it locallly and it worked but this time I still have problems with permissions or using my SATA drive.
Please help or I just gonna have a brand spanking new SATA drive sitting with nothing on it. There is got to be an easy way to install extra drive in linux. Thanks

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Formatting SATA drive

Postby Husse » Wed Feb 27, 2008 5:41 pm

Please don't write in one go all lines written to "the end", make few line breaks or so - it's very hard to read your post
What does sudo mean?
You temporarily become root....
So if you prepare a drive with sudo this drive gets owned by root
This has to be done properly regardless of operating system used - only it's done differently depending on what you use.
I see no reason why you could not use gparted - I admit I'm not quite happy with it, but it works
Does your new drive appear in fstab?
Post the content of /etc/fstab
There should be lines like this
# /dev/sda2
UUID=8cb04e6f-dee9-4de6-980e-d648eba537af /media/sda2 ext3 defaults 0 2

The best is to use
/dev/sda2 /media/sda2 ext3 defaults 0 2

Of course sda2 has to be adjusted to your needs
If it's there you may have to edit the line and change defaults to
If it's not there add such a line - the sdx can be found from gparted or any partitioning program
You also have to add a folder to each of the folders /dev and /media, like so
sudo mkdir /dev/sda2 (adjust to your needs)
Your post is so massive that I may have missed something
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Newbie Questions”

Who is online

Users browsing this forum: Bing [Bot], frmb, sdcougar, Seadreamer and 18 guests