Unable to start 'gnome-settings-daemon'

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Gone Mintal
Level 1
Level 1
Posts: 24
Joined: Tue Jan 22, 2008 10:48 am

Unable to start 'gnome-settings-daemon'

Postby Gone Mintal » Wed Feb 27, 2008 2:06 pm

I get this error a lot -
Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with Bonobo, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

Today, I got it when going to Control Center/Appearances to choose a GTK theme. I don't use KDE and don't know what could possibly be running that would be conflicting with it. Any ideas what I can do about it, please?

User avatar
clem
Level 15
Level 15
Posts: 5651
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: Unable to start 'gnome-settings-daemon'

Postby clem » Wed Feb 27, 2008 2:19 pm

Hi,

We've been having this problem since the very first releases of Linux Mint and I've seen it happened on other gnome distros too (even RPM ones). It doesn't happen often and usually you can just restart Gnome for it to go away. It seems to happen "sometimes" particularly when the system is run from the liveCD or within a virtual machine.

If somebody finds a solution to this I'd be extremely happy to know about it, why it happens and how to make it not happen again.

Clem.
Image

Gone Mintal
Level 1
Level 1
Posts: 24
Joined: Tue Jan 22, 2008 10:48 am

Re: Unable to start 'gnome-settings-daemon'

Postby Gone Mintal » Wed Feb 27, 2008 4:02 pm

I'm not running from a cd or from a virtual machine, but it doesn't sound like I need to worry about it too much if just restarting Gnome will work. How do I restart Gnome without rebooting the computer? Will ctrl/alt/bckspce do it?

clem wrote:Hi,

We've been having this problem since the very first releases of Linux Mint and I've seen it happened on other gnome distros too (even RPM ones). It doesn't happen often and usually you can just restart Gnome for it to go away. It seems to happen "sometimes" particularly when the system is run from the liveCD or within a virtual machine.

If somebody finds a solution to this I'd be extremely happy to know about it, why it happens and how to make it not happen again.

Clem.


Return to “Newbie Questions”

Who is online

Users browsing this forum: Fred Barclay, Jute and 11 guests