Howto: setting up Beryl on Linux Mint

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
User avatar
Alephcat
Level 3
Level 3
Posts: 131
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester
Contact:

Howto: setting up Beryl on Linux Mint

Post by Alephcat »

Edit:this post is now fairly out of date, I will leave it here for users of old versions of mint, but there is now a version of it with updates in the mint wiki here.

First open a terminal, you will not need it yet, but you will need it in a minute.
Now open mintMenu and go to Administration > Software Sources, when that has opened go to the “Third Partyâ€￾ tab and click on the “Addâ€￾ button. Copy and paste the following sources in the box that pops up one at a time.

Code: Select all

deb http://ubuntu.beryl-project.org/ edgy main
deb-src http://ubuntu.beryl-project.org edgy main
(only add the next one if you want unsupported experimental packages)
deb http://3v1n0.tuxfamily.org edgy beryl-svn
After adding those but before closing the Software Sources window change to the terminal and copy and paste the following command (it does not have to be done this way but it does stop it complaining when you close the window)

Code: Select all

sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | apt-key add -
if you added the experimental packages do the same with the next command

Code: Select all

sudo wget http://3v1n0.tuxfamily.org/DD800CD9.gpg -O- | apt-key add -
Once you have done that close the software sources and it will automatically update the package list for you.
Next type the following command in to the terminal

Code: Select all

sudo gedit /etc/X11/xorg.conf
this will launch a text editor and open your xorg.conf file in it scroll down until you find the Section “Moduleâ€￾. You need to check that the following lines are there and not prefixed with a '#' symbol.

Code: Select all

Load "dri"
Load "dbe"
Load "glx"
Next scroll down until you find the Section “Deviceâ€￾ for your graphics card and add the following line to the end of the section.

Code: Select all

Option  "XAANoOffscreenPixmaps"
Then add the following sections at the end of the file if they do not exist anywhere else in it.

Code: Select all

Section "DRI"
        Mode 0666
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection
Finally save the file and close the editor.
You now need to restart the X-server by pressing Ctrl+Alt+Backspace after closing any open windows.
When you have logged back in open a terminal and type

Code: Select all

sudo aptitude install beryl
which will install the latest version of beryl along with all recommended packages which include themes and some plugins.
Once that has finished installing type

Code: Select all

beryl-manager
to start beryl and the beryl manager.
Once beryl has started go to mintMenu > Preferences > Sessions and click on the “Startup Programsâ€￾ tab, once there click the add button and type

Code: Select all

/usr/bin/beryl-manager
this will make the beryl manger start every time you login.
Last edited by Alephcat on Wed Sep 19, 2007 4:50 am, edited 1 time in total.
"To absent friends, lost loves, old gods, and the season of mists; and may each and every one of us always give the devil his due."
User avatar
Alephcat
Level 3
Level 3
Posts: 131
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester
Contact:

Post by Alephcat »

what do you mean by "no window bar"? Do you mean the bar at the top of the window, or the "start bar" at the bottom of the screen?
"To absent friends, lost loves, old gods, and the season of mists; and may each and every one of us always give the devil his due."
User avatar
JohnH
Level 4
Level 4
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Post by JohnH »

Hi there,

I followed your How To and to my surprise, I've wiped X.

Gone into recovery and running nano /etc/x11/xorg.conf gives me a blank nano screen. Going to the dir it says no x11 directory. Now I'm stuffed, unless you have a solution (like something with nano or dir I'm not getting).

Regards
John
User avatar
JohnH
Level 4
Level 4
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Post by JohnH »

Its okay, dn't panic John.

x wouldn't start so I:

1) ctrl+alt+F1 This gave me a command line and login option.

2) after logging in

sudo dpkg-reconfigure xserver-xorg

I'm back on the desktop but I'm not sure my setting are right.

Ah well, that will teach me for fooling around.

Cheers
John
User avatar
Alephcat
Level 3
Level 3
Posts: 131
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester
Contact:

Post by Alephcat »

I have just worked out what you did wrong with the nano edit (I just made the same mistake myself :oops: ) you typed /etc/x11/xorg.conf instead of /etc/X11/xorg.conf case is important in Linux. that may also be the reason installing beryl did not work for you, but I assume you got something in the file when you edited it the first time.
"To absent friends, lost loves, old gods, and the season of mists; and may each and every one of us always give the devil his due."
antiquexray
Level 5
Level 5
Posts: 604
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Re: Howto: setting up Beryl on Linux Mint

Post by antiquexray »

Well, I'm 0 for 2. I had and unfavorable result trying to get CNN and BBC video, and now following Alephcat's instructions for installing Beryl (using cut and paste) I hosed my system. It was a simple fix though, I just reloaded Bianca. I'm getting pretty good at doing that, but all these updates are starting to drive me batty.

I guess me using older systems as test beds is why I'm have trouble when others aren't...and believe me, I learn something every time and blame no one. I can't help believe that if I knew more it wouldn't have happened in the first place or I would have been able to reverse the problem without having to reload.
User avatar
JohnH
Level 4
Level 4
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Post by JohnH »

Yes,

I did the cut and paste too, and it trashed my X. I went to the file and could not see anything that was out of the ordinary so I gave it another go; same result. I'll sit on the sidelines and watch the game until nearly fulltime.

Regards
John
User avatar
OzTracker
Level 1
Level 1
Posts: 10
Joined: Sun Dec 17, 2006 12:50 am

Post by OzTracker »

Many thanks for the how-to Alephcat. Worked perfectly for me.

The only thing I changed was to copy my xorg.conf first before editing. Screwed up my system too many times by not doing that beforehand :lol:
User avatar
Alephcat
Level 3
Level 3
Posts: 131
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester
Contact:

Re: Minor additons to main instructions

Post by Alephcat »

muncrief wrote: First, to import the beryl key I had to add "sudo" before the apt-key command or a "missing key ring" error would be reported. So the command that worked is:

sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
I initially did it like that but then found that I did not need the second sudo, I assume it must depend on your setup.
drum
Level 1
Level 1
Posts: 18
Joined: Thu Dec 21, 2006 7:55 am
Location: Australia

Life with beryl

Post by drum »

Hi, I followed Alephcat's instructions to the T and beryl worked fine till reboot then the beryl logo came up waving for a couple of seconds OK but the desktop was frozen. No option but to hit the reset button.
I tried rebooting into the Failsafe Gnome option and it was the same except for an error box telling me "there was an error starting the GNOME Settings Daemon"

So close and yet so far, methinks.
Any ideas will be appreciated
Thanks
User avatar
kiwiboyus
Level 1
Level 1
Posts: 22
Joined: Sun Dec 31, 2006 10:06 pm

Post by kiwiboyus »

I'm trying to get Beryl up and running on my laptop again after doing a clean install of Bianca but when I start Beryl through the terminal I get the following message "libGL warning: 3D driver claims to not support visual 0x5b"

It's odd because I never had any trouble running Beryl on Bea. My laptop has the Intel 945GM chip set. I'm going to see if I need to update my Intel drivers but any feed back would be welcome.
mfab
Level 1
Level 1
Posts: 22
Joined: Mon Feb 12, 2007 4:50 pm

Post by mfab »

hi there,

I also followed this tutorial (in fact it was not this one but the one from the beryl site, which seems to have the same content).

but instead of the modules:
Load "dri"
Load "dbe"
Load "glx"

i have the modules
Load "dri"
Load "vbe" #("v" not "d" ???!!!)
Load "glx"

As i have no idea what kind of modules these are i just thought i might try it without changing the "vbe" to "dbe" and guess what: it worked nontheless. :wink:

What is the difference in this?
maximus659
Level 1
Level 1
Posts: 8
Joined: Mon Feb 05, 2007 4:52 pm

Post by maximus659 »


drum
Level 1
Level 1
Posts: 18
Joined: Thu Dec 21, 2006 7:55 am
Location: Australia

Post by drum »

Hi, I added the repos as per instructins and then got this when getting the key.
Please help
Regards

sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | apt-key add -
--12:13:59-- http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg
=> `-'
Resolving ubuntu.beryl-project.org... 195.114.19.35, 82.140.42.54, 88.191.250.18, ...
Connecting to ubuntu.beryl-project.org|195.114.19.35|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,415 (2.4K) [application/octet-stream]

100%[====================================>] 2,415 --.--K/s

12:14:00 (319.05 KB/s) - `-' saved [2415/2415]

gpg: no writable keyring found: eof
gpg: error reading `-': general error
gpg: import from `-' failed: general error
mfab
Level 1
Level 1
Posts: 22
Joined: Mon Feb 12, 2007 4:50 pm

Re: Beryl not installing on Bianca

Post by mfab »

lvshankar wrote:I tried everything as posted by Alephcat. The only change I made was to try sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add - instead of what was given initially, because I got a general error.
But after restart :
$ sudo aptitude install beryl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Building tag database... Done
Couldn't find any package whose name or description matched "beryl"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.

why?????? :shock:

~LVS
it seems there is no package "beryl" available, you should install "beryl-manager" and all its recommended packages ! or use "aptitude install beryl-manager" which will install the recommendations automatically.

anyone some infos on my upper post concerning the modules (vbe or dbe)?

greets mfab
maximus659
Level 1
Level 1
Posts: 8
Joined: Mon Feb 05, 2007 4:52 pm

Post by maximus659 »


GoldNugget
Level 1
Level 1
Posts: 24
Joined: Mon Jan 01, 2007 6:51 pm

No title bars in Beryl

Post by GoldNugget »

I had a similar problem as the one described above. After scouring the forums and trying several things, I found this entry and it did the trick:
http://ubuntuforums.org/showthread.php?t=369703 (bottom of the page):

"I had the exact same problems.
a) There were no maximize and minimize buttons/titlebars.
b) Clicking on a new theme in Emerald Manager did nothing.
I asked on the forums and someone posted this response and it WORKED!!!

Quote:
If you have a nvidia card and if you are using the non-opensource drivers, run this command.
Code:

Code:

sudo nvidia-xconfig --add-argb-glx-visuals

Then hit <CTRL><ALT><Backspace> and log back in again. That should fix your problem.
Hope this fixes your problem. If not, there are some other suggestions in the thread: http://ubuntuforums.org/showthread.php?t=367850 "
User avatar
cedenburn
Level 1
Level 1
Posts: 4
Joined: Wed Nov 22, 2006 9:42 pm

Howto: setting up Beryl on Linux Mint

Post by cedenburn »

Went thru all of the suggestions and this what I get when I start Beryl-Manager

garbage.

but I can ctrl+alt+backspace and recover

Laptop = Presario R3210
Video = Nvidia = GForce4 420 Go 32meg
Driver = 1.0.8776
carlos
Level 4
Level 4
Posts: 470
Joined: Thu Dec 14, 2006 4:30 pm
Location: USA
Contact:

Post by carlos »

Hey cedenburn I have a geforce 440 GO on my laptop this is a quote from another post of what I did, try it and hopefully it can help:
carlos wrote:Well it looks it didn't work for me. I have Bianca installed on a dell inspirion laptop that has a nvidia "geforce4 440 GO" video card. It requires the legacy driver.

I used Alberto Milone's guide to manually install the driver. Just make sure to go to "point 7 of the PROBLEMS SECTION" and follow the additional instructions there.

http://www.albertomilone.com/latest_nvi ... _edgy.html

Also I installed beryl but had to make sure that options were specified before beryl was even started. Goto the beryl icon right click and on the menu under advanced > beryl options > Rendering Platform > Force nvidia. Otherwise the screen was completely garbled.

So far it been running well, but it is a tad slower when compared to my desktop. I think with a bit of tweaking I can solve this problem.
____________ ________ ______ ____ ___ __ __ _
http://www.designdrifter.com
The Purpose of Life is for DNA to reproduce.
User avatar
Alephcat
Level 3
Level 3
Posts: 131
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester
Contact:

Post by Alephcat »

the issue with games (and anything that trys to display full screen) is an issue with Beryl, not sure if/when it is going to be fixed but at least they allow you to switch back to a non-3D one easily now.
"To absent friends, lost loves, old gods, and the season of mists; and may each and every one of us always give the devil his due."
Post Reply

Return to “Tutorials”