Wireless disconnects frequent on LM 17.2

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 48
Joined: Thu Jul 30, 2015 3:22 pm

Wireless disconnects frequent on LM 17.2

Post by renzor »

thank you
Last edited by renzor on Sun Sep 20, 2015 4:22 am, edited 1 time in total.
User avatar
Level 22
Level 22
Posts: 15765
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)

Re: Wireless disconnects frequent on LM 17.2

Post by Pjotr »

You might try this how-to for the RTL8723BE chipset, which is probably closely related (obviously, replace every instance of "rtl8723be" by "rtl8723ae"):
https://sites.google.com/site/easylinux ... BE-chipset
(item 3, left column)
Tip: 10 things to do after installing Linux Mint 20 Ulyana
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
Level 1
Level 1
Posts: 1
Joined: Tue Sep 01, 2015 4:42 am

Re: Wireless disconnects frequent on LM 17.2

Post by trevorreznik »


I got the same problem and it is not related to 17.2 because I had it with previous version, too. When you search the internet you will see that many people seem to have similar problems with this chipset. There are a few suggested solutions but none of them worked for me. I think there is a big problem with the chipset driver.

For me that current situation is like this:
* Connection to wi-fi is established quickly
* Connection quality is normal
* Speed seems to have a huge latency and is very slow (around 10kb/s)
* After 1 minute no data is transmitted anymore
* After 2 minutes the connection is lost and re-established immediately

I have played with /etc/modprobe.d/RTL8723AE.conf some time ago and managed to get a good improvement (up to 40Mbit/s data transfer). Unfortunately, this only worked for 2 minutes. Then the connection was lost again and I never got this speed again.

All solutions that are suggested on the Internet seem to not have a clue what the real problem is. They just seem to try some things out. :-(

Any help to find out what is going wrong and how to fix this is appreciated very much!
Post Reply

Return to “Wireless”