Betsy boot now fails w/ dm-raid45 not found

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
kurtking
Level 1
Level 1
Posts: 39
Joined: Thu Aug 02, 2012 9:51 am

Betsy boot now fails w/ dm-raid45 not found

Post by kurtking »

Installed the LMDE2 MATE x64 Aug 8, '15 (downloaded and MD5 checked a week earlier) into my Abit AG8 machine as sda1 w/ 3 GB, and GRUB2, leaving LM13 (sda5), and XP (sdb1). It ran fine as my spare machine - used occasionally. Until now. The boot stops with "modprobe: module dm-raid45 not found in modules.dep" and a blinking cursor. I've never used raid. How can I get past this?

LM13 and XP are bootable. FWIW, I just noticed (in Disk Utility) on a 3rd drive, 3TB, a warning message says its partition is misaligned by 3072 bytes.

Thanks for any help.

kurtking
Level 1
Level 1
Posts: 39
Joined: Thu Aug 02, 2012 9:51 am

Re: Betsy boot now fails w/ dm-raid45 not found

Post by kurtking »

The issue is now clearly, why did it start (!) looking for the obsolete (or non-existent) module dm-raid45? - in a never raided machine? The modules.dep file is identical to that of a separate new install from the same iso - line 1740 of each defining the dependencies of dm-raid.ko where the first entry is raid456.ko and the line 1717 defining the dependencies of raid456.ko. Neither file contains a reference to raid45.

Laurent85
Level 16
Level 16
Posts: 6832
Joined: Tue May 26, 2015 10:11 am

Re: Betsy boot now fails w/ dm-raid45 not found

Post by Laurent85 »

Debian Bug report #745697 https://bugs.debian.org/cgi-bin/bugrepo ... bug=745697
Try to remove dmraid package:

Code: Select all

sudo apt-get purge dmraid
sudo update-initramfs -u
Image

kurtking
Level 1
Level 1
Posts: 39
Joined: Thu Aug 02, 2012 9:51 am

Re: Betsy boot now fails w/ dm-raid45 not found

Post by kurtking »

Thanks you Laurent85 for the bug report link. Although my problem went away when I re-installed lmde2, while doing so I saw the message flash a couple of times (in separate attempts to get it to work in an external USB drive box), but it didn't abort it.

Post Reply

Return to “Installation & Boot”