Grub showing wrong version of Mint

Forum rules
Before you post please read how to get help
Post Reply
cottfcfan
Level 4
Level 4
Posts: 263
Joined: Tue Jun 16, 2009 7:32 am
Location: Hull, England.

Grub showing wrong version of Mint

Post by cottfcfan » Sat Jan 09, 2016 9:56 am

Just upgraded kde from Mint 17.2 to 17.3. Everything went smoothly.
One slight glitch, is that the grub menu still says I'm on 17.2.
Not a real issue but wondered if it's easy to put right.
Tried sudo update-grub, to no effect.
The strange thing is that my xubuntu install on the same machine sees it as 17.3.
Any ideas?

GeneBenson
Level 4
Level 4
Posts: 342
Joined: Fri Sep 17, 2010 9:55 pm

Re: Grub showing wrong version of Mint

Post by GeneBenson » Sun Jan 10, 2016 3:50 am

Hi cottfcfan,

I had the same thing and "sudo update-grub" also didn't fix it. This did:

As root edit the file: /etc/grub.d/10_linux
Find the line: OS="Linux Mint 17.2 ..." and change 17.2 to 17.3 and save the file. Then in a terminal enter: sudo update-grub.
When done, reboot, and check the grub menu.

Hope this helps. :D

Paladin2019
Level 2
Level 2
Posts: 60
Joined: Tue Sep 16, 2014 2:31 pm

Re: Grub showing wrong version of Mint

Post by Paladin2019 » Sun Jan 10, 2016 6:58 am

GeneBenson wrote:Hi cottfcfan,

I had the same thing and "sudo update-grub" also didn't fix it. This did:

As root edit the file: /etc/grub.d/10_linux
Find the line: OS="Linux Mint 17.2 ..." and change 17.2 to 17.3 and save the file. Then in a terminal enter: sudo update-grub.
When done, reboot, and check the grub menu.

Hope this helps. :D
I use Grub Customizer so before I did this I had to click the 'Revert' button in GC's 'list' tab to remove its custom proxy scripts and restore the 10_linux file.

Once that was done I updated the line as above, did update-grub then reapplied my custom settings in GC. All's well.

Post Reply

Return to “KDE”